Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can't change thumbnail icons for .ASM, and .INC files.


  • Please log in to reply
5 replies to this topic

#1 codyw1996

codyw1996

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:01:10 AM

Posted 07 January 2018 - 02:45 PM

.ASM, and .INC files are associated with NotePad++ yet the file icons are not changing.

They are stuck with either the notepad, or wordpad icon, not sure which it is. 

All settings are set up correctly. (see included image attachment)

 

In folder options there are two options "Always show icons, never thumbnails", and "Display file icon on thumbnails".

In the image they are unchecked, but checking them and refreshing the folder view does not fix the issue.

I want the icon for notepad++ (seen at the bottom of the image) to appear on the .ASM and .INC file thumbnails instead of a generic blank page icon/thumbnail image.

Attached Files


Edited by codyw1996, 07 January 2018 - 02:54 PM.


BC AdBot (Login to Remove)

 


#2 mightywiz

mightywiz

  • Members
  • 810 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:10 AM

Posted 08 January 2018 - 05:28 PM

your making this harder then it is!

 

right click on the shortcut then select properties.

in the popup you have at the bottom of the screen 3 buttons the middle one says "change Icon" then you can pick the new icon you want to change to.



#3 codyw1996

codyw1996
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:01:10 AM

Posted 14 January 2018 - 01:02 PM

Thanks for the reply, but that is not a solution to my problem.

 

Look again at the image.

Notice that .ASM and .INC files are not shortcuts.

Now notice that the .DAT files are also not shortcuts, yet they actually DO HAVE CUSTOM icons.

How did I set .DAT files to have the icon of the program Frhed? I changed the default program that opens .DAT files to Frhed. 

Why is that same process not working for .ASM and .INC files? 

 

Even if I set .ASM and .INC files to open with Frhed, their thumbnails alone do not change. 

It doesn't matter what program I specifiy, the thumbnails are stuck as generic blank notebook pages.

On the other hand, if I change .DAT files to open with Notepad++ the thumbnails change to the Notepad++ icon.

This proves that the issue is specifically with these two file types.

 

I should also mention that the files are actually opening with Notepad++, as they should. 

My issue is that the thumbnail just isn't changing. 

 

I have an old Windows XP machine, and my main machine is a windows 10 machine.

Neither of those machines have this issue. 

 

 I would appreciate some help with this problem, thanks.


Edited by codyw1996, 14 January 2018 - 01:21 PM.


#4 mightywiz

mightywiz

  • Members
  • 810 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:10 AM

Posted 15 January 2018 - 11:07 AM

your talking about file associations, and icon do change with what ever the file association is.

 

so if you have ever used "open with" and didn't uncheck the "always open with this program" it will associate that extension with the program and change the icon setting for every item with that extension to the programs icon.

 

I did read your message and I believe this is what is happening.

 

my explanation was to help change back to a different icon because of how things change automatically when you use the "open with" feature.



#5 codyw1996

codyw1996
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:01:10 AM

Posted 15 January 2018 - 07:49 PM

The files are set to always open with Notepad++.

I've never once opened a .ASM or .INC file with any other program.

 

I found some other recomendations online which suggest deleting the icon cache file, then refreshing the folder.

I tried this too, it didn't work.

 

As a final effort, I wiped a spare hard drive I had lying around and reinstalled windows 7.

Without changing any system settings, I installed Notepad++ and I associated .ASM files to it.

It worked fine, obviously i've broken something at some point by changing some system setting.

I have no idea what I could have possibly done to prevent Windows from properly changing the thumbnails of specific file types.

 

I've tried re-enabling all system services, re-enabling file indexing, among other things. Nothing works.

This is such a stupid problem, and I'm almost ready to give up.

It's not worth a system restore.


Edited by codyw1996, 15 January 2018 - 07:51 PM.


#6 Clonkex

Clonkex

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Northern Tablelands, NSW, Australia
  • Local time:05:10 PM

Posted 09 May 2018 - 08:30 PM

I had this issue as well (and I very much understand your frustration). After reading this answer on SuperUser I decided to search for "notepad++" in Regedit and see what I could find. I spammed my way through with F3 for a while until I came across this key:
 
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Applications\notepad++.exe
 
(At least, I think that was the name of the key; there's not many keys in the Applications key so you could just scroll through and see if you find one relating to Notepad++.) It contained a key called ExShell, which itself contained a key that said something about icons (I can't remember exactly what it was). I decided I could safely delete the notepad++.exe key because I could just reinstall NPP if it broke things. Lo and behold, I only had to press F5 in Explorer for the Notepad++ icons to reappear. Then I just used Disk Cleanup to delete the thumbnail cache so that folder thumbnails regenerated.
 
Actually it's possible I had to change the file association of a random file that normally opens with NPP to something else and back again, then refresh Explorer. Can't remember.
 
Given it's now May I assume you've probably reinstalled Windows by this point, but on the off-chance you're still struggling through without correct icons hopefully this helps you.
 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users