Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Do I need to reinstall my drivers?


  • Please log in to reply
1 reply to this topic

#1 stebbinsd

stebbinsd

  • Members
  • 261 posts
  • OFFLINE
  •  
  • Local time:12:57 AM

Posted 04 January 2018 - 07:49 AM

I recently swapped out an Geforce GTX 750ti for another Geforce GTX 750ti. The only difference is that the old one was manufactured by Asus and the newer one was manufactured by Evga.

 

Does that alone mean I should reinstall my drivers? Because right now, none of my games work! At all!

 

EDIT: In case this helps, this is what the Diplay tab of dxdiag says:

 

No_graphics_card_installed.png


Edited by stebbinsd, 04 January 2018 - 07:59 AM.

My current build:

 

Motherboard: Gigabyte GA-970A-UD3P
Processor: AMD FX-8350
RAM: 16GB (2x8GB DDR3)
Video Card: Geforce GTX 1070ti

OS: Windows 7 64-bit Ultimate


BC AdBot (Login to Remove)

 


#2 Allan

Allan

  • BC Advisor
  • 8,674 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:01:57 AM

Posted 04 January 2018 - 08:38 AM

Go to the EVGA website and download the correct drivers for your system. Then uninstall the old drivers and install the new ones.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users