Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Wireless unavailable - new install Linus Mint 18.3


  • Please log in to reply
1 reply to this topic

#1 zipple

zipple

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:09:07 PM

Posted 28 December 2017 - 06:12 PM

New to Linux. Installed Linus Mint Cinnamon 18.3 and it is  up and running,but my wireless is not working. I have searched the forums and done a couple things:

 

1) Checked driver manager - no drivers for wireless listed.

2) Ran both sudo apt-get update and sudo apt-get upgrade - still no drivers listed.

3) Ran inxi -Fz and this is what is showed:

 

System:    Host: TheMosSatellite Kernel: 4.10.0-38-generic x86_64 (64 bit)
           Desktop: Cinnamon 3.6.7  Distro: Linux Mint 18.3 Sylvia
Machine:   System: TOSHIBA (portable) product: Satellite E205 v: PSE20U-002001
           Mobo: TOSHIBA model: Portable PC
           Bios: INSYDE v: 1.20 date: 04/13/2010
CPU:       Dual core Intel Core i5 M 430 (-HT-MCP-) cache: 3072 KB
           clock speeds: max: 2267 MHz 1: 1199 MHz 2: 1333 MHz 3: 1199 MHz
           4: 1333 MHz
Graphics:  Card: Intel Core Processor Integrated Graphics Controller
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel Ironlake Mobile
           GLX Version: 2.1 Mesa 17.0.7
Audio:     Card Intel 5 Series/3400 Series High Definition Audio
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network:   Card-1: Qualcomm Atheros AR8152 v1.1 Fast Ethernet driver: atl1c
           IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Intel Centrino Advanced-N 6200 driver: iwlwifi
           IF: wlp2s0 state: down mac: <filter>
Drives:    HDD Total Size: 500.1GB (2.8% used)
           ID-1: /dev/sda model: WDC_WD5000LPVT size: 500.1GB
Partition: ID-1: / size: 451G used: 5.4G (2%) fs: ext4 dev: /dev/dm-0
           ID-2: /boot size: 472M used: 68M (16%) fs: ext2 dev: /dev/sda1
           ID-3: swap-1 size: 8.38GB used: 0.00GB (0%) fs: swap dev: /dev/dm-1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 52.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 208 Uptime: 10 min Memory: 835.9/7780.3MB
           Client: Shell (bash) inxi: 2.2.35

 

This shows my wireless state is "down". Does that mean a hardware problem or is there a way to change it to "up"? Tried ip link set wlp2s0 up command.

 

Any thoughts or help is greatly appreciated.



BC AdBot (Login to Remove)

 


#2 Gary R

Gary R

    MRU Admin


  • Malware Response Team
  • 801 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:07 AM

Posted 29 December 2017 - 01:13 AM

Outside my area of expertise here, so if it's anything more complex than this I probably can't help any further, but here's a quick check you can make to see if it's just that your Wi-Fi network card is just shut down.

 

Click on the network icon in the bottom right corner of your screen, and choose "Network Settings"

 

This will open the "Networking" window.

 

Select Wi-Fi in the left panel.

 

If it says "Wi-Fi Unavailable" in the top right of the Networking window, and the toggle switch to the right of that is set to "Off", set the toggle switch to "On"

 

You should now be able to see a list of Wireless Networks available.

 

If not, then you definitely have a problem.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users