Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Remote Access to FTP server not working


  • Please log in to reply
6 replies to this topic

#1 woodsie

woodsie

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:08:27 AM

Posted 16 December 2017 - 11:59 PM

Hi all

 

Trying to set up Remote Access to a NAS i have configured as an FTP server.

Works perfect inside the network over port 2121? But out side I can never get it to work.

 

I also have an FTP server set up on my Windows 10 Computer with Filezilla Server running on port 21 (Forwarded in router) and that runs perfectly inside and out side my network.

 

My NAS is a Dlink DNS 345

My router/modem is a Netgear DGN2200v4

 

Have tried port forwarding the correct ports but like i said cant get it to work outside network.

 

Any help would be much obliged.

 

Cheers Reuben



BC AdBot (Login to Remove)

 


#2 woodsie

woodsie
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:08:27 AM

Posted 18 December 2017 - 01:13 AM

There must be someone in here that has more knowledge of how this all works.....

 

Please help, seems I have tried everything and nothing works.

 

Cheers



#3 Replicator

Replicator

  • Members
  • 306 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Dark Basement
  • Local time:06:27 PM

Posted 18 December 2017 - 03:59 AM

On that router under advanced setup, you should have an area titled Remote Management.

 

Try enabling it and then setting your IP range for devices you wish to use to connect.

Remember to reconfig your FTP server to use the same port as listed on the RM address.

Don't use the routers default password and turn the feature off once you have configured the router remotely in order to be able to ping it successfully.

 

Disable any hardware and/or software firewalls configured until connection can be made

 

Only reason to try this is if you can connect to the router remotely, then it must be a port of firewall issue with the server! 


Edited by Replicator, 18 December 2017 - 04:16 AM.

The quieter you become, the more you are able to hear!
CEH, CISSP @ WhiteHat Computers Pty Ltd

 


#4 woodsie

woodsie
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:08:27 AM

Posted 18 December 2017 - 04:34 AM

Hi Replicator and thank you for you reply.

 

Have had remote management on the router enabled once before when I was working away from home and it seem to work fine.

I know this problem is a port problem, I get confused with the port number and range of ports....

 

I have read so many documents on how to set up FTP Servers and can mostly get it right but when it comes to anymore than 1 Server on my network I struggle as what ports to use.

 

On my windows ten laptop I have Filezilla server running and i can connect to that via Teamviewer App on my android phone and also from AndFTP on my phone no worries inside and outside my network, I have port 21 forwarded in router.

Inside my network I can connect my NAS which has FTP server enabled via ANDFTP on my phone just not outside my network.

Have tried to set ports up in the nas and forward them in router but no luck.

 

I'm pretty sure it's just incorrect ports I'm using. Like I said the ports are what confuse me, even after reading alot of documents on them.



#5 Replicator

Replicator

  • Members
  • 306 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Dark Basement
  • Local time:06:27 PM

Posted 18 December 2017 - 06:22 AM

Yeh, sounds either a port or IP address issue.

 

Are you trying to forward multiple ports on the router?

Some router port forwarding config's can be fussy when it comes to multiple ports forwarded.

 

This may sound crazy, but can you test port forwarding configuration by putting them in a more logical order, ie lowest port first - to highest in order?

 

Does initializing iPv4 instead of iPv6 help at all?

 

Have you tried a static IP for the server?

 

Just a thought.


Edited by Replicator, 18 December 2017 - 06:24 AM.

The quieter you become, the more you are able to hear!
CEH, CISSP @ WhiteHat Computers Pty Ltd

 


#6 woodsie

woodsie
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:08:27 AM

Posted 19 December 2017 - 01:52 AM

Hi Replicator.

 Yes all IP Address are set up static and reserved on router.

iPv4 only.

And as for testing port forwarding config, I wouldn't have a clue.

For my windows ten computer and filezilla server I have port forward like this:

ftp server->external port start 21->external port end 21 and same for internal start and ending ports and it works fine.

 

For the nas, I tried 2121 and it works fine inside network.

But under ftp setting in the nas i put the port as 2121.and then its got Passive mode setting and I have left it at its default port range of (55536-55663)

This may sound like a dum question but do I need to forward that port range as well in the router? And if I do does it need to be a separate rule to the 2121 forward?

 

Thanks Replicator



#7 Replicator

Replicator

  • Members
  • 306 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Dark Basement
  • Local time:06:27 PM

Posted 21 December 2017 - 05:05 AM

It is recommended to assign a fixed IP to your NAS for FTP. (Since you may need to open the ports of req services on your router and forward them to the LAN IP address of the NAS, so you do not want it to be changed under DHCP.)

This should be able to be done under network / tcp/ip settings within the browser interface for NAS.

Be sure to set the DNS server (router) address as well.

 

If your NAS is located behind the router, you need to open the ports of the services on the router, and forward these ports to the fixed LAN IP of the NAS.

When the router receives packets from the WAN side to the external port 21, the router will forward these packets to the LAN IP of the NAS.

To connect to your NAS at home, from WAN ( using WAN IP address), you can simply forward traffic coming from port 8080 (which should be the default management port) to the LAN IP you set for your NAS.

 

Not sure of your NAS brand, but here is a guide for QNAP


Edited by Replicator, 21 December 2017 - 05:14 AM.

The quieter you become, the more you are able to hear!
CEH, CISSP @ WhiteHat Computers Pty Ltd

 





2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users