Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Asus X552E Turns on but screen remains black (won't load Bios or windows)


  • Please log in to reply
1 reply to this topic

#1 laurdor

laurdor

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:07:38 AM

Posted 14 December 2017 - 02:08 PM

ASUS X552E 

3 years old

Specs:

cpu: AMD quad-core A4-5000 1.5GHz

memory: 6 gigs

hdd: 750 gb

odd: dvd sup.MTI.

OS: WIN10

 

When turned on screen remains totally black (does not light up at all). Unable to show windows, unable to show BIOS (safe mode) when prompted. Sometimes turns on completely when hard shut down and rebooted many times. No beep codes. Possible virus though, many pop-ups when windows is finally booted.


Edited by laurdor, 14 December 2017 - 02:10 PM.


BC AdBot (Login to Remove)

 


#2 OldPhil

OldPhil

    Doppleganger


  • Members
  • 4,157 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Long Island New York
  • Local time:08:38 AM

Posted 14 December 2017 - 03:42 PM

This may or may not help, remove the battery then hold the button down for at least 30 seconds.  Reinstall battery and give it a try.


Honesty & Integrity Above All!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users