Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

no sound in aisleriot


  • Please log in to reply
7 replies to this topic

#1 placemat

placemat

  • Members
  • 45 posts
  • OFFLINE
  •  
  • Local time:01:08 AM

Posted 02 December 2017 - 04:03 AM

Hi Everyone, I am using Linux Mint Cinnamon 18.3, 64 bit and I have the system sounds, and sound from videos on youtube but I like to play aisleriot and it is has no

 

sound, and it is not listed in it's menu.

 

The file is under /usr/share/aisleriot/sounds and it lists the sounds click.ogg slide.ogg splat.ogg and victory.ogg

 

I am just wondering is there is some way I can get the sound to work in the terminal, and I am no expert with Linux.

 

Everything else works really well. Pulse Audio is installed and Alsa Mixer, and I do not have experience with either of these.

 

 



BC AdBot (Login to Remove)

 


#2 Al1000

Al1000

  • Global Moderator
  • 7,710 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:02:08 PM

Posted 02 December 2017 - 09:49 AM

Hi, try these commands:
xplayer /usr/share/aisleriot/slide.ogg
vlc /usr/share/aisleriot/slide.ogg
The slide.ogg file should play in different media players when you run these commands. Does that happen?

Edited by Al1000, 02 December 2017 - 09:49 AM.


#3 placemat

placemat
  • Topic Starter

  • Members
  • 45 posts
  • OFFLINE
  •  
  • Local time:01:08 AM

Posted 02 December 2017 - 04:11 PM

Hi AI1000, Thank you for your reply. The sounds do play when I right click on them, from the file, and open with Media Player.

 

I had errors with both commands.

 

Xplayer-WARNING**.xplayer-rotation-plugin.vala.163 Could not query file attribute:Error when getting information for file:No such file or directory

 

VLC is unable to open the MRL 'file':///usr/share/aisleriot/slide.ogg. Check the log for details.



#4 placemat

placemat
  • Topic Starter

  • Members
  • 45 posts
  • OFFLINE
  •  
  • Local time:01:08 AM

Posted 02 December 2017 - 05:08 PM

Hi again, I opened VLC Media Player, under Media I clicked open file, and the sounds for the game will play in the media player.



#5 Al1000

Al1000

  • Global Moderator
  • 7,710 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:02:08 PM

Posted 08 December 2017 - 01:43 PM

Hi,

I've been researching this mysterious issue, and thought I'd let you know what I discovered.

I installed aisleriot in a laptop that runs Mint 18 Cinnamon, and have the same problem. Apparently lack of sound in aisleriot has historically been an issue in previous versions of Linux Mint. There were workarounds involving installing Ubuntu packages, for some earlier versions of Mint, but none that I can find for version 18.

I also installed aisleriot in my desktop pc which runs Debian 8.9, and sound works just fine. There is a sound option under the "Control" tab, which is missing in aisleriot in Mint.

If I do find a solution, I'll post it here.
Please do the same should you find a solution elsewhere. :)

#6 placemat

placemat
  • Topic Starter

  • Members
  • 45 posts
  • OFFLINE
  •  
  • Local time:01:08 AM

Posted 08 December 2017 - 03:48 PM

Hi AI1000, Thank you for going to the trouble, and trying to find solutions. I have also looked everywhere and have not found and answer. I also tried Linux Mint Mate 18 and it does have the

 

sound option in the aisleriot menu, and works, but with Mate 18 you can have the problem of no startup sounds, and it is not a big deal as I do really like Linux Mint Cinnamon, and if I do come

 

across a solution I will let you know. Thank you again.



#7 nema32

nema32

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:06:08 AM

Posted 16 February 2018 - 02:34 AM

Probably using cinnamon display manager is the reason.  I use a login script that enables event sounds, and that fixes the issue.

#for cinnamon, turn on event sounds. dconf-editor doesn't retain true
if [ "$XDG_CURRENT_DESKTOP" = "X-Cinnamon" ]; then
  gsettings set org.cinnamon.desktop.sound event-sounds true
fi



#8 placemat

placemat
  • Topic Starter

  • Members
  • 45 posts
  • OFFLINE
  •  
  • Local time:01:08 AM

Posted 16 February 2018 - 02:53 AM

Hi nema32, Thank you so much. I just ran your script and now have the game sounds, very much appreciated.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users