Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


BSOD while loading ARK

  • Please log in to reply
1 reply to this topic

#1 Anron311


  • Members
  • 53 posts
  • Local time:01:03 AM

Posted 23 November 2017 - 12:09 PM

Not sure if this is the right forum for this so I apologize if it isn't. But I've been getting atikmpag.sys BSOD when I try to load ARK, then after reboot when I go to load it again it loads and plays no issues. No idea why it's doing this but it is only with ARK. Any help is appreciated!

BC AdBot (Login to Remove)


#2 Zhymli


  • Members
  • 1 posts
  • Local time:08:03 AM

Posted 01 January 2018 - 02:01 PM

Hey there.

I know I am being kinda late here, but there is not response in this topic at all, so I thought I'd put my two cents in.


I did face similiar problem for a few days lately. Whenever I played ARK for a couple of minutes, my computer went down (BSOD). I did use WhoCrashed to see what caused the BSOD and it pointed towards the atikmpag.sys file and Video TDR Failure. 

I did try the following:
- Different versions of GPU drivers
- Uninstalling my GPU drivers, cleaning out all of its remains and installing a fresh one through Safe Mode
- Even tried different ARK settings
- Went to clean my whole case (from dust and such) including the GPU
- Replacing the atikmpag.sys manually with a fresh one through command prompt

Geez, I don't really remember what else I did try. I got through s*itload of crashes (BSODs) before stumbling upon the solution (for me atleast for couple of days now).
Now - I am not stating that this is going to work for anyone else, but I would be damned not to share it along.

The solution for me, was to add the following Launch Option for ARK -> "-norhithread" <- without the quotation marks.
If you don't know how to do that -
1) Right Click on ARK: Survival Evolved in your Steam Library
2) Click on Properties
3) In the General tab click on Set Launch Options...
4) Add the following line without the quotation marks "-norhithread"
5) Click on OK and then Close the Properties window.

I hope it helps. 

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users