Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Touchpad and USB port drivers both will not install


  • Please log in to reply
1 reply to this topic

#1 nimrod99

nimrod99

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:02:10 PM

Posted 18 November 2017 - 02:35 PM

I'm completely stumped over here and hope someone can help.  I have a Toshiba Satellite L655 running Windows 7/64-bit.  After running Windows Update, the touchpad and the associated mouse buttons don't work, and the USB ports fail to recognize any devices.

Device Manager shows the yellow triangle ["Windows cannot load the device driver for this hardware.  The driver may be corrupted or missing. (Code 39)"] for Synaptics PS/2 Port TouchPad under Mice and other pointing devices and the same error for both USB Composite Device and USB Mass Storage Device under Universal Serial Bus Controllers.  Uninstalling the drivers removes them from Device Manager until I restart, then they reappear with the same error.  I've downloaded and installed the most recent drivers from the Toshiba website: The touchpad installation says it completed successfully, but the touchpad stil doesn't work, and Device Manager still shows the bad driver above.  The USB drivers from the Toshiba website won't even begin to install after the self-extractor runs.

Pressing the touchpad button or toggling the function key combination doesn't have any effect (the function key combo says the touchpad is enabled), and there doesn't appear to be a relevant setting in the BIOS.

I've tried running System Restore to no avail.  Interestingly, when I boot into System Recovery, the touchpad works fine.

I'm not sure that these two problems (the touchpad and the USB ports) are related, but they did begin to occur at the same time.  Not being able to use a USB mouse, I don't have any mouse functionality at all, so I'm trying to navigate websites exclusively by keyboard, which isn't an adequate long-term solution, of course, and I'm hoping to avoid a factory reset.

I can't find anything online that addresses these specific problems.  If anyone has any thoughts, I would really appreciate hearing them.  Thank you!

 



BC AdBot (Login to Remove)

 


#2 rp88

rp88

  • Members
  • 3,048 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:10:10 PM

Posted 20 November 2017 - 06:22 PM

Have you any way to undo the windows update which you suspect might have caused this? Although given the amount of changes you have made since then rolling back the update might not be enough to fix it, and that assumes that the update caused the problem which isn't certain either. Undoing it would be my first suggestion, maybe try doing the driver installs again after uninstalling the update, but it is also possible that the drivers you are trying to install are too recent for your hardware, ideally you might be able to find the exact driver version you had before the problems began.

Have you yet tried rolling back the driver, instructions on the webpage linked to:

https://www.lifewire.com/how-to-roll-back-a-driver-in-windows-2619217


Do you have any system images made which might let you restore to a point more recent than a factory install would? I highly recommend making such an image after your system is fixed if you've haven't got one already.

Edited by rp88, 20 November 2017 - 06:25 PM.

Back on this site, for a while anyway, been so busy the last year.

My systems:2 laptops, intel i3 processors, windows 8.1 installed on the hard-drive and linux mint 17.3 MATE installed to USB




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users