Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Urgent: Laptop not recognizing internal HDD!

  • Please log in to reply
3 replies to this topic

#1 r_zarrillo


  • Members
  • 1 posts

Posted 17 November 2017 - 11:48 PM

Hey all, this is my first post on this website. I’m at a loss for T-shooting and I’m looking forward to helping some of you with troubleshooting of your own someday but for now let’s focus on the task at hand.
I exclusively ran (I say ran b/c its not working in the present tense) Ubuntu 16.04.3. I left my laptop on for quite awhile today and it eventually died; upon booting I got an error stating no Hard Drive installed. I did a “quick check” of the hard drive and it came up with the same error. This simply isn't true, I have a 1TB (I think Seagate) HDD.
Prior to this, when I opened BIOS to select where to boot from (there was a time this computer had Windows 10 and Fedora 26) it would give me the option “Boot from an EFI File” and now that’s not even there. For some reason my Live USB of Ubuntu 16.04 worked so I can least be on the computer to troubleshoot.
So far I’ve tried installing this Live USB to the hard drive but the only HDD it sees during the partition phase is the exact same one it’s plugged into and frankly I'm gonna need more than a 50GB Hard Drive. I’ve also googled the problem and it doesn’t seem to be common. I checked System Diagnostics and there was no information about my hard drive.
I can only imagine it just has to be “hidden” since I’m using the laptop with a Live Ubuntu USBl
I know there will be more questions and I will gladly answer them so you can help me troubleshoot whatever is going on.

Edited by Al1000, 18 November 2017 - 07:12 AM.
moved from Linux & Unix

BC AdBot (Login to Remove)



#2 cat1092


    Bleeping Cat

  • BC Advisor
  • 6,952 posts
  • Gender:Male
  • Location:North Carolina, USA
  • Local time:09:57 AM

Posted 18 November 2017 - 07:07 AM

r_zarrillo,  :welcome: to Bleeping Computer Forums! :)


We're happy that you chose us & will see what we can do to assist. 


One thing that you can try is removing the drive (if easily accessible) and install in a USB docking station, or SATA to USB cable to see if it runs that way. Or if you have neither, try uninstalling, power cycle (boot to BIOS or UEFI, whichever you have & shutdown), then try reinstalling the drive to see if it works. Note that all HDD's eventually fails, usually within the first year of use if a bad one, or up to many years if good, yet still these all goes, sometimes w/out any warning. 


That's why I suggest at a minimum, to unplug the drive & power cycle as mentioned above, while a shot in the dark, may do the trick. There's also a slight chance that the drive may have came dislodged from the connector, have seen this a couple of times when there was no screw to hold the drive down, rather a rubber gasket holding these in place. It was likely movement or droppage that caused the drive to shift out of place, although note that this is uncommon, both of the models I seen this on were of the HP brand.


See what you can do with these suggestions, hopefully someone else will add a possible answer soon. :)


Good Luck!



Performing full disc images weekly and keeping important data off of the 'C' drive as generated can be the best defence against Malware/Ransomware attacks, as well as a wide range of other issues. 

#3 Al1000


  • Global Moderator
  • 6,932 posts
  • Gender:Male
  • Location:Scotland
  • Local time:01:57 PM

Posted 18 November 2017 - 07:11 AM

Hi and welcome to Bleeping Computer.

Your laptop will run from a live Ubuntu USB, whether or not a hard drive is present.

I suggest testing the drive with Seatools.

I'll move this topic to the Internal Hardware forum because it sounds like the problem is with the hard drive.

Edited by Al1000, 18 November 2017 - 07:12 AM.

#4 pcpunk


  • Members
  • 5,371 posts
  • Gender:Male
  • Location:Florida
  • Local time:09:57 AM

Posted 18 November 2017 - 05:12 PM

As cat said it could be a connection issue, and that would be the simplest to check.  So I would at least take out the HDD and Unplug it and replug it in a few times to make sure the connection is good in addition to the Power Cycle.  In many cases this will help, and as said it is the easiest thing to do.  If it is not being detected, it may not be readable by Seatools on that pc anyhow, but may need to be done on another, or with the SATA to USB cable also as cat suggested. Then move to Al's suggestion as the second step.  


Created by Mike_Walsh


KDE, Ruler of all Distro's



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users