Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows 8.1 64-bit. Chrome won't launch


  • Please log in to reply
No replies to this topic

#1 compbuff

compbuff

  • Members
  • 117 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:11 AM

Posted 16 November 2017 - 06:29 AM

My OS is Windows 8.1 64-bit. My current Google Chrome version is 62.0.3202.94.

 

I was having a problem with right click in Explorer (link) and having almost exhausted trying different options to fix the problem I decided to do a system restore to 3 days ago before the last software and Windows updates, problem posted here https://www.bleepingcomputer.com/forums/t/663042/windows-right-click-issue/ The restore fixed my right click issue in explorer but I found I was unable to launch my chrome browser at all. The steps I then followed to try and resolve the problem were as follows:

 

1. Kill any chrome process from task manager:

 

In task manager there were no previous instances of Chrome running but when I click chrome to attempt to launch it, it shows the Chrome.exe in task manager briefly then disappears, and does not launch.

 

2. Ran security scans:

 

I ran the following

 

- Malwarebytes Anti-Malware home (premium) Threat scan

- ESET Online Scanner: Enabled detection of Potentially unwanted applications (Computer scan settings and enabled detection of potentially unsafe applications (Advanced settings)

- Avast Premier: Full antivirus scan

 

None of them found any issues.

 

3. Rebooted several times:

 

No change; chrome still failed to launch

 

4. Reset Google Chrome by deleting the User profile

 

I have a default profile and several other profiles. I backed up the default folder and deleted it from the location C:\Users\MyName\AppData\Local\Google\Chrome\User Data\Default folder

 

Chrome still refused to launch at all

 

5. Re-installed Chrome?

 

I have not attempted to re-install chrome. I wanted to get advice first before attempting this. I’m assuming if when I may have to try uninstalling and re-installing chrome I can just use the backups of the default and profile folders in the User Date folder in the above mentioned location in step 4 above? I have only done manual backups, and not backups using google sync

 

6. Chrome Cleanup tool:

 

Also Ran the tool to scan for any software that may be causing problems with Chrome, such as crashes, unusual start up pages or toolbars etc. The tool found nonw.

 

7. Google Chrome Ownership:

 

I tried the following steps in case ownership was affected by any incompatible programs:

 

1.  Go to Shortcut of chrome Right click  on it > Open File Location. You can also open Chrome folder by navigating to Computer > C:\Program Files (x86)\Google\Chrome\Application                   OR

2. Create a new shortcut of chrome application on the desktop. (Right click on chrome and click send to desktop)

3. Right Click on New Shortcut and Go to Properties.

4. Go to Security tab.

5. Click on Advanced.

6. Once you click on Advanced option you will get another window named as  Advanced Security Settings. Here Click on Change Option.

7. After Clicking on Change  in owner section, you will get another window to Select User or Group, In the Box below type your USER NAME

8. Now Go to Effective Access Tab  in Advanced Security Settings, and Click on Select a User.

9. After clicking on Select a user same window of user or group will appear again, type USER name and Click on Check Names again.

10. Hit OK to it.

11. Hit Apply / OK  on Advance Security Settings Window.

Hit Apply / OK on  Chrome Shortcut – Properties Window.  Means Save all changes you made.

 

Now open Google chrome it should open and work properly if not then restart your computer and check. Delete the older shortcut of chrome from Start menu, Taskbar and Replace with Modified one.

 

However after following the above steps Chrome still won’t launch.

 

As Chrome recently had a minor update (62.0.3202.94) only a few days ago, my system restore must have taken me back to the previous version (62.0.3202.75) and perhaps causing a browser conflict?   

 

I then tried the Updated Fix for Google Chrome Not Opening Error:

 

Many users reported that the final fix “changing chrome ownership” is also not working for them, in this case, you can try these 2 latest solutions:

 

1. Undo Recent Updates

 

One of the best features of Google chrome is that it update itself in the background without any prompt, sometimes a problem occurs when chrome tries to update from one version to another, and the update fails which leaves chrome in an unstable state.

 

As mentioned my chrome has 2 versions in the Application folder the current and the latest.

 

Open both folders and check which has less number of files, if the older version has less no. of files then –

Open the newer version’s folder and copy all the subfolders & files and paste them into older version’s folder. Try to open Google Chrome now.

 

However after trying this it would not launch.

 

2. Delete Chrome.dll file

 

Chrome.dll is a file which contains the various setting for the chrome browser if chrome isn’t opening then delete this chrome.dll file from application folder.

 

Open C:\Program Files (x86)\Google\Chrome\Application then open chrome version folder, find and delete chrome.dll.  Deleting this DLL file removes all the older settings of google chrome. Open C:\Program Files (x86)\Google\Chrome\Application then open chrome version folder, find and delete chrome.dll.  Deleting this DLL file removes all the older settings of google chrome.

 

Again however, Google Chrome still won’t launch.

 

I have also tried disabling my Avast virus protection and firewall temporarily and it was not Avast stopping Chrome launching.

 

At this point, besides attempting a re-install of Chrome which I have not yet attempted, I have no idea what else to do. I suspect reverting back to the previous chrome version in the system restore may have something to do with it but not sure.

I would appreciate any help and advice on this issue so I can get my Chrome working again with the previous profiles and settings.

 

Thank you kindly in advance.

 

 

 

 

 



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users