Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Automatic ownership of Start Menu items/Warning 1909


  • Please log in to reply
25 replies to this topic

#1 ray5450

ray5450

  • Members
  • 415 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:21 AM

Posted 14 November 2017 - 01:46 PM

When installing programs, this error occurs:

 

"Warning 1909  Could not create Shortcut"

 

I have read dozens of sites with this same error, which all only give a work around and not a solution.  The work around, and probably a clue to the issue, is to take ownership of the folder C:\ProgramData\Microsoft\Windows\Start Menu\Programs/ProgramX in the middle of the install.  If the program installs more than one shortcut, it will miss the first one when it gets the error, then continue.  If there is only one shortcut, there will be none.

 

There is some kind of ownership problem with the files/folders in this location.  I am seeking a permanent solution.

 

Thank-you.



BC AdBot (Login to Remove)

 


m

#2 SleepyDude

SleepyDude

  • Malware Response Team
  • 2,690 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:09:21 AM

Posted 14 November 2017 - 02:24 PM

Hi,

 

Try this:

 

Download Windows Repair (All-in-One) Portable (use the Direct Download button)

  • extract the tweaking.com_windows_repair_aio.zip to c:\Windows\TEMP the zip will extract to a folder called Tweaking.com - Windows Repair
  • execute the file Repair_Windows.exe from the Tweaking.com - Windows Repair folder, accept the Security warning and the EULA
  • click the button Jump To Repairs
  • click the Open Repairs button to access the following screen:
    WindowsRepair.png
  • click the box All Repairs to uncheck all the box's
  • check only the following box's:
    • 02 - Reset File Permissions
  • check the box Restart/Shutdown System When Finished > Restart System
  • click the Start Repairs button

 


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#3 ray5450

ray5450
  • Topic Starter

  • Members
  • 415 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:21 AM

Posted 14 November 2017 - 05:16 PM

Before trying your suggestoin, I tried several things and installed and uninstalled the last program I installed and the issue always occurred.  Now, it seens to work, but I hope it is not because I already took ownership.  I'll know for sure the next time I install something.  Thanks.

 

Do you think something in this repair procedure would also fix this issue:

https://www.bleepingcomputer.com/forums/t/594689/printer-duplicates/


Edited by ray5450, 14 November 2017 - 05:17 PM.


#4 SleepyDude

SleepyDude

  • Malware Response Team
  • 2,690 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:09:21 AM

Posted 14 November 2017 - 05:33 PM

The Windows Repair tool will set the permissions to default you should apply this immediately to avoid future problems.

 

If the machine have more problems then my suggestion is to use another set of corrections:

  • 01 - Reset Registry Permissions
  • 02 - Reset File Permissions
  • 03 - Reset Service Permissions
  • 25 - Restore Important Windows Services
  • 26 - Set Windows Services to Default Startup

 

 


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#5 ray5450

ray5450
  • Topic Starter

  • Members
  • 415 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:21 AM

Posted 14 November 2017 - 05:51 PM

Yes, I used the repair before my previous post.  Like I said, it seemed to work.

 

What I am asking is, after reviewing the printer issue, is there a set of corrections that might work for it, or do you think that issue is a different thing?

 

Thanks.



#6 SleepyDude

SleepyDude

  • Malware Response Team
  • 2,690 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:09:21 AM

Posted 14 November 2017 - 06:12 PM

What I am asking is, after reviewing the printer issue, is there a set of corrections that might work for it, or do you think that issue is a different thing?

 

Not sure. Having wrong permissions can create troubles for sure.

 

Did you run a SFC scan also?


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#7 ray5450

ray5450
  • Topic Starter

  • Members
  • 415 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:21 AM

Posted 14 November 2017 - 08:13 PM

sfc, yes.  However, the cbs log file shows no problems, yet the message returned from the command says it does.  They do not match.



#8 SleepyDude

SleepyDude

  • Malware Response Team
  • 2,690 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:09:21 AM

Posted 15 November 2017 - 04:22 AM

sfc, yes.  However, the cbs log file shows no problems, yet the message returned from the command says it does.  They do not match.

 

Download and run the SURT tool http://support.microsoft.com/kb/947821 select the download that match your windows version.

 

Attach a zip file with the log c:\Windows\Logs\CBS\CheckSUR.log (copy the file to the desktop then zip it)
 


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#9 ray5450

ray5450
  • Topic Starter

  • Members
  • 415 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:21 AM

Posted 15 November 2017 - 12:43 PM

It looks like it repaired something.Attached File  CheckSUR.zip   601bytes   1 downloads



#10 SleepyDude

SleepyDude

  • Malware Response Team
  • 2,690 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:09:21 AM

Posted 15 November 2017 - 01:40 PM

Run another sfc /scannow to check if it continues to report errors or not.


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#11 ray5450

ray5450
  • Topic Starter

  • Members
  • 415 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:21 AM

Posted 15 November 2017 - 03:29 PM

No problems.  That was it.  Thanks, so much.  I'll try to install the printer again and see what happens.



#12 SleepyDude

SleepyDude

  • Malware Response Team
  • 2,690 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:09:21 AM

Posted 15 November 2017 - 04:01 PM

Good. Fingers crossed :)


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#13 ray5450

ray5450
  • Topic Starter

  • Members
  • 415 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:21 AM

Posted 15 November 2017 - 06:05 PM

Hmm, no, it says:

"Windows found a driver software for your device but encountered an error while attempting to install it.  There is no driver selected for the device information set or element."

 

This is the same printer (and driver) that I have always used with this machine, and also another Vista machine.



#14 SleepyDude

SleepyDude

  • Malware Response Team
  • 2,690 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:09:21 AM

Posted 15 November 2017 - 06:22 PM

Download MiniToolBox and save the file to the Desktop.
Close the browser and run the tool, check the following options:

  • List last 10 Event Viewer log
  • List Devices (Only Problems)

Click on Go.

Post the resulting log in your next reply.


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#15 ray5450

ray5450
  • Topic Starter

  • Members
  • 415 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:21 AM

Posted 15 November 2017 - 07:08 PM

Okay, thanks.  Attached.

 

Attached File  MTB.zip   1.63KB   1 downloads






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users