Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Laptop Randomly going to Sleep.


  • Please log in to reply
30 replies to this topic

#1 why12

why12

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:10:29 AM

Posted 12 November 2017 - 09:51 PM

Firstly thanks to the amazing forum, sorry for being mean to register just in time i need some help.

 

             My system randomly is going to sleep from few days. i read online and fixed all Wakeup detectors, disabled MSI power management and all. Scheduled System maintenance to a particular time and all. Ran Malware bytes and bunch others but still its going to Sleep randomly causing very inconvenience. Please help. I am seeing \\the following thing in Event viewer :

Its Windows 10 Home.

There are bunch of logs showing

 

System is entering Sleep

 

Sleep reason : Button or Lid

 

Source : kernel power

 

Event id : 42

 

Yes i have made changes to do nothing when the lid is closed.Attached File  Capture.JPG   43.56KB   0 downloads


Edited by why12, 12 November 2017 - 09:52 PM.


BC AdBot (Login to Remove)

 


#2 FreeBooter

FreeBooter

  • Members
  • 3,137 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Turkey - Adana
  • Local time:06:29 PM

Posted 12 November 2017 - 10:17 PM

Hi why12

 

Have you configure power settings for when computer enters sleep state. You can configure when your computer enters sleep state from Control Panel --> Power Options --> Change when the computer sleeps

 

Posted Image


#3 why12

why12
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:10:29 AM

Posted 12 November 2017 - 10:37 PM

Thanks for your reply, all set to Never from long time..


Edited by why12, 12 November 2017 - 10:37 PM.


#4 FreeBooter

FreeBooter

  • Members
  • 3,137 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Turkey - Adana
  • Local time:06:29 PM

Posted 13 November 2017 - 12:50 AM

Press the Windows + R keys to open the Run dialog, type eventvwr.msc, and press Enter.

 

In the left pane of Event Viewer, double click/tap on Windows Logs to expand it, click on System to select it, then right click on System, and click/tap on Filter Current Log.

 

In the <All Event IDs> field, type 42, then click/tap on OK.

 

PPQAJHc.png

 

 

 

Event Viewer will list logs for time of the computer enters sleep state it will also displays sleep reason.

 

 

MqlmcXb.png


Posted Image


#5 25techsupport

25techsupport

  • Banned Spammer
  • 28 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:59 PM

Posted 13 November 2017 - 03:22 AM

Check your BIOS there must be some kind of power saving mode enabled

also go to your Windows power settings and see if you have enable the power saving mode



#6 why12

why12
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:10:29 AM

Posted 13 November 2017 - 09:54 AM

Thanks for your replies, i tried to find the reason from the Event viewer, its not that helpful. But will try again for sure..

 

I even tried to do system restore its not that helpful either..

 

BIOS i tried to check, but learnt that MSI dont allow advanced options of BIOS and we have to request unlock some thing like.. now the BIOS is of no use pretty much basic options and i dont see any Power settings..

 

From the Windows, power saving mode its pretty much the same thing from more than a year.. no surprises/changes tehre and i also checked there is no sleep options and all set to never where ever its possible..

 

This thing getting more and more annoying.. and wonder if it will effect hard drive..



#7 why12

why12
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:10:29 AM

Posted 13 November 2017 - 09:30 PM

i filtered the log events and found this as the reason

The system is entering sleep.

Sleep Reason: Button or Lid

.. kindly please advise what should be done. Thank youAttached File  PowerSetting.JPG   67.08KB   0 downloads


Edited by why12, 13 November 2017 - 09:37 PM.


#8 FreeBooter

FreeBooter

  • Members
  • 3,137 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Turkey - Adana
  • Local time:06:29 PM

Posted 13 November 2017 - 10:14 PM

Set your power option to High performance this will disable sleep mode.

"5 Tools to Prevent Windows From Sleeping or Turning Off the Display"
https://www.raymond.cc/blog/dont-sleep-prevent-windows-from-standby-shutdown-hibernate-and-restart/

Posted Image


#9 why12

why12
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:10:29 AM

Posted 13 November 2017 - 10:19 PM

i have that option and it still have Turn of display and sleep options.. do you want me to make them never... wonder what is the difference it will make. Apologize for my ignorance.



#10 FreeBooter

FreeBooter

  • Members
  • 3,137 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Turkey - Adana
  • Local time:06:29 PM

Posted 13 November 2017 - 10:21 PM

Yes set Turn of display and sleep options to never.

Posted Image


#11 why12

why12
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:10:29 AM

Posted 13 November 2017 - 10:40 PM

changed lets see.. it went to sleep twice in between changing that mode.. lets see.. thank you.



#12 why12

why12
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:10:29 AM

Posted 13 November 2017 - 11:13 PM

still happening.. :(

#13 FreeBooter

FreeBooter

  • Members
  • 3,137 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Turkey - Adana
  • Local time:06:29 PM

Posted 13 November 2017 - 11:23 PM

Sorry for now i'm out of ideas for your issue.

Posted Image


#14 opera

opera

  • Members
  • 992 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:04:29 PM

Posted 14 November 2017 - 02:55 AM

 Check power lead and battery.



#15 why12

why12
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:10:29 AM

Posted 14 November 2017 - 09:42 AM

thanks and much appreciate your reply, the issue also happening on Battery too.. matter of fact the laptop goes to sleep comparatively more when operated on battery..






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users