Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

CD/DVD Drive not seen but inserted disc turns and nothing else


  • Please log in to reply
1 reply to this topic

#1 Blonders

Blonders

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:10:44 AM

Posted 03 November 2017 - 11:33 PM

Disc drive is not working as it should.It is not recognized in Windows Explorer, nor in Media Monkey.
It makes no popups on screen if disc is inserted. Device manager says this device is working properly.
There is no error nor exclamation mark in Device manager.Although in Device Manager "Other devices"
Ethernet Controller and SM Bus Controller both are there with yellow exclamation marks.They both say
the drivers for this device are not installed code 28.I also cannot update these 2 as when i ask it to search online it just
keeps searching and nothing happens - I kept it searching for over an hour.

Back to the disk drive.
Checked meatloaf disc and inserted with writing at top of disk when i insert it.
Also tried a dvd same as cd and once again nothing happens other than the disk turns.

Press button to go inside tower and then i very faintly hear a slight sound like it is turning.
I then open the disk drawer by pressing the button then find text is no longer at the top so it
has definitely turned in the drive.

Uninstalled driver for cd/dvd drive
rebooted and nothing changed.

Took off cover for tower and was going to remove dust but it looks clean to me.
Lightly dusted very carefully making sure i do not move anything with a very soft bristle makeup blusher brush.
No dust anyway.

So googled and found this page so followed it.

https://support.microsoft.com/en-us/help/314060/your-cd-or-dvd-drive-is-not-recognized-by-windows-or-other-programs

Method 1: Use the Hardware and Devices troubleshooter

Unable to do this as troubleshooter does not come up in results.

I did troubleshoot sounds and there is no problem coming up ( forgot how i did this - was a few days ago.)

Method 3: Update or reinstall the driver

Previously uninstalled so tried updating and it tells me the driver is the latest driver.

I did go to the website Acer (Tower is Veriton S670 Standard by Acer). Typed in details manually and got 17 updates
for drivers. Being overly cautious i updated only maybe 8 of these as i felt not so sure of the rest.( these were Intel named - I know intel is in the tower,
and audio) So far pc seems fine and not really altered in any way.

Method 4: Remove and reinstall IDE/ATAPI drivers
Did this today and although they reinstalled after rebooting, disc drive remains the same.

Method 5: Fix corrupted registry entries

Only got as far as locating sub key as upperfilters and lowerfilters do not appear in the right side.

Also checked Start, (type)diskmgmt.msc (in search box)
Disk manager comes up on screen but all I see is C drive only.


I have Windows Vista Home Premium SP2
       32-bit
       4.00GB RAM
       Tower is Veriton S670 Standard
Just been given to granddaughter to use by somebody they know- not really for Internet (they do not have wifi in their home)
but i have connected up to my wifi hoping to set it up for her and her brothers. They have many game discs
they want set up on the pc.Music and homework i am guessing too.

I know this is a long post but I had to explain everything - :)
Thanks for any help
Blonders

BC AdBot (Login to Remove)

 


m

#2 Havachat

Havachat

  • Members
  • 862 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sleepy Hollow - Geelong - Go Cats.
  • Local time:10:14 AM

Posted 04 November 2017 - 01:59 AM

1/ Check the Sata Cable remove and reattach or choose another Sata Port / if ide check that also.

2/ Or Go into the Bios and see if it shows up there.

3/ Does it show up in " Disc Management "  { CdRom - 0 }

 

Autoplay may be turned off , does it show up in Windows Explorer.

 

If they all fail to give any results , try another Dvd/Cd Unit to rule out the other , just use the cables to connect and try again.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users