Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Computer won't do Windows 10 updates


  • Please log in to reply
2 replies to this topic

#1 flingwing67

flingwing67

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Local time:02:49 AM

Posted 29 October 2017 - 02:55 PM

I have a Gateway PC (purchased new with Windows 7 installed) that was forced to upgrade from Windows 7 to Windows 10.  All was fine for the first few months.  Then an update would not install (as in continuously ran and would never finish or crash and revert to previous setup).  We have been able to work around by not allowing updates, but occasionally it will try one and fail.  I have had a professional (one who is certified and works on these type problems for pay) work on this to no avail.  My frustration with this is exceeding red line.  I know this has been a problem with others and I am wondering if there is a solution to it.



BC AdBot (Login to Remove)

 


#2 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,608 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:06:49 PM

Posted 30 October 2017 - 10:35 AM

Download the Windows Update Troubleshooter and run it.  Please let us know the results of the troubleshooter.

 

If the problems persist reset the Update Components.

 

Open Notepad and copy and paste the batch script below in it.  Save this to the Desktop and name it UCReset.bat.

@ECHO OFF
echo Simple Script to Reset / Clear Windows Update
echo.
PAUSE
echo.
attrib -h -r -s %windir%\system32\catroot2
attrib -h -r -s %windir%\system32\catroot2\*.*
net stop wuauserv
net stop CryptSvc
net stop BITS
ren %windir%\system32\catroot2 catroot2.old
ren %windir%\SoftwareDistribution sold.old
ren "%ALLUSERSPROFILE%\application data\Microsoft\Network\downloader" downloader.old
net Start BITS
net start CryptSvc
net start wuauserv
echo.
echo Task completed successfully...
echo.
PAUSE

To run the batch script right click on the UCReset.bat file on the desktop and select Run as administrator.

Restart your computer and try updating again.

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#3 flingwing67

flingwing67
  • Topic Starter

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Local time:02:49 AM

Posted 02 November 2017 - 12:55 PM

I ran the trouble shooter.  It had to update itself, which it did, no problem.  It ran and fixed everything but the service register on the first try.  I ran it again and it told me it fixed it.  Tried to update windows and no luck.  Trying your next step!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users