Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows launching all previous programs at startup


  • Please log in to reply
42 replies to this topic

#1 durrane25

durrane25

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:02:46 AM

Posted 08 October 2017 - 09:56 AM

Hello,

 

I have a new Windows 10 laptop (Dell XPS 13) and since a recent update Windows always attempts to automatically restore my previous desktop state when shut down and turned back on. For example, it will automatically reopen Chrome if it was open, relaunch Outlook, etc.

 

For the record I am not using a hibernate or similar feature. This occurs when I properly shut the machine off. (Start -> Power -> Shut Down). The programs that launch automatically are not set to launch at startup in System Configuration.

 

Anyone know how I can prevent this from happening?



BC AdBot (Login to Remove)

 


#2 britechguy

britechguy

    Been there, done that, got the T-shirt


  • Moderator
  • 7,495 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Staunton, VA
  • Local time:02:46 AM

Posted 08 October 2017 - 10:14 AM

Have you checked to see if Fast Startup is still enabled?

 

Control Panel, Power Options, "Choose what the Power Button does" link, "Change settings that are currently unavailable" link, uncheck "Fast Startup (recommended)" checkbox.


Brian AKA Bri the Tech Guy (website in my user profile) - Windows 10 Home, 64-Bit, Version 1803, Build 17134 

 

     In a modern society where everyone thinks their opinion deserves to be heard nothing annoys me more than individuals who mistake their personal preferences for fact.

         ~ Commenter TheCruyffGurn on the The Guardian website, 8/13/2014

 

              

 


#3 durrane25

durrane25
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:02:46 AM

Posted 08 October 2017 - 10:57 AM

Aha that's it. Thanks so much. I wasn't aware that refreshing programs was part of Fast Startup.

 

What is the general opinion of the pros/cons of fast startup? Does it save a sufficient amount of startup time to make reloading programs worth it?



#4 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,391 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:11:46 PM

Posted 08 October 2017 - 11:50 AM

Fast startup basically uses a form of hibernation which keeps the kernel and the loaded drivers active, this allows for the fast startup.  But the fast startup can be problematic since it doesn't do a complete shutdown.  One of the potential problems with this are Windows updates.  Some computers have problems installing Windows updates since the computer doesn't completely shutdown.

 

Fast startup does not refresh programs.


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#5 durrane25

durrane25
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:02:46 AM

Posted 08 October 2017 - 12:51 PM

So do you recommend leaving it on or off?



#6 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,391 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:11:46 PM

Posted 08 October 2017 - 12:53 PM

If you are not experiencing any problems with it enabled leave it enabled.

 

You can always disable it to see how it effects the performance of your computer.


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#7 britechguy

britechguy

    Been there, done that, got the T-shirt


  • Moderator
  • 7,495 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Staunton, VA
  • Local time:02:46 AM

Posted 08 October 2017 - 01:51 PM

My two cents is turn it off and leave it off.   In my years of working with clients who use assistive technology, in particular, I have seen misbehaviors crop up that were unlike any others I've ever seen and for which I could not find a direct solution.

 

When we disabled Fast Startup, they disappeared.  The process of deduction/elimination tells me that this means that corruption in the kernel hibernation file used for Fast Startup was at the root of those issues.

 

For myself, I am more than willing to have a start up time that's a bit longer if I can be guaranteed that when I'm shutting down the system I am really shutting it down and when it is fired up again the OS is reloaded, from scratch from disc.

 

Others, of course, will feel differently.


Brian AKA Bri the Tech Guy (website in my user profile) - Windows 10 Home, 64-Bit, Version 1803, Build 17134 

 

     In a modern society where everyone thinks their opinion deserves to be heard nothing annoys me more than individuals who mistake their personal preferences for fact.

         ~ Commenter TheCruyffGurn on the The Guardian website, 8/13/2014

 

              

 


#8 durrane25

durrane25
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:02:46 AM

Posted 13 October 2017 - 02:23 PM

Sorry to resurrect this post, but I decided to turn Fast Startup off and have found that didn't actually change anything. When I fully turn my computer off and back on, it still reopens all the previous programs/Chrome/etc. Is there any other place I need to change this setting?

 

Thanks again!



#9 britechguy

britechguy

    Been there, done that, got the T-shirt


  • Moderator
  • 7,495 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Staunton, VA
  • Local time:02:46 AM

Posted 13 October 2017 - 05:38 PM

Are you positive that you do not have some sort of program (probably supplied by your computer's manufacturer) active and performing this action?

 

I have to be honest and say that I have never, even once, see Windows 10 do this of its own accord except if Fast Startup is on or if Hibernate is being used.

 

How are you shutting down your computer?  Are you using the power button or going through the Start Menu, power options and, if the latter, what are you choosing from the pop up menu when you hit the power icon?


Brian AKA Bri the Tech Guy (website in my user profile) - Windows 10 Home, 64-Bit, Version 1803, Build 17134 

 

     In a modern society where everyone thinks their opinion deserves to be heard nothing annoys me more than individuals who mistake their personal preferences for fact.

         ~ Commenter TheCruyffGurn on the The Guardian website, 8/13/2014

 

              

 


#10 jenae

jenae

  • Members
  • 403 posts
  • OFFLINE
  •  
  • Local time:04:46 PM

Posted 14 October 2017 - 02:30 AM

Hi, open folder options and select the "View" tab uncheck the box " Restore previous folder windows at logon" also press the win +r keys together, in the run box type:- 

 

shell:startup (press ok) any item in startup will start.


Edited by jenae, 14 October 2017 - 02:31 AM.


#11 durrane25

durrane25
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:02:46 AM

Posted 02 November 2017 - 12:43 PM

Thanks again for all of your responses so far. Believe it or not I am still having the issue where on startup all of my previously opened programs reopen. This includes Chrome, with all previous tabs.

 

Here's what I've done so far:

 

1) Under Power Options -> Choose what the power buttons do -> Turn on fast startup (is now unchecked).

2) Shutting down the system by right clicking Windows button -> Shut down or sign out -> Shut down

3) Unchecked the "Restore previous folder windows at logon" under Folder Options

4) Removed everything from the shell:startup list of programs.

5) Checked the manufacturer software that is running, which is only a program called Dell Update that updates my drivers and such.

 

I hope I am missing something obvious because this has baffled me a bit! I would appreciate any off the wall ideas anyone can offer :)



#12 Rocky Bennett

Rocky Bennett

  • Members
  • 2,596 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Mexico, USA
  • Local time:12:46 AM

Posted 02 November 2017 - 12:53 PM

Thanks again for all of your responses so far. Believe it or not I am still having the issue where on startup all of my previously opened programs reopen. This includes Chrome, with all previous tabs.

 

Here's what I've done so far:

 

1) Under Power Options -> Choose what the power buttons do -> Turn on fast startup (is now unchecked).

2) Shutting down the system by right clicking Windows button -> Shut down or sign out -> Shut down

3) Unchecked the "Restore previous folder windows at logon" under Folder Options

4) Removed everything from the shell:startup list of programs.

5) Checked the manufacturer software that is running, which is only a program called Dell Update that updates my drivers and such.

 

I hope I am missing something obvious because this has baffled me a bit! I would appreciate any off the wall ideas anyone can offer :)

 

 

Are you running version 1709? That is a "feature" of the Fall Update.


594965_zpsp5exvyzm.png


#13 durrane25

durrane25
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:02:46 AM

Posted 02 November 2017 - 03:26 PM

 

Thanks again for all of your responses so far. Believe it or not I am still having the issue where on startup all of my previously opened programs reopen. This includes Chrome, with all previous tabs.

 

Here's what I've done so far:

 

1) Under Power Options -> Choose what the power buttons do -> Turn on fast startup (is now unchecked).

2) Shutting down the system by right clicking Windows button -> Shut down or sign out -> Shut down

3) Unchecked the "Restore previous folder windows at logon" under Folder Options

4) Removed everything from the shell:startup list of programs.

5) Checked the manufacturer software that is running, which is only a program called Dell Update that updates my drivers and such.

 

I hope I am missing something obvious because this has baffled me a bit! I would appreciate any off the wall ideas anyone can offer :)

 

 

Are you running version 1709? That is a "feature" of the Fall Update.

 

 

Yes, I am. Any way to disable this? :/



#14 britechguy

britechguy

    Been there, done that, got the T-shirt


  • Moderator
  • 7,495 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Staunton, VA
  • Local time:02:46 AM

Posted 02 November 2017 - 05:44 PM

Have you looked at this:  https://www.windowscentral.com/how-control-apps-startup-windows-10

or anything similar?

 

I still cannot understand how you would have any apps that are not a part of the startup hierarchy starting up again on their own upon boot.

 

I also would love to know where anything says this is a new feature in Version 1709.  I'm not saying that it isn't, but nothing I've read leading up to this feature update nor since indicates this.


Edited by britechguy, 02 November 2017 - 05:44 PM.

Brian AKA Bri the Tech Guy (website in my user profile) - Windows 10 Home, 64-Bit, Version 1803, Build 17134 

 

     In a modern society where everyone thinks their opinion deserves to be heard nothing annoys me more than individuals who mistake their personal preferences for fact.

         ~ Commenter TheCruyffGurn on the The Guardian website, 8/13/2014

 

              

 


#15 jenae

jenae

  • Members
  • 403 posts
  • OFFLINE
  •  
  • Local time:04:46 PM

Posted 02 November 2017 - 05:44 PM

Hi, still unable to get this to happen on any of our 1709 machines and from discussions many more also do not experience it. However others like you are experiencing this. Ms have been equally confused, suspect it will be removed.

 

What we know from an MS site: 

 

This is actually a change in the core functionality of Windows in this development cycle.

 

Old behavior:
- When you shut down your PC, all apps are closed

- After reboot/restart, you have to re-open any app you'd like to use

 

New behavior:

- When shutting down your PC, any open apps are "bookmarked" (for lack of a better word)

- After reboot/restart, these apps will re-open automatically

 

If you want to start with no apps open (other than those set to auto-start via Task Manager/Start), you'll need to ensure all apps are closed before shutting down or restarting the PC.

 

 

Why?

The desire is to create a seamless experience wherein, if you have to reboot a PC, you can pick back up quickly from where you left off and resume being productive.  This has far-ranging impacts across the OS (in a good way).

 

So far it has been possible to overcome this on effected machines with some registry mod's (as it could not be created by us, we did not write the mod's so I will not post them until I am sure they are safe, and more importantly why this is only effecting some machines and not all). For the moment close all app's before restart. One other issue that concerns us is an errant site (ransomeware, for eg) could these be reopened?






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users