Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Wifi card switched back to bad driver

  • Please log in to reply
1 reply to this topic

#1 OmegaWolf747


  • Members
  • 74 posts
  • Gender:Not Telling
  • Location:Michigan
  • Local time:12:31 AM

Posted 23 September 2017 - 09:21 AM

PC: PowerSpec G418 Desktop Computer; Intel Core i7-6700K Processor 4.0GHz; NVIDIA GeForce GTX 1070 8GB GDDR5 VR Ready; G.Skill 16GB DDR4-3200 RAM; Toshiba 1TB 7,200RPM HDD + Samsung 250GB SSD, RealTek 8812AE Wireless LAN 802.11ac


My wifi card's default driver doesn't work so well, in that, while the card is detected, it can't connect to networks (red X over the icon). I solve the problem by manually updating the driver in Device Manager to the 2016 driver you see in the screencap, thus removing the red X and regaining network. However, when I reboot or put the PC into Sleep Mode and then awaken it later, it has defaulted back to the bad 2014 driver. Is there a way to either delete the 2014 driver or at least force it to keep the driver I've chosen?


Thank you.


Attached File  how do i delete this 2014 driver that disables my wifi card.PNG   19.79KB   0 downloads

What is this Internet you speak of?

BC AdBot (Login to Remove)



#2 JohnC_21


  • Members
  • 22,171 posts
  • Gender:Male
  • Local time:01:31 AM

Posted 23 September 2017 - 09:26 AM

Did you disable Windows 10 auto driver update? Uninstall the bad driver then disable driver updates. Install good driver.



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users