Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Plantronics Gamecom 780/788 Headset Software Hangs


  • Please log in to reply
1 reply to this topic

#1 Naomeister

Naomeister

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:11:30 PM

Posted 12 September 2017 - 07:57 PM

Hey there,

 

For some reason I have yet to determine, the Dolby Surround Sound software for my Gamecom 788 headset won't open properly. It will begin to start, but hang at around 2700-2900k according to task manager, and never move from there. The software in question is used to enable this headset's surround sound features and precise volume control, and is available on this site:

http://www.plantronics.com/us/product/gc780-surround-sound-windows

 

I haven't been able to determine if it's due to the installer itself, or an error with the program. Installing and uninstalling APPEARS to work, though there is a delay around halfway through the install of about a 30-45 seconds. Installing the plug-and-play drivers from the headset works perfectly fine, and I can get stereo sound and basic functionality from that, but when the Gamecom software is installed, the plug-and-play driver will stop working, and if I try to install the driver while the software is installed, it will always fail (even though it doesn't fail when the software isn't installed). In addition, when booting while the software is installed, the display will switch off (monitor says "No Signal") for about 30-45 seconds between the black Windows startup screen, and the blue WIndows startup screen appearing. Without the software, I can't use surround sound, precise audio control, and other features.

 

I previously had a Plantronics Gamecom 780 headset, but the wires had become frayed and were shorting out, so I temporarily replaced it with an old Razer Kraken 7.1 while I waited for my 788 to arrive. The software had worked entirely fine when I switched to the Kraken temporarily, but after that week, it no longer works. No unusual software was installed during that week, save for the Kraken drivers and Razer Synapse (both have since been uninstalled again).

 

I have tried uninstalling and reinstalling the software, doing so as administrator, doing so from safe mode, doing so with the unzipped installer specific to Windows 7 (tried all the other installers, but they obviously don't work on a Windows 7 system). I have also tried reinstalling my Nvidia HD Audio drivers in case it was a conflict of some sort.

 

I am running Windows 7 64-bit.



BC AdBot (Login to Remove)

 


#2 backtwo2

backtwo2

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:07:30 AM

Posted 29 September 2017 - 03:23 PM

I'm also having issues using the Plantronics GamesCom 788 surround sound software. 

 

I've just formatted my windows and went to install the surround sound driver. I installed it and restarted my computer as the installation prompts. However, the program doesn't open no matter what i've tried restarting my computer and reinstalling the driver. Nothing seems to work and I cannot get the software to open. It doesn't hang in task manager for me either.

 

I've just emailed their support email which will take one business day hopefully ;D (Doubt it). However, I plugged the headset into my computer which I assumed was bad because when I got the headset it said you should install the software before plugging the device in. I plugged in the device and it seems to work without the surround sound. Obviously you don't get 7.1 but you still get the base function mic/headphone with stereo sound. I'll use this until they reply back to my email. Ill update you if I get a reply. I suggest you also email them asking specifically about your issue too.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users