Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Short Filenames


  • Please log in to reply
3 replies to this topic

#1 dudeman

dudeman

  • Members
  • 38 posts
  • OFFLINE
  •  
  • Location:TX
  • Local time:10:31 PM

Posted 10 June 2004 - 03:50 PM

We are trying to figure out how to enable the 8.3 naming on Windows 2000 server. We found lots of ways to disable it if necessary, and you would think to do the opposite of disabling it to enable it, but that doesn't work. To tell you the truth we only need it for one folder. So if there is a way to enable it for just one folder that would be great. So if anyone could help this one is for you. Grinler, This may be something you can help me with. We know it has to do something with the Filesystem and by default it is enabled on 95, 98se, NT4 and ME. Our thoughts were "If it is on NT4, then it is not stopped by NTFS". Your guess is as good as ours. Thanks for the help!

BC AdBot (Login to Remove)

 


#2 Grinler

Grinler

    Lawrence Abrams


  • Admin
  • 43,717 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:10:31 PM

Posted 10 June 2004 - 03:56 PM

It is on by default for win2000 as well. Has it ever been disabled in the past that you know of?

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem\NtfsDisable8dot3NameCreation

What is the value of that key in the registry?

#3 dudeman

dudeman
  • Topic Starter

  • Members
  • 38 posts
  • OFFLINE
  •  
  • Location:TX
  • Local time:10:31 PM

Posted 10 June 2004 - 04:03 PM

It is on but only with default Win2k folders and files. Which is really confusing because that means it is 16bit. here is how to disable it.


HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem


Change or add the following value:
Data Type: REG_DWORD
Value Name: NtfsDisable8dot3NameCreation
Value: 1

It was at 1 by default. We put it to 0 and it changed nothing. We created files with long names before and after the regitry setting( you must reboot for it to take effect everytime you change it.) I am also looking through all of our default DoD templates to find if it is a DoD setting. Then that means we can't do anything about it. We have other security templates as well and I haven't gotten to them yet.

#4 Grinler

Grinler

    Lawrence Abrams


  • Admin
  • 43,717 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:10:31 PM

Posted 11 June 2004 - 08:44 AM

This is strange. With the registry entry set to 0 or even missing, then any new folders/files with long file names will also create the corresponding 8.3 variants. At least that is what it is supposed to do by the book.

As you said changes do not go into effect until you reboot and then create files. I would try deleting the key and then rebooting and seeing what that does. It really should work once you set it to 0 and reboot. From that point forward all new files on a ntfs partition should get the 8.3 naming convention.

Have you tried creating a folder called "this is a long filename folder" on the c: drive, going to a cmd prompt, cd \, and typing dir /x ?

This will show if the 8.3 file name is being created. You may have already done all of this, but just trying to cover all the bases.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users