Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Windows is not using my Nvidia Graphics

  • Please log in to reply
3 replies to this topic

#1 ext4zy


  • Members
  • 24 posts
  • Local time:10:43 PM

Posted 29 August 2017 - 01:50 PM

Asus R753U

Processor: Intel Core i7-7500 CPU @2.70GHz Turbo: 3.50GHz




Graphics : NviDiA GEFORCE GTX 950M 2GB

Hello My Windows 10 is not using my Graphics as u can see it in the picture : https://ibb.co/hvgJsQ

How To change it to Nvidia I went To Nvidia Control Panel did that But my Games Are Still Laggy I do belive i have a good graphic card so what should i do ? 

BC AdBot (Login to Remove)


#2 Kilroy


  • BC Advisor
  • 3,461 posts
  • Gender:Male
  • Location:Launderdale, MN
  • Local time:02:43 PM

Posted 29 August 2017 - 01:57 PM

Can you disable the Intel graphics in the BIOS?

#3 ext4zy

  • Topic Starter

  • Members
  • 24 posts
  • Local time:10:43 PM

Posted 29 August 2017 - 02:07 PM

No i can't i tried it to disable in the Device Manager but my Resolution of my laptop changed entirely 

#4 opera


  • Members
  • 1,027 posts
  • Gender:Not Telling
  • Local time:08:43 PM

Posted 30 August 2017 - 12:22 AM

Have a look at a few suggestions here



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users