Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Keyboard Mismapping Some Keys


  • Please log in to reply
No replies to this topic

#1 GideonJagged

GideonJagged

  • Members
  • 1 posts
  • OFFLINE
  •  

Posted 29 August 2017 - 12:58 PM

I'm having an infuriating problem.

 

I'm running the latest version of Windows 10 Enterprise on an Alienware m17x r3.

 

Since Windows 8, the keyboard has been doing the following:

 

  1. pressing 'a' does nothing
  2. pressing 's' outputs '-' (pressing shift+'s' outputs '_')
  3. pressing '-' outputs 's' (pressing shift+'-' outputs 'S')
  4. pressing 'w' outputs 'a' (pressing shift+'w' outputs 'A')
  5. pressing keypad '2' outputs 'w' (pressing shift+keypad '2' outputs 'W')
  6. pressing 'd' outputs '2' (keypad '2' I'm almost certain)
  7. pressing shift+'d' executes the keypad down arrow.
  8. Nothing will output 'd' or 'D'

 

All other keys working normally.

 

I've upgraded and reinstalled windows several times and recently bought a new keyboard for the laptop. Same problem exactly.

 

I've run every sort of virus/malware/rootkit software countless times. I've also run every kind of hardware diagnostic I can find. No result. Windows thinks the keyboard is fine.

I'm using an external (USB) keyboard ATM.

 

Help!



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users