Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

BITS does not start?


  • Please log in to reply
20 replies to this topic

#1 The Big Remover

The Big Remover

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Tucson, Arizona
  • Local time:01:31 PM

Posted 29 August 2017 - 02:26 AM

I have to turn it on,  The only error I get when I  check for a missing dll file is the pic below?  (depends.exe %windir%\system32\qmgr.dll)  sfc /scannow is ok..... no infections?   Windows 7 64 bit...thx. for any help

Attached Files


see website and you tell me!

BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 55,545 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:03:31 PM

Posted 29 August 2017 - 08:21 AM

Worth A Look

 

Louis


Edited by hamluis, 29 August 2017 - 08:25 AM.


#3 sflatechguy

sflatechguy

  • BC Advisor
  • 2,200 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:31 PM

Posted 29 August 2017 - 08:45 AM

That error means the depends.exe executable is not installed on your system, so you can't use Dependency Walker to check for possible missing dependencies of qmgr.dll.

 

Visual Studio and related Microsoft tools will install it. If you don't have any of those and you need to install it, use this link: http://dependencywalker.com/



#4 joseibarra

joseibarra

  • Members
  • 1,154 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Downstairs
  • Local time:04:31 PM

Posted 29 August 2017 - 09:00 AM

You topic subject says "BITS does not start" but you did not say what happens when you attempt to start BITS or how you are attempting to start BITS.

 

If you are getting some kind of error message you need to tell us exactly what it says or include a screen shot of that you are seeing.

 

As a test I deleted (renamed) my qmgr.dll so it became "missing" (the DLL that BITS needs) and running sfc /scannow did replace the missing file.


Edited by joseibarra, 29 August 2017 - 04:25 PM.

The mediocre teacher tells. The good teacher explains. The superior teacher demonstrates.


#5 The Big Remover

The Big Remover
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Tucson, Arizona
  • Local time:01:31 PM

Posted 29 August 2017 - 12:53 PM

 
@ joseibarra
 
        I would start the pc, then go into services.msc  - scroll down to Background Intelligent Transfer Service, & start it manually! (change it to Auto)  after running depends.exe %windir%\system32\qmgr.dll
         I would only get the pic you see "cannot find: depends.exe"     sfc /scannow  shows up with no issues.   the pic is the only error message

Edited by The Big Remover, 29 August 2017 - 12:54 PM.

see website and you tell me!

#6 joseibarra

joseibarra

  • Members
  • 1,154 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Downstairs
  • Local time:04:31 PM

Posted 29 August 2017 - 04:37 PM

I have never used Dependency Walker so maybe somebody else can help.


The mediocre teacher tells. The good teacher explains. The superior teacher demonstrates.


#7 The Big Remover

The Big Remover
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Tucson, Arizona
  • Local time:01:31 PM

Posted 29 August 2017 - 05:11 PM

I also never used the above !!!!


see website and you tell me!

#8 sflatechguy

sflatechguy

  • BC Advisor
  • 2,200 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:31 PM

Posted 29 August 2017 - 06:08 PM

I also never used the above !!!!

 

Then why are you running the Dependency Walker  executable with depends.exe %windir%\system32\qmgr.dll ? The only reason to do that is to check and ensure qmgr.dll has all it's dependencies installed.



#9 The Big Remover

The Big Remover
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Tucson, Arizona
  • Local time:01:31 PM

Posted 29 August 2017 - 07:32 PM

worked on this since 10pm last nite - what do you think?  http://helpdeskgeek.com/how-to/background-intelligent-transfer-service-will-not-start/


see website and you tell me!

#10 sflatechguy

sflatechguy

  • BC Advisor
  • 2,200 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:31 PM

Posted 29 August 2017 - 07:54 PM

I assumed you were trying to troubleshoot. Did you follow all the other troubleshooting steps first? Check to make sure all the related services outlined in the link are running.

 

The problem with depends.exe is you don't have it installed. As I stated earlier, it gets installed with Visual Studio and other related Microsoft programs. Otherwise, you'll need to install it from the Dependency Walker website. Then you can run depends.exe %windir%\system32\qmgr.dll



#11 The Big Remover

The Big Remover
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Tucson, Arizona
  • Local time:01:31 PM

Posted 29 August 2017 - 08:18 PM

"As I stated earlier, it gets installed with Visual Studio and other related Microsoft programs. Otherwise, you'll need to install it from the Dependency Walker website. Then you can run depends.exe %windir%\system32\qmgr.dll"

 

@sflatechguy   I can use some help with the above

 

Terminal Services, Remote Procedure Call (RPC), System Event Notification, Windows Management Instrumentation Driver Extensions, COM+ Event System, DCOM Server Process Launcher

 

Terminal Services is not there?  the rest are & running!


Edited by The Big Remover, 29 August 2017 - 08:18 PM.

see website and you tell me!

#12 The Big Remover

The Big Remover
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Tucson, Arizona
  • Local time:01:31 PM

Posted 29 August 2017 - 08:45 PM

FIXED !!!!!!!                     All's well, thank you all for your time  !!!!'


see website and you tell me!

#13 opera

opera

  • Members
  • 966 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:09:31 PM

Posted 30 August 2017 - 01:19 AM

Come on... you cannot just say FIXED!! and not tell how you did it. :)



#14 The Big Remover

The Big Remover
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Tucson, Arizona
  • Local time:01:31 PM

Posted 30 August 2017 - 03:49 PM

hi opera!

I was lucky !!  Plus the 2 websites above  http://dependencywalker.com/   and   http://helpdeskgeek.com/how-to/background-intelligent-transfer-service-will-not-start/   another sfc /scannow  showed the 3rd time a whole bunch of errors?  & it fixed them - BITS Starts ok now........   

 

Since I'm kinda wiped out from lack of sleep..... its the best response I can give you...... 

 

not bad for a 66 yr. old dude  :tophat: 


see website and you tell me!

#15 sflatechguy

sflatechguy

  • BC Advisor
  • 2,200 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:31 PM

Posted 30 August 2017 - 06:46 PM

Glad you got that resolved.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users