Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Problems with adding a second wireless router


  • Please log in to reply
7 replies to this topic

#1 DDE12

DDE12

  • Members
  • 33 posts
  • OFFLINE
  •  
  • Local time:05:50 PM

Posted 27 August 2017 - 02:02 PM

I am trying to get my home network set up with two wireless routers and am having problems with the second router connecting to the network and internet.  Here is a diagram of what I am trying to accomplish.

 

Fiber optic modem -->  Wireless Router A at 192.168.1.1 (DHCP Enabled, some IP's assigned to "servers")  
                                                   |                                        
                                                   |--> Server A at static 192.168.1.2                        
                                                   |--> Vonage adapter                                
                                                   |--> Wireless Router B (DHCP disabled)
                                                                                    |
                                                                                    |--> DVR at static 192.168.1.3
                                                                                    |--> Server B at static 192.168.1.4    

The address pool of Router A is 192.168.1.2 - 192.168.1.20
Ethernet cable is connected to LAN jack on Router and and WAN/Ethernet jack on Router B.
I have tried Wireless Router B at 192.168.1.11 and 192.168.1.100 with no success.  Cannot obtain default gateway address wired or wireless.
I have also tried placing Router B after the switch (ethernet cable connected from one of the switch ports to WAN/Ethernet port of Router B ) and assigning it the IP's above with the same results.
If I put a switch in place of Router B (removing Router B from the netowrk), the DVR and Server B connect to network and internet and get assigned to the desired IP's.

How can I configure Router B so that my wireless devices can connect to the network (access the servers, DVR) and connect to the internet?  I do have a second switch on hand that can be used if needed.

 

Thank you in advance.



BC AdBot (Login to Remove)

 


#2 toofarnorth

toofarnorth

  • Members
  • 379 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:50 PM

Posted 28 August 2017 - 10:19 AM

Hello

 

If you are using WAN port of Router B you will have problems.
The reason for this is that Router B then split the network into a part on the WAN side and a part on the LAN side.
This leads to problems connecting units on each side to eachother.

I would first try to connect the cable from Router A to the LAN side on Router B.
That way it doesnt do any routing at all.

Hth!

 

tfn



#3 Kilroy

Kilroy

  • BC Advisor
  • 3,372 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Launderdale, MN
  • Local time:04:50 PM

Posted 28 August 2017 - 12:36 PM

As toofarnorth said, you need to use a LAN port on Wireless Router B instead of the WAN port.  Moving to the LAN port will make Wireless Router B a switch with an attached Wireless Access Point (WAP).



#4 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:02:50 PM

Posted 28 August 2017 - 05:08 PM

You couldn't route with that ip addressing anyway. Problem is router B, to do NAT, has to have different ip subnets not the same subnet on the wan and lan interfaces.

Here is a how to to setup router b correctly:
http://www.techsupportforum.com/3001-connecting-additional-routers/

#5 DDE12

DDE12
  • Topic Starter

  • Members
  • 33 posts
  • OFFLINE
  •  
  • Local time:05:50 PM

Posted 04 September 2017 - 10:00 PM

Thank very much for your help.  I connected the Ethernet cable from the switch to one of the LAN ports of Router B and set it's IP address to 192.168.1.11 and then turned off NAT.  Everything is working as expected and I can connect to the all the shared folders on the network.

 

Will then NAT on Router A protect the entire network, making the NAT on Router B (if enabled) redundant?

If the IP address of Router B is outside the IP pool of Router A, would that prevent devices connected through Router B from being able to view the shared folders of the devices connected through Router A?



#6 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:02:50 PM

Posted 05 September 2017 - 11:15 AM

"Will then NAT on Router A protect the entire network, making the NAT on Router B (if enabled) redundant?"

Yes

 

"If the IP address of Router B is outside the IP pool of Router A, would that prevent devices connected through Router B from being able to view the shared folders of the devices connected through Router A?"

No

 

This assumes you followed the linked article.  Router b becomes nothing more than a wifi ap/switch


Edited by Wand3r3r, 05 September 2017 - 11:15 AM.


#7 DDE12

DDE12
  • Topic Starter

  • Members
  • 33 posts
  • OFFLINE
  •  
  • Local time:05:50 PM

Posted 16 September 2017 - 10:29 PM

I did follow the article except that I have Router B inside the IP address pool of Router A.  Thank you Wand3r3r, toofarnorth, and Kilroy for your help.  I appreciate your time and expertise.



#8 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:02:50 PM

Posted 17 September 2017 - 11:18 AM

"I did follow the article except that I have Router B inside the IP address pool of Router A"

 

This will cause you ip conflicts so don't do that.  Change router A's dhcp scope to 50-75 so there will never be a conflict with the lower ip range assignments.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users