Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Could not update .ICEauthority file/home/USERNAME/.ICEauthority login error


  • Please log in to reply
3 replies to this topic

#1 Agent_Orange

Agent_Orange

  • Members
  • 85 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Brisbane, Australia
  • Local time:05:48 PM

Posted 27 August 2017 - 10:09 AM

Hi all,

I recently completed a fresh install of Linux Mint 18.3 and went and made a huge mistke by changing the permissions on my Home directory which has lead to the following login error: Could not update .ICEauthority file/home/USERNAME/.ICEauthority. and am forced to logout.

I have tried to fix the issue by following dated (the only ones that I could find) instructions : https://forums.linuxmint.com/viewtopic.php?t=115076 and https://askubuntu.com/questions/55568/could-not-update-iceauthority-file-after-login-independent-of-gnome as well as https://ubuntuforums.org/showthread.php?t=1841457 without any success.

When running the following commands as Root in Recovery Mode : chown username:groupname /home/username/.ICEauthority & chmod 0600 /home/username/.ICEauthority I receive an error message advising that there is "no such file or directory as .ICEauthority"

When running the alternative command offered : sudo chown username:groupname /home , I receive a message advising that the permissions have been changed to a read only filesystem. I then log out of root and login in as normal only to find the same error message waiting for me: Could not update .ICEauthority file/home/USERNAME/.ICEauthority. accompanied by a request to logout.

I used a LIve Linux Mint CD to look at the files and could see that the ownership has been changed to Root for the Home folder and tried the following command whilst in Recovery mode and Root shell : sudo chown -R user:user /home/user. This did something, I noticed that a lot of changes were being displayed and that there were no error messages about no such file etc. When attempting to log in as normal I am again greeted with the error message and asked to logout out.

I have made numerous attempts to resolve the issue, even trying to enable AutoLogin by modifying /etc/mdm/mdm.conf which only results in an error message advising that there is no such directory or that I have a read only file system.

Coulde someone please help as I am not able to resolve this issue by myself, cannot access my computer and do not wish to do a complete re-install that results in the loss of my files.

Thank you

 


Edited by Agent_Orange, 27 August 2017 - 09:06 PM.


BC AdBot (Login to Remove)

 


#2 Agent_Orange

Agent_Orange
  • Topic Starter

  • Members
  • 85 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Brisbane, Australia
  • Local time:05:48 PM

Posted 28 August 2017 - 05:21 AM

It does not look like I am going to receive any help with this issue any time soon so please close the topic, I will reintsall the OS.


Edited by Agent_Orange, 28 August 2017 - 05:22 AM.


#3 mremski

mremski

  • Members
  • 492 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:NH
  • Local time:03:48 AM

Posted 29 August 2017 - 03:09 AM

You posted on a Sunday (in the US), need to give folks a chance to read it first.  Noones getting paid here to answer questions and you've pretty much given us nothing more than "the car won't start, why?"

If you've reinstalled and gotten things to work again, ok.  If not and you still like some help resolving it:

Exactly what command did you run to change the permissions on your home directory?

Exactly what are the current permissions on the directory?

Have you tried switching to a console at the login screen (Ctrl-Alt-F3 or something), logging in as root and mucking around?

ls -ltr /home for a start

if you've already done "chown -R user:user /home/user" that should have set user to be the owner of all the files and subdirectories of /home/user

now try:

cd /home

chmod u+rwx user  may need sudo on that, that will set the "user" permissions to read, write and execute on the /home/user directory

cd user

ls -ltr .ICEauthority

chmod u+rw .ICEauthority  should not need a sudo


FreeBSD since 3.3, only time I touch Windows is to fix my wife's computer


#4 Turpy

Turpy

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:07:48 AM

Posted 01 March 2018 - 02:55 PM

Hi, and THANK YOU very much for anyone's time & wisdom!

 

I'm getting the op's exact error upon logging into my Linux Mint 18 box, although I'm pretty sure that the cause is different.

 

A few weeks ago, I was compromised by a nasty virus, and so I instantly changed ALL of my passwords to VERY STRONG (and also all completely different) randomly generated ones.  So, I got busy and didn't log into this box for a week, and when I did (and since I did NOT write the new one down), it wouldn't let me in!

 

I searched, and managed to boot into a recovery mode and change my original user password (meaning that I can now get past the initial login prompt), and I apologize for not remembering the exact commands that I used (which I know was to be your first question).

 

Now, once I get through the initial login prompt, the screen goes blank for about 30 seconds and I receive "Could not update ICEauthority file /home/username/.ICEauthority".  The only option is to Log Out.

 

I can get into it both by Recovery, as well as a Mint 18 Live flash drive (which I can see & mount my local hard drive).  BUT, I think that perhaps it's encrypted, because my user's home directory contains only two files, one that says "THIS DIRECTORY HAS BEEN UNMOUNTED TO PROTECT YOUR DATA.

From the graphical desktop, click on:
 "Access Your Private Data"

or

From the command line, run:
 ecryptfs-mount-private"






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users