Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

PCs on LAN can ping each othr but can't share files


  • Please log in to reply
4 replies to this topic

#1 windranger

windranger

  • Members
  • 32 posts
  • OFFLINE
  •  
  • Local time:04:54 AM

Posted 27 August 2017 - 09:13 AM

I have a LAN with 2 PCs and the situation is weird: PCs on same workgroup can see each other, but they can't see the shared files/folders- because these don't show up in Network (Windows Explorer).
 
One computer is the main one (Windows 10, set as Master Browser), the other one is XP.
Name of the workgroup is WORKGROUP.
 
- On W10, the samba v1, v2, v3 are enabled (see screenshot)
 
- I can ping from any of the PCs the other one successfuly.
 
- The result of the command "net view" on w10 PC is:
"System error 53 has occurred. The network path was not found."
 
- The result of the command "nslookup hostname" on w10 PC is:
"Server:  ap8857ee75cefe
Address:  192.168.11.1
*** ap8857ee75cefe can't find hostname: Non-existent domain"
 
- The result of the command "nbtstat -A 192.168.11.3" on w10 PC (where the IP is XP's) is:
       NetBIOS Remote Machine Name Table
       Name               Type                            Status
    ---------------------------------------------------------
    HOME-PC     <00>   UNIQUE      Registered
    HOME-PC     <20>   UNIQUE      Registered
    WORKGROUP <00> GROUP       Registered
    WORKGROUP <1E> GROUP       Registered
 
 
Even when XP computer is not connected to LAN, the result of "net view" on w10 PC is the same: "System error 53 has occurred. The network path was not found."
 
Adapter's settings -> Properties -> IPv4 -> Properties -> Advanced -> WINS : NetBIOS Setting is set to "Enable NetBIOS over TCP/IP"
 
Just in case, I also flushed the DNS server.
 
Don't understand why this happens, I'd appreciate any help.


BC AdBot (Login to Remove)

 


#2 mikey11

mikey11

  • Members
  • 1,509 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Psychiatric Ward @ Beelitz-Heilstatten Hospital, Beelitz, Germany
  • Local time:08:54 PM

Posted 27 August 2017 - 09:39 AM

 


One computer is the main one (Windows 10, set as Master Browser), the other one is XP.

 

 

i doubt it will ever work with the xp computer,

 

i have never been able to get an xp to share files with any other windows version, except xp with xp



#3 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:11:54 AM

Posted 27 August 2017 - 10:59 AM

I would suggest that knowing what the master browser is located and what is enabled means you are too deep in the weeds.
Not a place to be.

You can't use nslookup since that is a dns server request and 1. you don't have a local dns server and 2. the internet dns server you are pointed to doesn't know your lan hosts as it would never know that.

Perhaps this will help


review this for the system 53 error
https://answers.microsoft.com/en-us/windows/forum/windows_vista-networking/system-error-53-has-occurred-the-network-path-was/9511bbd8-ca11-4c1e-8d85-f7e8ce7e0fb9?auth=1

biggest points I can point out are as following;
firewall configured to allow file and printer sharing [enabled]
same exact user name and password on all hosts
share off the root not from under some existing folder so you don't have hierarchal permissions messing with you.
share with full control to 'everyone'.

Let us know how it goes.

Edited by Wand3r3r, 27 August 2017 - 11:02 AM.


#4 Kilroy

Kilroy

  • BC Advisor
  • 3,442 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Launderdale, MN
  • Local time:01:54 PM

Posted 28 August 2017 - 01:58 PM

I've never found Microsoft's simple file sharing to be something that was easy to get working, I always use the advanced sharing.  To truly understand sharing and security is a two day block of instruction.

 

1.  Create an account on all machines involved with the same account name and password.  If you want to have different types of access, i.e. one account with Read and one account with Read and Write create an account for each need on each machine with the same password.

2.  Right click the folder you want to share and select Properties.

3.  Switch to the Sharing tab and press the Advanced Sharing button.

4.  Check the Share this folder box.

5.  Name the share, ideally something without spaces as spaces tend to cause issues.

6.  Set your permissions.  Read allows viewing of the items in the folder.  Change allows adding, changing, and deleting items in the folder.  Full Control should not be needed. Normally you only add the users or groups that you want to have access.

7.  You can also set permissions on the security tab.  Never, ever, use the Deny permission.  If you do not have permission you do not have access.  Using Deny causes more problems than it solves.  People will have the least amount of access of the combination of Share access and Security.  Think of Share rights as remote rights and Security as local rights.  You may have full control if you're logged on to the machine locally, but if your Share rights are Read you will only be able to Read when connecting to the Share remotely.



#5 windranger

windranger
  • Topic Starter

  • Members
  • 32 posts
  • OFFLINE
  •  
  • Local time:04:54 AM

Posted 31 August 2017 - 08:10 AM

Thanks for coming up with many possible solutions.
 
What I did is I tried accessing with command  //computername/sharedfolder  and it worked.   I can see the shared folders on the other computer from any of the PCs.
I posted a screenshot from the XP PC here:
The XP's name is Goodguy-pc;  the W10 PC's name is Home-pc
 
Now I have the following questions:
1. After accessing the location with the above command, the shared folder (music) showed under "Web Client Network".
But shouldn't it be displayed under Workgroup..?
 
2.  Until I specifically accessed location  //computername/sharedfolder , the shared folder on the other PC was not visible in Entire Network.
I think this behavior is not normal... why doesnn't it show there from the beginning...?





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users