Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows 7 leaving icon in folder after delete?


  • Please log in to reply
27 replies to this topic

#1 20GT

20GT

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:30 AM

Posted 25 August 2017 - 06:53 PM

My Windows 7 is leaving the item in folder after i delete it. It's not officially there and disappears when the folder is re-entered. 
 
Does anyone know why this is happening?


BC AdBot (Login to Remove)

 


#2 dropbear

dropbear

  • Members
  • 134 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Brisbane
  • Local time:03:30 PM

Posted 25 August 2017 - 06:56 PM

if you hit F5 (refresh) does it disappear as well?

is it just some sort of time delay thing?, is the PC generally slow?

when deleted, if you wait 30'ish seconds, do the icons go automatically?

 

what is the icon is question, what file are you deleting?


Edited by dropbear, 25 August 2017 - 06:57 PM.

Instead of reading this, why not do a backup of your PC.

You won't regret it.


#3 20GT

20GT
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:30 AM

Posted 25 August 2017 - 07:26 PM

any file, text, pic deleted will stay as long as it is not refreshed no time limit

F5 makes it disappear



#4 dropbear

dropbear

  • Members
  • 134 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Brisbane
  • Local time:03:30 PM

Posted 26 August 2017 - 01:28 AM

go to Tools > Folder Options in Windows Explorer, click the View tab, hit the Reset Folders button.

does that help?


Instead of reading this, why not do a backup of your PC.

You won't regret it.


#5 zainmax

zainmax

  • Banned
  • 344 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:30 AM

Posted 26 August 2017 - 04:40 AM

@dropbear said absolutely correctly, deleted icons or files snapshots (which is sometimes used instead the icons) disappeare always after refresh, but sometimes happens, they will not . It means, that folder default settings or some other Windows default settings are changed or missing. Using default settings the folder refreshes always itself automatically. So, first suggest reset folder default settings and clean  cache and junk files. If needed, check also system files integrerity and correctness.
(Run => sfc.exe /scannow, you must run in administrator privileges)


#6 20GT

20GT
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:30 AM

Posted 26 August 2017 - 08:26 AM

go to Tools > Folder Options in Windows Explorer, click the View tab, hit the Reset Folders button.

does that help?

Done didn't help

 

 

@dropbear said absolutely correctly, deleted icons or files snapshots (which is sometimes used instead the icons) disappeare always after refresh, but sometimes happens, they will not . It means, that folder default settings or some other Windows default settings are changed or missing. Using default settings the folder refreshes always itself automatically. So, first suggest reset folder default settings and clean  cache and junk files. If needed, check also system files integrerity and correctness.
(Run => sfc.exe /scannow, you must run in administrator privileges)

 

I reset folder default settings and clean cache and junk files.

and ran sfc.exe /scannow 

 

I went to documents created a new tex file and deleted it and it worked correctly. 
Just to be positive I went to the folder that I originally saw the problem and repeated the test .
It failed. the text file remained seen, I went to back to documents created a new tex file and deleted it and it also failed.

Edited by 20GT, 26 August 2017 - 08:27 AM.


#7 EZSPIRIT

EZSPIRIT

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:01:30 AM

Posted 26 August 2017 - 06:33 PM

Hi 20GT
Have you tried renaming the file, and then deleting it? If that doesn't work maybe this will help. https://www.bleepingcomputer.com/download/iobit-unlocker/



#8 20GT

20GT
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:30 AM

Posted 26 August 2017 - 06:45 PM

Hi 20GT
Have you tried renaming the file, and then deleting it? If that doesn't work maybe this will help. https://www.bleepingcomputer.com/download/iobit-unlocker/

 

thanks but I think you're not really understanding what's going on. The file deletes, but does not disappear from the folder until refreshed. 

 

So maybe the problem is the folder is not refreshing after the delete?



#9 JohnC_21

JohnC_21

  • Members
  • 22,592 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:30 AM

Posted 26 August 2017 - 07:49 PM

Try the following.

 

Rebuild indexing. If rebuilding the index does not work:

 

Reset Folders



#10 20GT

20GT
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:30 AM

Posted 27 August 2017 - 02:39 PM

Try the following.

 

Rebuild indexing. If rebuilding the index does not work:

 

Reset Folders

 

rebuild indexes and reset folders again but it didnt fix anything



#11 JohnC_21

JohnC_21

  • Members
  • 22,592 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:30 AM

Posted 27 August 2017 - 04:27 PM

I could have sworn I didn't see those previous posts when I posted my suggestion.

 

Have you tried rebuilding he icon cache?

 

https://www.sevenforums.com/tutorials/49819-icon-cache-rebuild.html



#12 20GT

20GT
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:30 AM

Posted 27 August 2017 - 06:01 PM

I could have sworn I didn't see those previous posts when I posted my suggestion.

 

Have you tried rebuilding he icon cache?

 

https://www.sevenforums.com/tutorials/49819-icon-cache-rebuild.html

 

just tried still didnt fix it



#13 JohnC_21

JohnC_21

  • Members
  • 22,592 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:30 AM

Posted 27 August 2017 - 06:14 PM

I'm out of ideas on this one. It has been mentioned that it's common when using libraries. There's a couple of long threads out there. You can google Explorer does not refresh after file deletion.



#14 FreeBooter

FreeBooter

  • Members
  • 3,137 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Turkey - Adana
  • Local time:08:30 AM

Posted 27 August 2017 - 09:16 PM

I would like you to check the integrity of your HDD.

  • Please type cmd.exe into Start Menu search box.
  • Please right click cmd.exe and select "Run as administrator".
  • Please type the following command and press the <Enter> key: Chkdsk  C: /r



Share your knowledge. Its a way to achieve immortality.
- Dalai Lama

 

 


#15 HyperHenry

HyperHenry

  • Malware Study Hall Junior
  • 773 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Iowa (but travel)
  • Local time:12:30 AM

Posted 27 August 2017 - 10:31 PM

Are you deleting something or uninstalling something? If you deleted it you should be able to just delete the folder and be done with it.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users