Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Steam unable to install successfully on Zorin 12


  • Please log in to reply
6 replies to this topic

#1 TOMIS13LACK

TOMIS13LACK

  • Members
  • 213 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:30 AM

Posted 19 August 2017 - 11:23 PM

I am trying to install steam on Zorin 12 64 bit. When i do "steam" in terminal, it begins to update. This is what i have thus far:

tom@Tom-pc:~$ steam
Running Steam on zorin 12 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1500335472)
Installing breakpad exception handler for appid(steam)/version(1500335472)
Installing breakpad exception handler for appid(steam)/version(1500335472)
Installing breakpad exception handler for appid(steam)/version(1500335472)
Installing breakpad exception handler for appid(steam)/version(1500335472)
[S_API FAIL] SteamAPI_Init() failed; create pipe failed.[S_API FAIL] SteamAPI_Init() failed; create pipe failed.[S_API FAIL] SteamAPI_Init() failed; create pipe failed.^C

// the [S_API FAIL] SteamAPI_Init() failed; create pipe failed. loops forever. Because of this my "steam" process uses 25% of cpu.

anyone have any idea as to what i could do to fix this?


ooh, i have a signature


BC AdBot (Login to Remove)

 


#2 NickAu

NickAu

    Bleepin' Fish Doctor


  • Moderator
  • 13,543 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:127.0.0.1 Australia
  • Local time:04:30 PM

Posted 19 August 2017 - 11:35 PM

Have you tried this?

 

https://steamcommunity.com/groups/LinuxOptimus/discussions/1/864951657810357639/



#3 TOMIS13LACK

TOMIS13LACK
  • Topic Starter

  • Members
  • 213 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:30 AM

Posted 19 August 2017 - 11:57 PM

 

The link you provided me is a solution to games not running. In my case, steam will not run.


ooh, i have a signature


#4 NickAu

NickAu

    Bleepin' Fish Doctor


  • Moderator
  • 13,543 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:127.0.0.1 Australia
  • Local time:04:30 PM

Posted 20 August 2017 - 12:01 AM

That's all Im finding searching those errors.



#5 TOMIS13LACK

TOMIS13LACK
  • Topic Starter

  • Members
  • 213 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:30 AM

Posted 20 August 2017 - 12:05 AM

That's all Im finding searching those errors.

 

I have solved it. I had originally installed through a .deb file. I uninstalled it that way and reinstalled it through terminal (apt-get) and it ran. That worked for some reason. Thanks for your help.


ooh, i have a signature


#6 NickAu

NickAu

    Bleepin' Fish Doctor


  • Moderator
  • 13,543 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:127.0.0.1 Australia
  • Local time:04:30 PM

Posted 20 August 2017 - 01:07 AM

Good job,



#7 DeimosChaos

DeimosChaos

  • BC Advisor
  • 1,420 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States, Delaware
  • Local time:01:30 AM

Posted 29 August 2017 - 08:57 AM

The .deb file was probably broken. I would always just install via 'apt-get' if the package is there. If its not, that is different, but if its in the repositories I would use that over using a .deb package that you downloaded.


OS - Ubuntu 14.04/16.04 & Windows 10
Custom Desktop PC / Lenovo Y580 / Sager NP8258 / Dell XPS 13 (9350)
_____________________________________________________
Bachelor of Science in Computing Security from Drexel University
Security +





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users