Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Cannot disable windows Hotkeys


  • Please log in to reply
11 replies to this topic

#1 Cue777

Cue777

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:10:18 AM

Posted 19 August 2017 - 10:00 AM

I am using Windows 10 Home edition 64bit and I cannot get the Windows hotkeys to disable. I am using it for a arcade game so I dont need any keyboard shortcuts like ctrl +a, etc that kick me out of the game.

 

I have installed the group policy editor (since it was not in the home edition already)  and disabled them in that, I have also disabled them in the Intel Graphics driver by right clicking on the desktop and going into the graphics options, I have also disabled them by editing the registry, but they still keep on working!

 

Any ideas how to disable them?



BC AdBot (Login to Remove)

 


#2 sikntired

sikntired

  • Members
  • 1,087 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:09:18 AM

Posted 19 August 2017 - 10:16 AM

Might be of interest, however don't know if it will work with Win 10.

https://msdn.microsoft.com/en-us/library/windows/desktop/ee416808(v=vs.85).aspx

#3 JohnC_21

JohnC_21

  • Members
  • 24,676 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:18 AM

Posted 19 August 2017 - 10:35 AM

Did you disable individual keys as shown in the below link? End of the page.

 

https://www.ghacks.net/2015/03/22/how-to-disable-specific-global-hotkeys-in-windows/



#4 Cue777

Cue777
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:10:18 AM

Posted 19 August 2017 - 10:46 AM

I did not try the individual keys, the Windows key isn't really a problem, its the ctrl key. I can try that later tonight when I get home.



#5 JohnC_21

JohnC_21

  • Members
  • 24,676 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:18 AM

Posted 19 August 2017 - 10:54 AM

Good luck, fingers crossed.



#6 Cue777

Cue777
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:10:18 AM

Posted 19 August 2017 - 10:57 AM

Thats only for the windows key though it seems? That key isnt my problem, it is the ctrl key combos.



#7 JohnC_21

JohnC_21

  • Members
  • 24,676 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:18 AM

Posted 19 August 2017 - 11:01 AM

I see your point. I'm not sure that hack will solve the generic Crtl combo. There are utilities that can reassign hotkeys. By reassigning the Ctrl + A key to some key combination that is not common would possibly work.

 

Edit: From within Windows.

 

https://www.microsoft.com/accessories/en-us/support/how-to/keyboard/reassign-keys

 

 

After looking at this, it seems it requires the Microsoft Mouse and Keyboard Center. I believe this only supports the Microsoft Mouse and Keyboard but I cannot confirm this.


Edited by JohnC_21, 19 August 2017 - 11:05 AM.


#8 Cue777

Cue777
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:10:18 AM

Posted 19 August 2017 - 11:55 AM

Any ideas on why they wont disable with the reg edit or policy editor?



#9 JohnC_21

JohnC_21

  • Members
  • 24,676 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:18 AM

Posted 19 August 2017 - 12:02 PM

I am not sure. Group Policy is not available in the Home Edition. I can't say if hacking Windows 10 to include the Group Policy Editor would be an issue. 

 

Group Policy Editor basically does the same as editing the Registry Manually. When you edit the Registry keys does the edit stick once you reboot? If not then you would need to change the ownership permissions of the registry keys.



#10 Cue777

Cue777
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:10:18 AM

Posted 19 August 2017 - 12:16 PM

I didn't check it again to see if the reg edit stayed after a reboot, ill check that also tonight.



#11 Cue777

Cue777
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:10:18 AM

Posted 21 August 2017 - 06:30 PM

Well nothing worked, I edited the registry to stop the windows key from working and that worked but not the other keyboard shortcuts so I had to download a 3rd party software program to disable them.



#12 JohnC_21

JohnC_21

  • Members
  • 24,676 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:18 AM

Posted 21 August 2017 - 06:54 PM

Thanks for the update. What 3rd party utility did you use?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users