Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Audio permission issues


  • Please log in to reply
7 replies to this topic

#1 Overkillian

Overkillian

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:44 PM

Posted 18 August 2017 - 04:46 PM

Mod Edit:  Split from https://www.bleepingcomputer.com/forums/t/502384/conexant-smartaudio-hd-sound-card-enable-stereo-mix/ - Hamluis.

 

  • Windows will not let you modify the chdrt.inf file without changing file permissions.
    • Right click on chdrt.inf filename and select Properties
    • Go to the Security tab and click on the Edit button
    • In the "Groups or user names" box, highlight the Users profile
    • In the "Permissions for Users" box, check the "Allow" checkbox next to "Full Control". This will place check boxes in all permissions.
    • Click Apply
  • Right click on chdrt.inf filename and select "Open With" then choose Notepad
  • Hit Control+F then search for StereoMixEnable to find the three lines:

;HKR,%EPattributePath%\EpSettings\StereoMixEnable,Enable,1,01

;HKR,%EPattributePath%\EpSettings\StereoMixEnable,MixAssocSeq,1,E0,E0

;HKR,%EPattributePath%\EpSettings\StereoMixEnable,MuteGainSettings,1,00,00

  • Delete the semi-colons (;) at the beginning of each line and save the file (Save as chdrt.inf with All Files selected as file type)
  • This step is VERY important. You must change back the file permissions to the way they were. Please follow these directions exactly or you could put your computer at risk:
    • Right click on chdrt.inf filename and select Properties
    • Go to the Security tab and click on the Edit button
    • In the "Groups or user names" box, highlight the Users profile
    • In the "Permissions for Users" box, uncheck the "Allow" checkbox next to "Full Control". This will remove checks in the checkboxes for all permissions
    • Check the "Allow" checkbox next to "Read & Execute" and "Read"
    • Click Apply

 

 

Sorry for thread-digging, but I got tricked in the process of doing this.

I'm on a Windows 10 Lenovo laptop (15-IBD) and I can't even edit the permissions at all in any way. ALL options are greyed out when I enter into security -> edit. How do you do this?


Edited by hamluis, 19 August 2017 - 08:10 AM.


BC AdBot (Login to Remove)

 


#2 mjd420nova

mjd420nova

  • Members
  • 1,742 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:44 AM

Posted 20 August 2017 - 06:05 PM

I've had real good luck with Lenovo's on-line support site.



#3 JohnC_21

JohnC_21

  • Members
  • 23,275 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:44 PM

Posted 29 August 2017 - 06:33 PM

You can also edit this file with a live linux disk and not worry about permissions. 



#4 mightywiz

mightywiz

  • Members
  • 704 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:44 AM

Posted 30 August 2017 - 11:46 AM

try this:

in the search bar type "notepad", when it pops up at the top of the list right click it and select "open as admin"

 

then select file - open and choose your chdrt.inf file.

then make your changes

when you save - select "save as" and make sure you type "chdrt.inf" in the name box.  if you don't add the .inf it will save as a text file instead of an inf file.

 

this is how I modify all windows files, i've never messed with the permissions to do it.


Edited by mightywiz, 30 August 2017 - 11:47 AM.


#5 Overkillian

Overkillian
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:44 PM

Posted 06 October 2017 - 03:57 PM

Sorry for being absent from my own question and not replying - I didn't notice the thread split for long, but simply thought it vanished from the other thread.

 

Sure, I can change the text and save as a new file - but I'm not allowed to save it in the System32 subfolder it's in (C:\Windows\System32\DriverStore\FileRepository\g15plmwa.inf_amd64_4d5310668bb0850f\g15plmwa.inf in my case).



#6 rqt

rqt

  • Members
  • 374 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:07:44 PM

Posted 06 October 2017 - 04:03 PM

Can you save it elsewhere & then copy it to the desired location?? (this has worked for me on similar problems)



#7 Overkillian

Overkillian
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:44 PM

Posted 09 October 2017 - 03:29 PM

Nope, only to System32 main folder, neither of the three subfolders (\DriverStore\FileRepository\g15plmwa.inf_amd64_4d5310668bb0850f).

It doesn't allow me, saying I 'need permission' to do so with a 'retry' button.


Edited by Overkillian, 09 October 2017 - 03:31 PM.


#8 seth_nesta

seth_nesta

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:08:44 PM

Posted 11 October 2017 - 06:01 AM

On Windows 10, the difficulty is to modify and then apply again the driver because of file protection of windows (digital signature). Once the file is modified, Windows can't applied it because it has been modified.

 

So I managed to solve by launching a search on "g15plmwa.inf" and by modifying each one as suggested above.

 

And finaly I deleted the device in "Device Manager" (without delete driver) and lauched a new hardware detection and let the system install again the sound device.

 

Now "Stereo Mix" is available !






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users