Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Cursor problem, connected to malware or corrupted drivers possibly


  • Please log in to reply
41 replies to this topic

#1 blinky88

blinky88

  • Members
  • 68 posts
  • OFFLINE
  •  
  • Local time:08:15 AM

Posted 17 August 2017 - 09:37 AM

Original post in Virus/Malware section, with screenshots and steps already taken (thanks to Satchfan for trying to help me, she suggested to post here in Windows section):

https://www.bleepingcomputer.com/forums/t/651520/strange-evolving-cursor-prob-suspected-malware-or-virus/

 

 

 

***** SYMPTOMS *****

1. CURRENTLY, MY MOUSE IS CHANGING OR TWITCHING TO PIXELATED VERSION WHEN OPENING A PROGRAM OR APPLICATION. ORIGINALLY IT DISAPPEARED ON REBOOT, BUT IT COMES BACK A FEW HOURS LATER, (POSSIBLY FUELED BY A HIDDEN OR CORRUPTED PROGRAM?)

2. 2ND CURSOR, BLACK COLOUR STUCK ON SCREEN SOMETIMES (RANDOM BUT GONE FOR NOW)

3. THE SCREEN IS REFRESHING ITSELF OR TWITCHING OCCASIONALLY. 

4. BACKGROUND THEME CHANGED ITSELF. CURRENTLY I CANT FIX THIS...ALL MY ICONS ARE 'INDENTED' FROM EACH SIDE OF THE SCREEN ON THE DESKTOP BACKGROUND.

5. AVAST SHIELDS TURNED OFF RANDOMLY TWICE (SEEMS TO HAVE STOPPED AFTER ALL THE SCANS).

*****

 

My system: 

Lenovo ideapad 310-15ABR  

AMD A12-9700P 7th gen.

RADEON R7

10 COMPUTE CORES 4C+6GS 2.50GHZ

12GB RAM

Windows 10 64bit

 

Over the years, (on 4 laptops) im reasonably tech-savvy, and have always kept a smoothly run pc/laptop. Ultimately, using the below programs (free versions):

the main 4:

Avast. (high heuristics, deep and rootkits enabled)

Ccleaner.

Superantispyware.

Malwarebytes.

 

and others, when i did get more pesky or persistent issues:

Hijackthis.

S and D Spybot. 

Kaspersky AV. (high heuristics and roots)

Hitman Pro.

AVG (only in the past- havent used this in years since everyone complained about removal issues).

 

As far as i know, these are the best of their kind and despite being free versions they have very rarely let me down over the years.... untill now i guess! 

 

The programs above that can be, were run in safemode to ensure max effectiveness.

 

I have tried 2 restore points and this problem has come back. 

 

Tried reinstalling most programs and updating them, manually. including AMD GRAPHICS for the desktop flickering/refreshing issue. 

 

I assume its from a TORRENT file possibly, be it pirate copy of a large game folder... or just music files. ...but i have used file scanner (deep scan) from avast, kaspersky and spybot with no hits. 

 

*I then scanned my external hard drives and did come back with a TROJAN.WIN32, with Kaspersky on my WD 2tb drive, INCLUDING Avast getting 2 files in a torrented game file (see attached screenshots).

*i have NOT scanned my phones yet (on the agenda however).

*i have NOT tried AVG yet.

 

Im reduced to my knees now, as im concerned my system could be compromised at the deepest undetectable level, and i reeeeeally dont want to have to reset this PC, as i have programs i cant get back ...'sigh' :(

 

 

Superrr appreciate any help from you guys... and apologies if im a bit scatty with my procedure or explanations, ha!

Cheers


Edited by blinky88, 17 August 2017 - 09:40 AM.


BC AdBot (Login to Remove)

 


m

#2 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 5,597 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:12:15 AM

Posted 17 August 2017 - 04:19 PM

Among the list of things you say you have done you do not say you tried uninstalling the mouse drivers themselves.

 

If you haven't done this then 'Device manager - expand 'Mice and other pointing devices' - double click on each entry for 'Mice' - Drivers - Uninstall'

 

This then leaves you with the slightly inconvenient process of using your keyboard to shut down your computer but the use of 'Ctrl+Alt+Del' and the tab key makes it possible. New drivers will be installed when you re-boot.

 

Chris Cosgrove



#3 blinky88

blinky88
  • Topic Starter

  • Members
  • 68 posts
  • OFFLINE
  •  
  • Local time:08:15 AM

Posted 18 August 2017 - 07:42 AM

Ok Chris, il give it a shot!

It was in my list of things im gradually working through. The reason i hadnt tried that yet is because it seems something has caused all of these 'symptoms' and got worse up until this day. So instead of fixing these one by one, which i already tried by fixing the desktop and avast shields issue (with no real results), i was trying to find the 'root cause'.

 

*additionally, i'm getting a black but what seems to be 'blank' command line box flash up briefly after each startup (again this could be nothing, but i thought i should mention it at least).

 

(and also by fixing these one by one, i was worried i might hide all evidence of the virus/malware, and never really no if its gone properly - a friend once described to me think of a virus or malware like a weed, and cutting it down back to the ground isnt good enough, you have to kill the root... anyway, im sure you know more on this subject than i, ha).

cheers :)

 

(off topic.. is autospell off here in reply section? or is it my computer?) :/



#4 dc3

dc3

    Bleeping Tree Hugger


  • Members
  • 29,299 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:04:15 PM

Posted 18 August 2017 - 09:20 AM

Spell check is a function of your browser.


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#5 blinky88

blinky88
  • Topic Starter

  • Members
  • 68 posts
  • OFFLINE
  •  
  • Local time:08:15 AM

Posted 21 August 2017 - 11:17 AM

Mouse drivers in device manager uninstalled and then rebooted. they came back, however the Synaptic driver in device manager (2nd driver under mouse pointer driver) hasn't come back and so i cant use all functions of the touchpad. 

 

i'll monitor the computer more now for the next couple days, as i had a long weekend and didnt have the machine on enough to see if this problem came back or not.

 

Hmm i should reinstall the synaptic drivers from the Lenovo website, unless you object?

 

cheers guys :)



#6 blinky88

blinky88
  • Topic Starter

  • Members
  • 68 posts
  • OFFLINE
  •  
  • Local time:08:15 AM

Posted 24 August 2017 - 01:45 PM

Anybody know how i can fix my desktop in the meantime?   ...or seen similar problem with windows 10 desktops?

 

4. BACKGROUND THEME CHANGED ITSELF. CURRENTLY I CANT FIX THIS...ALL MY ICONS ARE 'INDENTED' FROM EACH SIDE OF THE SCREEN ON THE DESKTOP BACKGROUND.

 

cheers



#7 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 5,597 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:12:15 AM

Posted 24 August 2017 - 05:30 PM

I saw a report earlier today that might bear on this problem.

 

 

Build 16273 bug fixes include resolving an issue where Facebook status updates got erased during input in the Edge browser, icons couldn't be dragged and dropped around the desktop and the full touch keyboard was "unexpectedly not available" at some screen resolutions.

 

The Register :-  http://www.theregister.co.uk/2017/08/24/windows_insider_build_16273/

 

Chris Cosgrove



#8 blinky88

blinky88
  • Topic Starter

  • Members
  • 68 posts
  • OFFLINE
  •  
  • Local time:08:15 AM

Posted 25 August 2017 - 07:13 PM

Ok possibly, but I don't see any fixes or links on that page...hmmm.
Then there's the twitching of the screen as another symptom ..kind of like a ram related problem with icons refreshing every 10mins or so.

#9 dc3

dc3

    Bleeping Tree Hugger


  • Members
  • 29,299 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:04:15 PM

Posted 26 August 2017 - 08:19 AM

Mouse drivers in device manager uninstalled and then rebooted. they came back, however the Synaptic driver in device manager (2nd driver under mouse pointer driver) hasn't come back and so i cant use all functions of the touchpad.

 

i should reinstall the synaptic drivers from the Lenovo website, unless you object?

Yes, download and install the Synaptic touchpad driver from the Linovo Support download site.


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#10 blinky88

blinky88
  • Topic Starter

  • Members
  • 68 posts
  • OFFLINE
  •  
  • Local time:08:15 AM

Posted 28 August 2017 - 03:09 PM

The problem is back... :(

 

1. this time it was a slightly different cursor... like a mini-cursor, so thats 3 diff types of cursor i have seen now since this problem started 2months ago now!

 

2. the black command box that flashes up shortly after each startup also worries me, too fast to read it but i can video it in a while (dont remember ever seeing that before in the past).

 

If everyone is out of ideas, what are my windows 10 recovery options? ...resetting my pc says it can keep my files...maybe i should try this then if not, the next option which wipes the whole system right?

i really didnt want to have to 'nuke' my system but this is worrying me greatly and i dont see any other way.

 

Appreciate any help i can get. Cheers :)



#11 HyperHenry

HyperHenry

  • Members
  • 243 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Iowa (but travel)
  • Local time:07:15 PM

Posted 28 August 2017 - 08:47 PM

Are you using a PCI video card? If so have you downloaded the drivers for it? If you haven't already, I'd download every driver update available for your machine.



#12 dc3

dc3

    Bleeping Tree Hugger


  • Members
  • 29,299 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:04:15 PM

Posted 29 August 2017 - 08:20 AM

Please download and install Speccy to provide us with information about your computer.  Clicking on this link will automatically initiate the download.

When Speccy opens you will see a screen similar to the one below.

 speccy1.png

Click on File which is outlined in red in the screen above, and then click on Publish Snapshot.

 speccy2.png

The following screen will appear, click on Yes.

 speccy3.png

The following screen will appear, click on Copy to Clipboard.

In your next post right click inside the Reply to Topic box, then click on Paste.  This will load a link to the Speccy log.


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#13 blinky88

blinky88
  • Topic Starter

  • Members
  • 68 posts
  • OFFLINE
  •  
  • Local time:08:15 AM

Posted 31 August 2017 - 12:04 AM

Sorry not sure PCI... its AMD shared, not dedicated.

Im pretty sure my drivers are all updated as i went trough each device manager and updated each and every aspect of my machine. Including the Lenovo scanning LSB bridge thing on their website.

Oh i also periodically check and update via the Radeon app that is always running and in my taskbar :)

 

I will double check all of this tonight, although to be honest ive had my doubts ever since i bought this machine that the graphics or video software/hardware never ran properly or performed to what was promised (before sale), but found it to be a bottomless pit after talking to AMD contact via email for 3weeks and testing the graphics with stress tests and stuff (star swarm i believe?).

 

Are you using a PCI video card? If so have you downloaded the drivers for it? If you haven't already, I'd download every driver update available for your machine

 

 

 

My specs ..via speccy app:

http://speccy.piriform.com/results/opoSti3BbaJlg7VwirQizHL

 

Cheers guys

:D



#14 blinky88

blinky88
  • Topic Starter

  • Members
  • 68 posts
  • OFFLINE
  •  
  • Local time:08:15 AM

Posted 31 August 2017 - 12:17 AM

Im not sure Speccy is too accurate, as my system, AMD app and CCleaner says i have 8+4gb ram and a few other discrepancies... maybe its not important, but just thought i should add that.

thanks



#15 HyperHenry

HyperHenry

  • Members
  • 243 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Iowa (but travel)
  • Local time:07:15 PM

Posted 31 August 2017 - 08:18 AM

Do you have a PCI video card you can put in to test it?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users