Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Windows 10 64-bit won't boot

  • Please log in to reply
3 replies to this topic

#1 GasparB123


  • Members
  • 1 posts
  • Local time:07:08 PM

Posted 16 August 2017 - 12:06 PM

I recently bought a PC (Specs below), and I made a clean install of Windows 10 64-bit from a USB using UEFI, which it supports. The instalation process goes normally, and after restarting the PC, the strangest thing happens. I take out the USB stick and when it tries to boot from the HDD, I get a "Reboot and Select Proper Boot Device" message on my screen. The weirdest thing is when I put the USB stick in it's slot, and choose to boot from the HDD, the computer boots up the installation screen again.


When I try to use legacy to boot and install Windows 10 it won't let me telling me I must have my SATA controllers activated, which they are.


I'm not really all that experienced with computers but I have done this before and this has never happened to me, and I can't seem to find anyone on the internet with this specific problem.


My PC:


Gigabyte B250M-DS3H (F3 BIOS)

Intel Core i5-7400

8GB DDR4 RAM Memory

Intel HD Graphics 630


Edited by GasparB123, 16 August 2017 - 12:46 PM.

BC AdBot (Login to Remove)


#2 mightywiz


  • Members
  • 874 posts
  • Gender:Male
  • Local time:02:08 PM

Posted 21 August 2017 - 01:39 PM

you may have to create a windows 10 disk and then do a repair from the disk.  i think what has happened is your drive letters are messed up when the 

usb stick is unplugged. and that's why you can select the hdd when the usb stick is in.


when you pull the usb stick out then drive assignments change and it doesn't boot correctly.

#3 dc3


    Bleeping Treehugger

  • Members
  • 30,757 posts
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:02:08 PM

Posted 21 August 2017 - 02:00 PM

There are a couple of things which can cause this error message.  Not having the boot order set properly, it should have the hdd as the first boot device, then the dvd, etc.



Another problem could be that you have the Legacy option enabled.  If this is the case open the UEFI and disable the Legacy option.  You can find some good information regarding this here.

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.





#4 gamehay24h


  • Members
  • 1 posts
  • Gender:Male
  • Location:Argentinal
  • Local time:05:08 AM

Posted 21 August 2017 - 09:33 PM

If you boot from USB, you need set for USB start first in BIOS

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users