Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Computer turns on by itself at midnight

  • Please log in to reply
7 replies to this topic

#1 bertiemae


  • Members
  • 80 posts
  • Local time:07:52 PM

Posted 12 August 2017 - 09:15 AM

I started having a problem with my windows 7 Home Edition Dell computer with it turning on by itself so I had it reformatted and it still turns on at midnight.  Under power options and advanced settings I change the sleep to Disable wake timers and that didn't help. I looked in the task scheduler and typed in the command prompt window to see what was last run and there's nothing there. I have searched the web for suggestions and tried them all.  So I was wondering if someone here has any other helpful hints that might work to stop computer from turning on by itself at midnight. Thanks,  Alberta

BC AdBot (Login to Remove)



#2 Just_One_Question


  • Members
  • 1,400 posts
  • Gender:Male
  • Location:Bulgaria
  • Local time:03:52 AM

Posted 12 August 2017 - 09:54 AM



Not too sure, but try this:


Right-click on your desktop. Then, Create a new shortcut. Then, when it asks you to where you need that shortcut, type the following


shutdown /s /t 0


Then, close everything on your computer. Then, open that shortcut. Then, your computer will turn off. Then, wait 1 minute. Then, start your computer. Then, the problem might be solved.


Good luck! :)

#3 bertiemae

  • Topic Starter

  • Members
  • 80 posts
  • Local time:07:52 PM

Posted 12 August 2017 - 09:59 AM

Thanks. I will try that but won't know if it worked until after midnight tonight as that's when it turns on. Will let you know tomorrow.

#4 buddy215


  • BC Advisor
  • 12,752 posts
  • Gender:Male
  • Location:West Tennessee
  • Local time:07:52 PM

Posted 12 August 2017 - 10:30 AM

Since the same happened after a reinstall of Windows...then I would think it is something in the BIOS. If

the fix by Just One doesn't solve the problem then check out the solutions in this link:

[SOLVED] Why Is My Computer Turning On By Itself? - Tech Support Forum

“Every atom in your body came from a star that exploded and the atoms in your left hand probably came from a different star than your right hand. It really is the most poetic thing I know about physics...you are all stardust.”Lawrence M. Krauss

A 1792 U.S. penny, designed in part by Thomas Jefferson and George Washington, reads “Liberty Parent of Science & Industry.”

#5 SleepyDude


  • Malware Response Team
  • 2,953 posts
  • Gender:Male
  • Location:Portugal
  • Local time:12:52 AM

Posted 12 August 2017 - 10:32 AM



Post the brand and model of the computer please.


Did you check the BIOS/UEFI? some of them have options to power on the machine at certain time.

• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

Proud graduate of GeekU and member of UNITE


#6 FreeBooter


  • Members
  • 3,135 posts
  • Gender:Male
  • Location:Turkey - Adana
  • Local time:03:52 AM

Posted 12 August 2017 - 10:36 AM

You can usually figure out what event caused your computer to wake up most recently with a simple Command Prompt command.

Please open the Command Prompt by clicking Start Menu --> All Programs --> Accessories, right-click on Command Prompt, and open it as an administrator.  Execute following command and post a screenshot of the Command Prompt.

powercfg -lastwake

Share your knowledge. Its a way to achieve immortality.
- Dalai Lama



#7 bertiemae

  • Topic Starter

  • Members
  • 80 posts
  • Local time:07:52 PM

Posted 12 August 2017 - 01:55 PM

Thanks for all your input.  Will try each suggestion.  Alberta

#8 joseibarra


  • Members
  • 1,049 posts
  • Gender:Male
  • Location:Downstairs
  • Local time:08:52 PM

Posted 15 August 2017 - 03:08 AM

Anybody that thinks it might be a Scheduled Task, just try to set up a Scheduled Task on your own system to wake it up at midnight when it is shutdown (not sleeping) and you will see what I mean, then tell us how that works out for you.  Can you get it to work?

It is more likely that your system is getting a "magic packet" from your Internet Service provider (ISP).

That means that even if the system is turned off, some systems have a feature that will wake them up when there is some activity on their Internet connection - even if the machine is powered off (that is by design and can be useful).

Sometimes this can be referred to as receiving a "magic packet" that is just what the system needs to see on the Internet connection to wake itself up.   Often these things seem to happen shortly after midnight when your Internet Service Provide (ISP) might be sending out these magic packets.

You can read some about it here:



Wake on LAN (WoL) support is sometimes implemented in the motherboard of the computer.  Most modern motherboards with an embedded Ethernet controller support WoL so you need to find that option/feature and disable it.

To test the WoL theory, the next time you turn off your computer for the day, physically unplug the Internet connection from the computer and then wait (as long as you think it takes to convince you) and see if the system turns itself on or not when the cable is unplugged at the time you suspect - after waiting longer than it usually takes for it to turn on by itself (which may be overnight).  That means you may have to wait a day or two to test this idea.

There could be a setting in your system BIOS to enable/disable this feature or in your network card, but since we don't know anything about your system, that is just a guess.  You can look around in your system BIOS and see if you can spot this feature and disable it, save the setting and see how things look.

You might visit the manufacturers web site for your system to see how to disable this feature.

There could also be a setting to disable in the Properties of your network interface card to not allow the system to be started or come out of hibernation or standby/sleep on a signal from the device or router.  You can look in Device Manager and the Properties of your device for those settings and disable those features.

Look for a "Power Management" tab.




On my motherboard in the system BIOS settings under Power Management is a section called "Wake Up Setup Event" and under that are the various ways that one could configure the system to wake up from some event.  Under that section are things like keyboard, mouse and one is "Resume by Onboard LAN" which if I enable that, and the correct "magic packet" comes into the built in Ethernet connection, my system would startup by itself.

In Device Manager, Network adapter, for a NVIDIA network controller under Properties, Advanced there are settings called "Wake on Magic Packet" and "Wake on pattern Match" that can be disabled.

Try not to think of it as a Windows thing you need to change - it is more of a hardware thing that has to do with your motherboard and/or network interface and the way you connect to the Internet.


Another possibility is that if you have your system configured to allow a device (mouse or keyboard) to wake the computer with a click or key press and if you have cats they might be walking on your devices and waking the computer.

The mediocre teacher tells. The good teacher explains. The superior teacher demonstrates.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users