Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Chrome fails to check for updates + possibly related DCOM errors?


  • Please log in to reply
3 replies to this topic

#1 CursedLaptop

CursedLaptop

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:04 PM

Posted 05 August 2017 - 09:40 AM

Hi,

 

Problem: Chrome is working perfectly, but it fails to check for updates. DCOM errors in event viewer (?) via MiniToolBox

 

I've been following this guide: https://decentsecurity.com/holiday-tasks/ as part of getting my somewhat neglected Windows 7 laptop up to speed. Windows Update was not working on it for quite some time, but that has been resolved thanks to that guide. It now checks for and downloads/installs Windows updates successfully.

 

So I continued following the guide (deviating a little: I didn't run the MalwareBytes Anti-Malware program, since they didn't offer a portable version, I didn't set UAC to full, and I don't have Windows Search enabled) without issue. But after reinstalling Chrome (part 16 of the guide) I found that it failed to check for updates on the chrome://settings/help page, giving the following error:

 

"An error occured while checking for updates: Update check failed to start (error code 3: 0x80080005 -- system level)."

Version 60.0.3112.90 (Official Build) (64-bit)

 

Note: I checked Firefox (which was also out of date, I am tackling Chrome first) and it checked for and downloaded an update just fine. (The plan is to reinstall that later anyway.)

 

I searched for information about this error, but couldn't really figure out what caused it. I tried:

 

Rebooting.

 

Resetting the ip stack (Worth mentioning that I had to reboot my router and modem a couple times in the middle of it all, but I suspect that was due to my ISP who's warned they are doing scheduled maintenance this summer and interruptions may occur, had a similar interruption a week ago, but I'm back online now).

 

Uninstalling and reinstalling Chrome several times (always using the standalone installer as per the link in the guide), making sure to check for and remove (if any) Google folders in the relevant Appdata & Programdata & Program Files directories.

 

I tried an "sfc /scannow", but it came up with nothing wrong.

 

I noticed the 2 Google Update services (gupdate, gupdatem, in services.msc) were mostly not running at all, or sometimes one of them was, but the update check in Chrome always fails with the same error regardless.

 

I ran MiniToolBox and saw there were some DCOM errors under "System Errors". The most recent one for example, was this one:

"{8A1D4361-2C08-4700-A351-3EAA9CBFF5E4}". Might this be related?

I tried searching about that and came across this thread: http://forums.whirlpool.net.au/archive/2477711

The user mentions it in combination with Google Update, and he appeared to be able to resolve his problem with the help of those guys. I recognized those programs (AdwCleaner, JRT, FRST) and thought of you guys here at Bleeping Computer, so I figured I'd write this up and get your advice on how to proceed, since that particular solution was tailored to that user's specific scenario.

 

So long story short, Chrome is working fine, but I'm worried it might fail to download future updates due to this.

 

Thanks for your help!

CursedLaptop


Edited by CursedLaptop, 05 August 2017 - 09:51 AM.


BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 56,379 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:12:04 PM

Posted 05 August 2017 - 10:33 AM

You can just manually install a new version of Chrome?

 

I don't use Chrome, so I really don't understand what you consider a problem.

 

Louis



#3 CursedLaptop

CursedLaptop
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:04 PM

Posted 05 August 2017 - 10:43 AM

I have manually reinstalled it many times, but every time I try to verify version / check for updates at chrome://settings/help (basically the About Google Chrome page), it gives me that same error every time. So clearly somewhere along the line something is interfering with the update check, causing it to fail. The error, once again, is as follows:

 

"An error occured while checking for updates: Update check failed to start (error code 3: 0x80080005 -- system level)."

Version 60.0.3112.90 (Official Build) (64-bit)


Edited by CursedLaptop, 05 August 2017 - 10:44 AM.


#4 zainmax

zainmax

  • Banned
  • 344 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:04 PM

Posted 05 August 2017 - 11:09 AM

Any of Chrome manually installed version will update automatically never, because any version has its own update program, which is not included in those installer packages, which allows to install manually. 
These installation packages, which allows manually installation are absolutely different of them, which are used for automatical installation.
So, if You have even one time updated manually, You must use the same version auto installer and install it (if possible, very often isn't) and if have success, run Chrome. Then close it and use default uninstaller (not any third party uninstaller) and uninstall it again. Restart computer and install again as should. 
Now it will update automaticaly again.
As soon as You instal for example some beta version, is very difficult go back to stable version, You will get note - not possible to install because a newer version is allready installed.
Also Chrome must be installed in folder even if You have 64-bit computer (very important) - %ProgramFiles(x86)%\Google\Chrome\Application

Edited by zainmax, 05 August 2017 - 11:12 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users