Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Time and Date in dual boot Linux/Windows 10 not accurate


  • Please log in to reply
9 replies to this topic

#1 paul88ks

paul88ks

  • Members
  • 1,289 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Dallas,Texas
  • Local time:05:11 PM

Posted 04 August 2017 - 11:11 PM

 I have a Dual boot Windows 10 / Linux Mint machine. Here's the problem- when I boot into either one,the time will be off 6 hours- I correct it,and boot into the other and the time there is off 6 hours.I correct it,and boot into the other side and the same thing happens again. I placed the bootloader into the Windows bootloader.I don't know if that has anything to do with it or not. Anyone else had this issue,and if so how do I correct it? I have disabled automatic time settings in WIn 10 and set and locked the time settings in Linux,still happens- Paul



BC AdBot (Login to Remove)

 


#2 zainmax

zainmax

  • Banned
  • 344 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:11 AM

Posted 05 August 2017 - 12:03 AM

Operating systems store and retrieve the time in the hardware clock located on your motherboard so that it can keep track of the time even when the system does not have power. Most operating systems (Linux/Unix/Mac) store the time on the hardware clock as UTC by default, though some systems (notably Microsoft Windows) store the time on the hardware clock as the 'local' time. This causes problems in a dual boot system if both systems view the hardware clock differently.

The advantage of having the hardware clock as UTC is that you don't need to change the hardware clock when moving between timezones or when Daylight Savings Time (DST) begins or ends as UTC does not have DST or timezone offsets.

Changing Linux to use local time is easier and more reliable than changing Windows to use UTC, so dual-boot Linux/Windows systems tend to use local time.

Read more about how to fix this problem

https://askubuntu.com/questions/800914/clock-shows-wrong-time-after-switching-from-ubuntu-to-windows-10
http://lifehacker.com/5742148/fix-windows-clock-issues-when-dual-booting-with-os-x
https://www.howtogeek.com/211144/how-to-get-windows-and-linux-clocks-to-display-the-correct-and-matching-time-dual-boot/

Edited by zainmax, 05 August 2017 - 12:04 AM.


#3 paul88ks

paul88ks
  • Topic Starter

  • Members
  • 1,289 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Dallas,Texas
  • Local time:05:11 PM

Posted 05 August 2017 - 01:43 AM

 

Operating systems store and retrieve the time in the hardware clock located on your motherboard so that it can keep track of the time even when the system does not have power. Most operating systems (Linux/Unix/Mac) store the time on the hardware clock as UTC by default, though some systems (notably Microsoft Windows) store the time on the hardware clock as the 'local' time. This causes problems in a dual boot system if both systems view the hardware clock differently.

The advantage of having the hardware clock as UTC is that you don't need to change the hardware clock when moving between timezones or when Daylight Savings Time (DST) begins or ends as UTC does not have DST or timezone offsets.

Changing Linux to use local time is easier and more reliable than changing Windows to use UTC, so dual-boot Linux/Windows systems tend to use local time.

Read more about how to fix this problem

https://askubuntu.com/questions/800914/clock-shows-wrong-time-after-switching-from-ubuntu-to-windows-10
http://lifehacker.com/5742148/fix-windows-clock-issues-when-dual-booting-with-os-x
https://www.howtogeek.com/211144/how-to-get-windows-and-linux-clocks-to-display-the-correct-and-matching-time-dual-boot/

THanks Zainmax! I knew someone would know the answer to this! It's been bugging me for days! The only option I have in Linux Mint 18.2 is to turn on Network Time- I hope that fixes it!



#4 mremski

mremski

  • Members
  • 493 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NH
  • Local time:06:11 PM

Posted 05 August 2017 - 02:20 AM

OP, make sure that BOTH Windows and Linux are set to use Network Time.  On Linux, it's trivial, all one needs is a correctly configured NTP client.  Windows has always been a pain (at least in my experience) to make it use Network Time.  (Is that a typo in your last sentence, did you mean turn on Network Time in Windows, not in Linux?).  Even better if you point both Network Time clients to the same set of Time servers.


FreeBSD since 3.3, only time I touch Windows is to fix my wife's computer


#5 paul88ks

paul88ks
  • Topic Starter

  • Members
  • 1,289 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Dallas,Texas
  • Local time:05:11 PM

Posted 05 August 2017 - 03:11 AM

OP, make sure that BOTH Windows and Linux are set to use Network Time.  On Linux, it's trivial, all one needs is a correctly configured NTP client.  Windows has always been a pain (at least in my experience) to make it use Network Time.  (Is that a typo in your last sentence, did you mean turn on Network Time in Windows, not in Linux?).  Even better if you point both Network Time clients to the same set of Time servers.

I didn't see a place to set Network time in Windows. Did you mean the automatically set the date and time check box?



#6 Rocky Bennett

Rocky Bennett

  • Members
  • 2,597 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Mexico, USA
  • Local time:04:11 PM

Posted 05 August 2017 - 06:19 AM

I always just set all of my Linux installations to use local time instead of UTC. I am triple booting right now and I have everything set to Microsoft's local time. It is the easiest way that I know how to get past this problem.


594965_zpsp5exvyzm.png


#7 mremski

mremski

  • Members
  • 493 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NH
  • Local time:06:11 PM

Posted 06 August 2017 - 04:42 AM

OP, On windows 7, right click the time widget in the taskbar, "Adjust Data and Time", a tab labelled "Internet Time".  That was Win7, Win10, no idea.


FreeBSD since 3.3, only time I touch Windows is to fix my wife's computer


#8 zainmax

zainmax

  • Banned
  • 344 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:11 AM

Posted 06 August 2017 - 05:31 AM

I always just set all of my Linux installations to use local time instead of UTC. I am triple booting right now and I have everything set to Microsoft's local time. It is the easiest way that I know how to get past this problem.

You did absolutely correct,. Just this I recommended to do, but seems like it is for him impossible to understand.



#9 paul88ks

paul88ks
  • Topic Starter

  • Members
  • 1,289 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Dallas,Texas
  • Local time:05:11 PM

Posted 06 August 2017 - 06:09 PM

I understand perfectly my friend! It's all good now!



#10 zainmax

zainmax

  • Banned
  • 344 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:11 AM

Posted 06 August 2017 - 07:05 PM

I understand perfectly my friend! It's all good now!

Then everything is OK. Thank you for saying that the question has been resolved.

Good luck.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users