Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Mouse software won't work?


  • Please log in to reply
1 reply to this topic

#1 TheHarmacist

TheHarmacist

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:11:52 AM

Posted 02 August 2017 - 09:45 PM

I'm not 100% sure this is the right spot for this post, but anyway..

 

Some time ago, I purchased a Thermaltake Theron mouse. Said mouse came with a disc for installing color and configuration software for the mouse. The mouse itself is plug-n-play, the software controls configuration and color settings.

 

 

The software USED to run. One day, it didn't work anymore, and did not appear to be installed. 

  • To my knowledge, there were no updates done.
  • I was running Windows 7 at the time it stopped working, have since upgraded to Win10, no change.
  • I've emailed their support a number of times, they've sent me links for downloads and eventually stopped replying. 
  • I've tried reinstalling from the disk.
  • I've also tried installing the software from a number of sites.

 

I'm running Windows 10 Home Edition. I can install other programs, just not this one.

I can provide any other specs that might be related.

 

Thermaltake haven't been able to help, does anyone else have any idea as to why this specific software now refuses to install?


Edited by britechguy, 02 August 2017 - 10:25 PM.
Moved to External Hardware Forum


BC AdBot (Login to Remove)

 


#2 britechguy

britechguy

    Been there, done that, got the T-shirt


  • Moderator
  • 8,991 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Staunton, VA
  • Local time:09:52 PM

Posted 02 August 2017 - 10:24 PM

This is really a 50/50 split between the mouse application/driver and an external hardware issue.  After this post I'm going to escort you over to the External Hardware forum.

 

First, use the software supplied by the vendor, no one else.

 

Then try the following:

 

1.  Connect a standard USB mouse along with the Theron mouse.

 

2.  Open Control Panel, Device Manager.

 

3.  Go to the Mice and Other Pointing Devices entry in Device Manager and expand it.

 

4.  You will likely see two entries, one of which is for your Theron mouse, click on that entry.

 

5.  At the top of the Device Manager window hit the red X to uninstall the device.  Immediately unplug it when it says it's uninstalled.

 

6.  Reboot your computer.

 

7.  Install the software from the manufacturer BEFORE plugging the Theron mouse back in.

 

8.  Plug the Theron mouse back in.

 

Report back as to whether this worked or not.


Brian  AKA  Bri the Tech Guy (website in my user profile) - Windows 10 Home, 64-Bit, Version 1803, Build 17134 

     . . . the presumption of innocence, while essential in the legal realm, does not mean the elimination of common sense outside it.  The willing suspension of disbelief has its limits, or should.

    ~ Ruth Marcus,  November 10, 2017, in Washington Post article, Bannon is right: It’s no coincidence The Post broke the Moore story


 

 

 

              

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users