Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows 7 pro OEM cannot install SP1


  • Please log in to reply
6 replies to this topic

#1 Galdorf

Galdorf

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:04:56 PM

Posted 24 July 2017 - 11:06 AM

If i try to install sp1 on windows 7 i get this error:

Things i have tried

SFC /scannow  no errors

Chkdsk /r  No errors

System Updates Readiness Tool no errors in log

 

CBS.LOG

 

2017-07-21 19:08:17, Error                 CSI    000001f2@2017/7/21:23:08:17.502 (F) d:\win7sp1_gdr\base\wcp\componentstore\csd_locking.cpp(324): Error STATUS_SXS_ASSEMBLY_MISSING originated in function CCSDirectTransaction::LockComponent expression: (null)
[gle=0x80004005]
2017-07-21 19:08:17, Error                 CSI    000001f3 (F) STATUS_SXS_ASSEMBLY_MISSING #627871# from CCSDirectTransaction::OperateEnding at index 0 of 1 operations, disposition 2[gle=0xd015000c]
2017-07-21 19:08:17, Error                 CSI    000001f4 (F) HRESULT_FROM_WIN32(ERROR_SXS_ASSEMBLY_MISSING) #627756# from Windows::ServicingAPI::CCSITransaction::ICSITransaction_PinDeployment(Flags = 0, a = Microsoft-Windows-Branding-Ultimate-Deployment-LanguagePack, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture = [l:10{5}]"en-US", VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral, cb = (null), s = (null), rid = [108]"Microsoft-Windows-Branding-Ultimate-Client-Package~31bf3856ad364e35~amd64~en-US~6.1.7601.17514.BUC Namespace", rah = (null), manpath = (null), catpath = (null), ed = 0, disp = 0)[gle=0x80073701]
2017-07-21 19:08:17, Info                  CBS    Failed to pin deployment while resolving Update: BUC Namespace from file: (null) [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
2017-07-21 19:08:17, Info                  CBS    Failed to resolve item[0] in Package: Microsoft-Windows-Branding-Ultimate-Client-Package~31bf3856ad364e35~amd64~en-US~6.1.7601.17514, Update: BUC Namespace [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
2017-07-21 19:08:17, Info                  CBS    Failed to resolve execution update. [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
2017-07-21 19:08:17, Error                 CBS    Failed to resolve execution package: Microsoft-Windows-Branding-Ultimate-Client-Package~31bf3856ad364e35~amd64~en-US~6.1.7601.17514 [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
2017-07-21 19:08:17, Info                  CSI    000001f5@2017/7/21:23:08:17.892 CSI Transaction @0x4b69470 destroyed
2017-07-21 19:08:17, Info                  CBS    Perf: Resolve chain complete.
2017-07-21 19:08:17, Info                  CBS    Failed to resolve execution chain. [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
2017-07-21 19:08:17, Error                 CBS    Failed to process Multi-phase execution. [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]

2017-07-24 11:34:11, Error                 CBS    SPI: (SPIRegQueryStringValue:700)Failed to query registry value: MiscString2 er=0x2
2017-07-24 11:34:11, Error                 CBS    SPI: (CSystem::GetMachineName:395)Failed to query machine name from RAC hr=0x80070002


Edited by Galdorf, 24 July 2017 - 11:25 AM.


BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 22,597 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:56 PM

Posted 24 July 2017 - 11:31 AM

See this article on what updates must be installed before installing SP1

 

https://support.microsoft.com/en-us/help/2505743/steps-to-follow-before-you-install-windows-7-sp1-and-windows-server-20

 

If you are trying to install SP1 through Windows update you may have a  better chance installing using the standalone installer.

 

https://www.microsoft.com/en-us/download/details.aspx?id=5842

 

For 64bit 

  • windows6.1-KB976932-X64.exe   903.2 MB

Edit: Deleted Update Readiness Tool link


Edited by JohnC_21, 24 July 2017 - 11:33 AM.


#3 Galdorf

Galdorf
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:04:56 PM

Posted 24 July 2017 - 12:15 PM

See this article on what updates must be installed before installing SP1

 

https://support.microsoft.com/en-us/help/2505743/steps-to-follow-before-you-install-windows-7-sp1-and-windows-server-20

 

If you are trying to install SP1 through Windows update you may have a  better chance installing using the standalone installer.

 

https://www.microsoft.com/en-us/download/details.aspx?id=5842

 

For 64bit 

  • windows6.1-KB976932-X64.exe   903.2 MB

Edit: Deleted Update Readiness Tool link

 

tried that already also have all required updates installed . the standalone installer gives same error.



#4 JohnC_21

JohnC_21

  • Members
  • 22,597 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:56 PM

Posted 24 July 2017 - 12:21 PM

Have you tried the Update Troubleshooter?



#5 Galdorf

Galdorf
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:04:56 PM

Posted 24 July 2017 - 12:55 PM

Have you tried the Update Troubleshooter?

tried that as well found nothing.



#6 JohnC_21

JohnC_21

  • Members
  • 22,597 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:56 PM

Posted 24 July 2017 - 02:00 PM

There is a Board that can diagnose Update issues. Post in the SysNative Update Forum. Please read the pinned post in the Forum for instructions. Good Luck and if you solve the problem please post an update with a link to the thread. Thanks.

 

https://www.sysnative.com/forums/windows-update/



#7 arlattimor

arlattimor

  • Members
  • 591 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Beaufort, SC.
  • Local time:03:56 PM

Posted 24 July 2017 - 02:24 PM

I would run Windows Repair AIO Tool from tweaking.com http://www.tweaking.com/content/page/windows_repair_all_in_one.html this usually repairs windows updates in my experience.


A. Lattimore

CCNA, CWNA, MCITP, MCSA, MCT, MCP, Security+, Server+, Linux+, Network+, A+, CNST

Network Security Engineer

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users