Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

No Android devices syncing to my PC USB issues...


  • Please log in to reply
5 replies to this topic

#1 Amebix

Amebix

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:02:40 AM

Posted 11 July 2017 - 05:13 PM

Ok so out of nowhere none of my android devices are being installed when I plug in my USB ports.

No matter what I do, I cannot install the correct drivers  for ANY of my devices (and I have tried just about EVERYTHING from legacy installing to reinstalling windows MTP software, USB debugging on and off, airplane mode on and off, uninstalling drivers etc)

 

When I plug in my device(s) and makes the normal USB sound but in device manager under portable devices (I can't recall for the life of me if before it showed up under the USB tabs with the correct device name, tho this no longer does this with ANY device if it did at all) as MTP USB Device with the Yellow sign and "!" letting you know that not only are you an utter failure, women no longer find you attractive (the exclamation mark told me this by the way)

 

The only thing I can get to work is when I Select CDROM/DRIVER install option, then it shows up as an installer to install the devices driver. This is the only time that it connects. My girlfriends laptop is running the same version of windows and hers installs just fine with the exact same devices and cords.

It's not my USB ports as my gamepad, mouse and keyboards work.

hmm

 

it seems my thumb drives are doing the exact same thing...

I tried to turn off Driver Signage protecting thing in boot options a bit ago to try and install a legacy driver for my BLU device that didn't have a signature so it wouldn't install correctly....this is the only thing I have added or done to my machine lately so I am not sure what would cause USB storage to not install....

 

I am at a total loss...

 

I will respond, I was away for a bit but I am now back....

 

Thanks guys...

 

"This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)"


Edited by Amebix, 11 July 2017 - 05:17 PM.


BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 22,612 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:40 AM

Posted 11 July 2017 - 05:38 PM

You can try clearing all non-present device drivers using Device Cleanup Command. 

 

http://www.uwe-sieber.de/misc_tools_e.html

 

Unzip the devicecleanupcmd.zip file to a folder on your desktop and then copy the X64 subfolder to the root of C:\. Rename it something simple like cleanup. 

 

Open an elevated command prompt by pressing the Windows key + X. cmd > as admin

 

Type the following commands. Your admin command prompt will be C:\Windows\System32

 

cd c:\

cd cleanup

Devicecleanupcmd *

 

This will clean up all  non-present devices. When you attach your USB flash drive you should get the notice install drivers for the device.

 

If you don't feel comfortable with the command line you can use the GUI tool and delete all non-present devices with it. Sometimes the drivers of one device can conflict with another causing problems.

 

devicecleanup.png



#3 Amebix

Amebix
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:02:40 AM

Posted 11 July 2017 - 06:38 PM

Ok cool, that worked for the USB flash drive.

When I put in my thumb drive in device Manager under portables it shows up WPD filesystem Volume Driver with the Yellow sign(!)

tho the flash drive does show up fine and I am able to use it.

BUT when I try my android devices it shows up on device mgr under android devices up on top and it shows to be working in device mgr and shows up again under portable as MTP yellow sign(!) and does not show up on my connected devices under my computer.

 

Getting there tho :)



#4 JohnC_21

JohnC_21

  • Members
  • 22,612 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:40 AM

Posted 11 July 2017 - 06:47 PM

Right click the WPD device and select Properties. Click on Update Driver. If that fails see this Microsoft help page.

 

https://answers.microsoft.com/en-us/windows/forum/windows_10-other_settings/windows-10-how-to-fix-wpd-filesystem-volume-driver/1be2bb83-f1e4-4259-b94f-8092ab0f7c3e

 

I found this video. It could be caused by the device not having a drive letter assigned to it. 

https://www.youtube.com/watch?v=Ba5ZNGWTnOE

Edited by JohnC_21, 11 July 2017 - 06:57 PM.


#5 Amebix

Amebix
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:02:40 AM

Posted 11 July 2017 - 07:47 PM

I don't know If i was clear or not but the USB thumb stick works, I am able to go into it and move files around, it shows up as a lettered drive, and it shows up under disk drives in device mgr, it also shows up in portable devices as an non-working "WPD filesystem volume Driver" and I tried to update the driver and it still shows the exact same thing(device status brings up code 31)

So, I am able to use my thumb drive even tho it ALSO shows up a non-working portable device. Even when I uninstall it and check hardware changes it comes back, while the USB disk drive (under the disk drive tab in device mgr) stays the same, even if I uninstalll the portable devices non-working entry the entry for the disk drives stays (till of course I take out the stick myself)

 

I don't know if this is also affecting my other devices, or if there is something wrong with the portable devices section..if some how it got corrupted or something...I have no idea what yo do next...

 

I will look at that video and see if maybe this will have an impact, as the windows link did not solve my issues with both probllems

 

again it shows up fine under my computer but in devices and printers it shows up as USB disk with the yellow sign (!) just like it does under portable devices in the device mgr

 

EDIT:

Under the device and printers tab when i right click on the USB Disk icon it shows up under properties three different names with (in order)

WPD FileSystem Volume Driver Portable Device (!) [not working]

USB Disk 2.0. USB Device  Disk Drive (working)

USB Mass Storage Device  U.S.B. Controllers (also working)

Don't know if this info means anything but I Figured I would share it


Edited by Amebix, 11 July 2017 - 07:57 PM.


#6 JohnC_21

JohnC_21

  • Members
  • 22,612 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:40 AM

Posted 11 July 2017 - 07:54 PM

I am not that familiar with Windows 10 but I thought possibly your Android devices when attached did not get a drive letter though the flash drives did.

 

A couple of commands to look at.

 

sfc /scannow at the command prompt to check for missing or corrupt files.

 

The DISM command as shown here.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users