Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Changing from WPA to WPA2 via mac


  • Please log in to reply
6 replies to this topic

#1 JimmyRiddle

JimmyRiddle

  • Members
  • 56 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:British Columbia
  • Local time:09:59 AM

Posted 11 July 2017 - 05:51 AM

I've done this successful before, but can't find how to do so again. I get the message 'weak security' warning under wifi recs. where and how do I alter this via my mac?

I am not the router admin, and other devices on the network don't have this message.

BC AdBot (Login to Remove)

 


m

#2 x64

x64

  • Members
  • 351 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:London UK
  • Local time:08:59 AM

Posted 11 July 2017 - 01:53 PM

I’ve not tried this procedure, but this would appear to be the way to do it.

 
I’m assuming that the router is capable of and configured for WPA2 and for some reason the Mac has not negotiated the connection correctly, and that the Mac is not so old that it does not support WPA2
 
These steps are for Sierra. Earlier versions might have these controls in different places but try to follow the general procedure.
Ensure you have the wi-fi password as we will need to delete the wi-fi settings and rejoin the Mac to the router.
 
 
Go to “System Preferences” / “Network”
 
In the lefthand column select “Wi-Fi” and then in the bottom righthand corner choose “Advanced”
Beneath the table of connections, click the “+” (brings up an “Add a network profile” dialog) and verify that various WPA2 options exist in the “Security” list. Dismiss the “Add a network profile” dialog by clicking cancel so that you are back on the screen that you got from the “Advanced” button. If WPA2 does not exist then it sounds as if the Mac does not support it.
 
In the table of wi-fi connections locate the Wi-Fi connection that you wish to alter and click on it to select it.
Click the “-“ Button beneath the table that should delete the connection from the Mac.
Let the connection re-detect, connect to it and reenter the network password.
 
If that does not work (it still detects incorrectly then note the network name of the connection [exactly!] delete the connection again (as above). 
Then beneath the table click the “+” sign. Enter the network name as noted from above and as “security” select “WPA2 Personal”. Click “OK” and enter the network key.
 
If neither of this things do it then the issue may be with the router. 
 
x64


#3 JimmyRiddle

JimmyRiddle
  • Topic Starter

  • Members
  • 56 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:British Columbia
  • Local time:09:59 AM

Posted 12 July 2017 - 10:54 AM

Thanks x64, I did all that and it appears to have altered it so in the box with plus and minus, it is shown as WPA2. So everything looks fine, then when I hit apply it reconnects and changes it back to WPA, with the same security rec highlighted.
I've entered and re entered around five times now and can't seem to fix it permanently.

This seems to be solely affecting my mac in the entire network and I can't understand why. Could it be that the admin when allocating access via the router inputted WPA only for my mac? Or someone with access to the router has done similar? As you may remember I had some security concerns before so am naturally a bit jumpy with these things.

#4 x64

x64

  • Members
  • 351 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:London UK
  • Local time:08:59 AM

Posted 12 July 2017 - 01:30 PM

Certainly puzzling.. What exact model of Mac do you have? What version of macOS is it running? (the first few Lines of "about this Mac" from the apple menu would be useful.

 

Do you have any other Apple devices on the same network/ is keychain synced between them (through iCloud)? (I'm sure you'd have mentioned it before but need to  be sure).

 

I can't see why a router admin would mess about limiting wi-fi protocols for one user - even if that was possible (which for the kind of routers you'd see in residential use, it's not - the settings are not that granular`- I've only ever seen one set of protocols across an entire SSID).

 

Are there any wi-fi repeaters or multiple wi-fi access points around the property? (if so) Could the one nearest to you be old enough not to support wpa2, or be configured to only use the older protocol?. A variation on this is someone setting up another wi-fi network with the same SSID as one they want to hijack (however, that kind of attack would be used on public hotspots rather than on residential networks)

 

If the router admin was malicious he could intercept your traffic within the router (or interfere with your DNS) without going to the hassle of weakening your wi-fi and the further cracking that. Not worth the hassle.

 

There's also the possibility of a plain old software incompatibility between the Mac and router. I have seen such issues in the past.

 

x64



#5 JimmyRiddle

JimmyRiddle
  • Topic Starter

  • Members
  • 56 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:British Columbia
  • Local time:09:59 AM

Posted 12 July 2017 - 02:23 PM

It's a five year old mac running the latest sierra, and I haven't had any similar issues as I recall. The router admin certainly wouldn't be malicious, but I remember him setting up a hidden network that he said required him to add each device independently, but I'm pretty sure he's subsequently changed it. I really don't want to concern him about it as he suffers from Parkinson's, so am trying to resolve it on my end if at all possible.

I've never knowingly used iCloud, but I do have a iPhone that is connected to this wifi and like all the other peoples devices on here, seems to be on with WPA2

I guess my slightly paranoid fear is someone could've altered the settings remotely in order to get access to my encrypted information specifically, thus targeting just my device on the network via altering the fouters settings with it. Could it be possible howerver unlikely?

Edited by JimmyRiddle, 12 July 2017 - 02:28 PM.


#6 x64

x64

  • Members
  • 351 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:London UK
  • Local time:08:59 AM

Posted 12 July 2017 - 04:18 PM

Hidden network/adding devices manually was always false security. Now technologies sync as MAC address randomisation make that unworkable. 

 

I was wondering if corrupted wifi settings were synced with the keychain... You can check in the new account section at the top of settings on the iPhone and then iCloud (see which elements are turned on). and on the Mac under Settings/iCloud.

 

In terms of encrypted information being stolen, as long as the website is https and you've not overridden certificate issues when connecting to the site the you're reasonably safe. HTTPS encrypts the information and the way that https/certificates work proves you are actually talking to the server that you think you are (without any possibility of someone sitting in the middle). The only thing at someone in the middle could figure out is what site you're accessing. Not what you're doing on it. Of course plain http information is fair game for interception.

 

Of course the use of internet access VPNs will protect against that kind of local interception and some offer other added protection such as virus scanning. I'm not a great fan of them however - I do have a subscription but only use it occasionally.

 

The WPA2/WPA encryption protects traffic between you and the router or direct traffic between you and other devices wired or on wifi form the same  router. If you are only accessing the internet, then anything sensitive you are doing should already be encrypted. One more thing to check there 'though...

 

One thing that amazes me is that some ISPs still run mail servers that permit client access through unencrypted protocols. In Mail for Mac nd iPhone mail, check that TLS is turned on on all pop/imap accounts, and on those for both sending and receiving.

 

x64


Edited by x64, 12 July 2017 - 04:20 PM.


#7 JimmyRiddle

JimmyRiddle
  • Topic Starter

  • Members
  • 56 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:British Columbia
  • Local time:09:59 AM

Posted 17 July 2017 - 08:50 AM

Resolved this - it turns out the router was reset and when turned back on it was with the old settings. Strange how only my Mac got the 'weak security' message, while other devices in property didn't though. Thanks for the input X64.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users