Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows Smartscreen prevented an unrecognized app from starting


  • Please log in to reply
8 replies to this topic

#1 Sylveon Fetish

Sylveon Fetish

  • Members
  • 391 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:28 AM

Posted 07 July 2017 - 04:27 PM

I cannot update klite codec pack on Windows 10, every time I try to run the installer I always get a "Windows Smartscreen prevented an unrecognized app from starting" I am unable to run it!

Google just says to click 'more info' and then 'run anyway' but nothing could be further from the truth! The only option is 'don't run' and that's it. No other options at all. and there is no way I can get this to run AFAICS!

How do I get the ball rolling

 



BC AdBot (Login to Remove)

 


#2 britechguy

britechguy

    Been there, done that, got the T-shirt


  • Moderator
  • 6,846 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Staunton, VA
  • Local time:09:28 AM

Posted 07 July 2017 - 05:27 PM

There used to be a way in the dialog to do what was mentioned, but apparently that's been changed.

 

At this point I'd suggest opening Windows Defender, App & Browser control (from the home page in WinDefender), and disabling Smartscreen for the appropriate mechanism, or all of them, temporarily to allow the install to proceed then turn it back on as you see fit.

 

I've got mine set to Warn for everything and Block for nothing.  That way I get things effectively blocked unless I allow them through when the warning comes up.  If that's what you've got then I'd try "off" until your installation is complete if you know what you're installing is clean.


Brian  AKA  Bri the Tech Guy (my website address is in my profile) Windows 10 Home, 64-bit, Version 1709, Build 16299

       

    Here is a test to find out whether your mission in life is complete.  If you’re alive, it isn’t.
             ~ Lauren Bacall
              

 


#3 Sylveon Fetish

Sylveon Fetish
  • Topic Starter

  • Members
  • 391 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:28 AM

Posted 07 July 2017 - 05:29 PM

How do I do that?



#4 Sylveon Fetish

Sylveon Fetish
  • Topic Starter

  • Members
  • 391 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:28 AM

Posted 07 July 2017 - 05:31 PM

I go to the option to turn it off when I search settings but it ONLY brings me to privacy settings and it is NOT in there!!


Edited by Sylveon Fetish, 07 July 2017 - 05:31 PM.


#5 britechguy

britechguy

    Been there, done that, got the T-shirt


  • Moderator
  • 6,846 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Staunton, VA
  • Local time:09:28 AM

Posted 07 July 2017 - 05:36 PM

I said:  

 

  1. Open Windows Defender.  (If necessary, hit the Windows Key and immediately type "defender" to have it returned as the first, and probably only, item)
  2. Go to the App & Browser control pane from the WinDefender Home Dialog

 

I can't be any more clear than that.  If you're not using Windows Defender then I'm not quite sure where SmartScreen is snagging you or how.

 

Mind you, the above presumes you're running Version 1703.  If you're still back on Version 1607 I do not have access to a machine to check where this was found in earlier versions.  It could have changed.


Edited by britechguy, 07 July 2017 - 05:38 PM.
Mention of Version and possible differences

Brian  AKA  Bri the Tech Guy (my website address is in my profile) Windows 10 Home, 64-bit, Version 1709, Build 16299

       

    Here is a test to find out whether your mission in life is complete.  If you’re alive, it isn’t.
             ~ Lauren Bacall
              

 


#6 Lvlpost

Lvlpost

  • Members
  • 77 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:hawai
  • Local time:08:28 PM

Posted 07 July 2017 - 10:41 PM

I highly suggest you turn Off SmartScreen. Now I will show you how to disable SmartScreen in Windows 10.

1. Go to the Control Panel> System and Security> Action Center.
2. Click Change Windows SmartScreen settings.
3. Click Don’t do anything (turn off Windows SmartScreen). And click OK to save changes.



#7 jwoods301

jwoods301

  • Members
  • 1,489 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:28 AM

Posted 08 July 2017 - 12:15 AM

I just downloaded the K-Lite Codec Pack and uploaded the installer to VirusTotal.com for a check.

 

https://www.codecguide.com/klcp_update.htm

 

It came back clean.

 

https://www.virustotal.com/en/file/21f3694f0124b199200f2fe3ba8cbe7de96eab7b0bccc0586e66013a952a800a/analysis/1499490507/

 

I would highly recommend that you don't turn off SmartScreen. It is another layer of security that is useful when optimally configured.

 

I would use @britechguy's settings of Warn.

 

See this tutorial from TenForums...

 

https://www.tenforums.com/tutorials/5593-change-windows-smartscreen-settings-windows-10-a.html

 

This sidebar article from TenForums describes what SmartScreen does...

 

https://www.tenforums.com/windows-10-news/34066-evolving-microsoft-smartscreen-protect-you-drive-attacks.html


Edited by jwoods301, 08 July 2017 - 12:40 AM.


#8 tos226

tos226

    BleepIN--BleepOUT


  • Members
  • 1,568 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:LocalHost
  • Local time:09:28 AM

Posted 08 July 2017 - 08:37 PM

Do not EVER turn Smartscreen off. To change Windows Defender to WARN instead of block needs to be done under administrative rights.

#9 britechguy

britechguy

    Been there, done that, got the T-shirt


  • Moderator
  • 6,846 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Staunton, VA
  • Local time:09:28 AM

Posted 08 July 2017 - 08:55 PM

Do not EVER turn Smartscreen off. To change Windows Defender to WARN instead of block needs to be done under administrative rights.

 

The default setting for Smartscreen is Warn.  I have never tweaked it, I just looked at what it's set to, and Windows Defender shows a green checkmark and states that I am using the recommended settings.

 

I agree that I would not turn Smartscreen for anything to OFF on a permanent basis, but nor would I set it to Block, either, as that's overkill.  Warn stops execution unless you allow it.

 

I would imagine that most changes for Windows Defender would require admin rights given what it does.


Brian  AKA  Bri the Tech Guy (my website address is in my profile) Windows 10 Home, 64-bit, Version 1709, Build 16299

       

    Here is a test to find out whether your mission in life is complete.  If you’re alive, it isn’t.
             ~ Lauren Bacall
              

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users