Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

IDE to AHCI Windows 10


  • Please log in to reply
17 replies to this topic

#1 scottausburn

scottausburn

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:09:05 PM

Posted 04 July 2017 - 04:16 PM

Hello everyone.

 

(I´m posting here because I think this is a Windows 10 problem and not a BIOS problem)

 

I am a little frustrated.  I am trying to change to  AHCI from IDE on my computer.  I have a SSD hard drive.

 

I have followed the instructions on the web: 

 

1.  Start in safe mode (with network)

2.  Change 3 registry keys:  I am the owner under permissions and know how to change keys

3.  Restart and boot into BIOS.. change SATA to AHCI

4. Boot and Windows 10 should load drivers

5.  Reboot normally

 

Problem:  My registry keys keep reverting back to a value of 3

 

the keys are:  HKEY_LOCALMACHINE/SYSTEM/CURRENTCONTROLSET/SERVICES/  and then the keys  iaSTORAV , iaSTORV and storeahci/StartOverride--- ( changing the Dword  to 0 from 3)

 

I am the owner under permissions and I am signed in as Administrator.

 

When I make the change in the BIOS to AHCI the computer boots with no problems but no AHCI drivers load and under device manager it shows IDE controllers for the port,  I have also tried manually updating the driver.

 

Any Ideas,

 

Running Windows 10 Pro 64bit



BC AdBot (Login to Remove)

 


#2 dhagerjohns

dhagerjohns

  • Members
  • 145 posts
  • OFFLINE
  •  

Posted 04 July 2017 - 10:03 PM

  1. Right-click the Windows Start Menu. Choose Command Prompt (Admin).
  2. Type this command and press ENTER: bcdedit /set {current} safeboot minimal
  3. Restart the computer and enter BIOS Setup (the key to press varies between systems).
  4. Change the SATA Operation mode to AHCI from either IDE or RAID (again, the language varies).
  5. Save changes and exit Setup and Windows will automatically boot to Safe Mode.
  6. Right-click the Windows Start Menu once more. Choose Command Prompt (Admin).
  7. Type this command and press ENTER: bcdedit /deletevalue {current} safeboot
  8. Reboot once more and Windows will automatically start with AHCI drivers enabled.


#3 FreeBooter

FreeBooter

  • Members
  • 3,137 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Turkey - Adana
  • Local time:10:05 PM

Posted 05 July 2017 - 02:27 AM

Windows 10 compatible with Sata Advanced Host Controller Interface (AHCI) you don't need to change anything in registry just enable Advanced Host Controller Interface (AHCI) in BIOS setup utility.

Posted Image


#4 scottausburn

scottausburn
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:09:05 PM

Posted 05 July 2017 - 08:48 AM

Hi,

 

DhagerJohns,  I've tried  this method.  Under device manager the IDE/ATA/ATAPI  setting the controller is still IDE, should change to AHCI. 

 

FreeBooter, I have enabled the Advanced Host Controller interface in the BIOS, but still shows IDE in device manager.  This should change, it is changed on my other two computers. 

 

I will attempt the command prompt safeboot again and let you know how it goes.  Thanks for the replies.

 

ScottAusburn



#5 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,690 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:12:05 PM

Posted 05 July 2017 - 08:57 AM

When you make the change in the BIOS do you use the 10 key to save the changes you made?


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#6 dhagerjohns

dhagerjohns

  • Members
  • 145 posts
  • OFFLINE
  •  

Posted 05 July 2017 - 09:40 AM

Remember, after changing in BIOS you MUST boot to safe mode FIRST, then reboot normally.



#7 FreeBooter

FreeBooter

  • Members
  • 3,137 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Turkey - Adana
  • Local time:10:05 PM

Posted 05 July 2017 - 04:08 PM

Please post screenshot of Device Manager.

Posted Image


#8 Bulgaristan

Bulgaristan

  • Members
  • 278 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Bulgaria
  • Local time:09:05 PM

Posted 06 July 2017 - 10:49 AM

Changing IDE to ACHI mode will require a new installation of windows.
There is a way to manually configure MBR but I will not amend such madness to no one.
The difference between them will not increase your computer performance.
The best will be to go for a fresh install with changed BIOS options so the partition can be created GBP instead MBR but for that, you will need UEFI.
 



#9 dhagerjohns

dhagerjohns

  • Members
  • 145 posts
  • OFFLINE
  •  

Posted 07 July 2017 - 12:15 AM

Changing IDE to ACHI mode will require a new installation of windows.
There is a way to manually configure MBR but I will not amend such madness to no one.
The difference between them will not increase your computer performance.
The best will be to go for a fresh install with changed BIOS options so the partition can be created GBP instead MBR but for that, you will need UEFI.
 

AHCI has nothing to do with MBR.  Just BIOS options afaik.  I use old BIOS, and when I first switched to AHCI I just did what I reported in previous post.  



#10 cheaterslick

cheaterslick

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:03:05 PM

Posted 28 July 2017 - 08:15 AM

I had the same problem too.  What dhagerjohns says will work. 

 

No need to reinstall Windows.  Save yourself a lot of time by doing the instructions in his #2 post


Edited by cheaterslick, 28 July 2017 - 08:16 AM.


#11 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,690 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:12:05 PM

Posted 28 July 2017 - 08:37 AM

Changing IDE to ACHI mode will require a new installation of windows.
There is a way to manually configure MBR but I will not amend such madness to no one.
The difference between them will not increase your computer performance.
The best will be to go for a fresh install with changed BIOS options so the partition can be created GBP instead MBR but for that, you will need UEFI.
 

You do not need to reinstall Windows in order to correct this.  This also has nothing to do with the MBR.


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#12 cassinisavior

cassinisavior

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:01:05 PM

Posted 07 September 2017 - 05:52 PM

 

  1. Right-click the Windows Start Menu. Choose Command Prompt (Admin).
  2. Type this command and press ENTER: bcdedit /set {current} safeboot minimal
  3. Restart the computer and enter BIOS Setup (the key to press varies between systems).
  4. Change the SATA Operation mode to AHCI from either IDE or RAID (again, the language varies).
  5. Save changes and exit Setup and Windows will automatically boot to Safe Mode.
  6. Right-click the Windows Start Menu once more. Choose Command Prompt (Admin).
  7. Type this command and press ENTER: bcdedit /deletevalue {current} safeboot
  8. Reboot once more and Windows will automatically start with AHCI drivers enabled.

 

Is there any technical reason why it should boot to Safe Mode first? This is out of curiosity. I just want to understand. And for what it's worth, yes it works.



#13 webgrunt

webgrunt

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:02:05 PM

Posted 05 October 2017 - 07:18 AM

Is there any technical reason why it should boot to Safe Mode first? This is out of curiosity. I just want to understand. And for what it's worth, yes it works.

 

 

 

Yes.  If you don't boot into safe mode first, your system will bluescreen with an "inaccessible boot device" error instead of booting into Windows.


Edited by webgrunt, 05 October 2017 - 07:19 AM.


#14 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,690 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:12:05 PM

Posted 05 October 2017 - 09:16 AM

In Windows 8.1 and Windows 10 you can no longer boot into Safe Mode by tapping the F8 key.  For this reason I would suggest that you set Windows to boot into Safe Mode or enable the F8 key to boot into Safe Mode before making the suggested changes in the BIOS.

 

How to start Safe Mode in Windows 10

Press the Windows key OS4o0pO.png  and the R key to open the Run box.

Type msconfig in the Run box and click/tap OK.  This will open System Configuration.

Click/tap on the Boot tab, then click/tap on Safe boot.

Click/tap on Apply, then OK.

Important:  Once you have set the computer to boot into Safe Mode it will continue to do this until you go back to System Configuration,open the Boot tab and remove the check from Safe boot.

 

 

How to enable the F8 key in Windows 10

Press the Windows key OS4o0pO.png and the R key together to open the Run box.  

When the Run opens copy and past cmd (admin), then click/tap on OK.

When the Command Prompt opens copy the command below, then press Enter.

bcdedit /set {default} bootmenupolicy legacy

You will receive the message The operation completed successfully.

You will need to restart the computer for this to take effect.

Now you will be able to use the F8 key to boot into the Safe Mode option when Windows starts loading.
 


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#15 Lamf77

Lamf77

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:01:05 PM

Posted 30 November 2017 - 01:16 PM

 

  1. Right-click the Windows Start Menu. Choose Command Prompt (Admin).
  2. Type this command and press ENTER: bcdedit /set {current} safeboot minimal
  3. Restart the computer and enter BIOS Setup (the key to press varies between systems).
  4. Change the SATA Operation mode to AHCI from either IDE or RAID (again, the language varies).
  5. Save changes and exit Setup and Windows will automatically boot to Safe Mode.
  6. Right-click the Windows Start Menu once more. Choose Command Prompt (Admin).
  7. Type this command and press ENTER: bcdedit /deletevalue {current} safeboot
  8. Reboot once more and Windows will automatically start with AHCI drivers enabled.

 

 

I just got my old Seagate Hybrid Drive cloned on a new Samsung 850 EVO 500GB and installed in my tower.  I tried to do this, but Windows will not automatically boot into safe mode as shown in point #5?

I saw the post directly above and will enable the F8 key since the "shift + restart" is not working.

So after I change the BIOS, I can just use the F8 key to enter safe mode and enter the second command?

Also, once the new drive is switched to AHCI, can I reinstall my old hard drive in the computer? Or am I best served by just leaving it out and using my docking station?

Thanks!






2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users