Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

mass storage driver..??


  • Please log in to reply
21 replies to this topic

#1 weak2017

weak2017

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:04:23 PM

Posted 22 June 2017 - 09:08 AM

hey guys fixing a friends laptop ... had to reinstall win 7.... all is good expect its missing... 

 

mass storage controller and theres an unknown device in USB controller (im guessing its 5 in 1 card reader) 

 

ive went to the toshiba website but theres no drivers listed at all (old laptop)

 

toshiba statellite a200 ah3     AKA    psae0c-ah308c

 

so when i plus a USB in it says unable to install driver 

 

any idea?

 

thanks!!



BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 23,220 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:04:23 PM

Posted 22 June 2017 - 09:21 AM

On each device with a yellow exclamation mark in Device Manager right click, select Properties > Details > Hardware IDs in the dropdown box. Copy and post the first line of each device.



#3 weak2017

weak2017
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:04:23 PM

Posted 22 June 2017 - 09:29 AM

ok so mass storage controller :

 

PCI\VEN_104C&DEV_803B&SUBSYS_FF001179&REV_00
PCI\VEN_104C&DEV_803B&SUBSYS_FF001179
PCI\VEN_104C&DEV_803B&CC_018000
PCI\VEN_104C&DEV_803B&CC_0180
 
unknown device :
 
USB\UNKNOWN
 


#4 JohnC_21

JohnC_21

  • Members
  • 23,220 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:04:23 PM

Posted 22 June 2017 - 09:38 AM

Does this driver work for the card reader? Edit: The Vendor and Device ID is for the card reader.

 

http://cdgenp01.csd.toshiba.com/content/support/downloads/driver_cardreader_ti_25844A.exe

 

I can't help with the unknown device, sorry?

 

Edit: Is this a 64bit OS? The above may be 32bit. It will fail if trying to install to 64bit. I will need to find a 64bit drive but it may be problematic as the chipset is Texas Instruments.


Edited by JohnC_21, 22 June 2017 - 09:43 AM.


#5 weak2017

weak2017
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:04:23 PM

Posted 22 June 2017 - 09:47 AM

its 32.... and it worked!! thank you ... ubs is still not working ugh 


Edited by weak2017, 22 June 2017 - 09:47 AM.


#6 weak2017

weak2017
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:04:23 PM

Posted 22 June 2017 - 09:52 AM

so when i plug in a usb  it says....

 

usb device not recognized 

one of the usb devices attached to this computer has malfunctioned and windows does not recognize it

 

and ive tried a few different ones usb stick, usb external drive ..same result 


Edited by weak2017, 22 June 2017 - 09:53 AM.


#7 JohnC_21

JohnC_21

  • Members
  • 23,220 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:04:23 PM

Posted 22 June 2017 - 09:54 AM

That sounds like a problem with the USB drivers but Windows 7 has native USB drivers in the install.

 

Go here, provide a junk email address and name. Download the driver. Click on the hard drive icon only. Hopefully it will work



#8 weak2017

weak2017
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:04:23 PM

Posted 22 June 2017 - 10:03 AM

when installing it says ....

 

the intel chipset software requires a supported chipset platform on a supported OS



#9 JohnC_21

JohnC_21

  • Members
  • 23,220 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:04:23 PM

Posted 22 June 2017 - 10:07 AM

If you have an intel chipset then download and run the intel chipset identification utility. It requires an internet connection.

 

Use the dropdown box to select your OS.

 

https://downloadcenter.intel.com/product/2715/Intel-Chipset-Identification-Utility



#10 weak2017

weak2017
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:04:23 PM

Posted 22 June 2017 - 10:11 AM

Chipset

Detected Chipset:

Mobile Intel® 945GM/GMS/940GML Express Chipsets or Intel® 945GT Express Chipset

Chipset Components

=bodycopy>

Memory Controller:

82945GM/GMS/82940GML or 82945GT

I/O Controller:

Intel® 82801GBM I/O controller hub (ICH7M)

Integrated Graphics:

Gfx String not set



#11 JohnC_21

JohnC_21

  • Members
  • 23,220 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:04:23 PM

Posted 22 June 2017 - 10:19 AM

The utility is supposed to install the inf files. Do you still have the Yellow exclamation mark in Device Manager?



#12 weak2017

weak2017
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:04:23 PM

Posted 22 June 2017 - 10:21 AM

ya



#13 weak2017

weak2017
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:04:23 PM

Posted 22 June 2017 - 10:23 AM

so i did update driver (browsed to the unzipped folder) and it says ... best driver is already installed


Edited by weak2017, 22 June 2017 - 10:25 AM.


#14 weak2017

weak2017
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:04:23 PM

Posted 22 June 2017 - 10:30 AM

side note... i just plugged a usb mouse in and it worked fine



#15 JohnC_21

JohnC_21

  • Members
  • 23,220 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:04:23 PM

Posted 22 June 2017 - 10:34 AM

Not sure what else to try. I did find this Toshiba A200 support page with drivers. Perhaps installing the Chipset driver from there will work.

 

If you have a fingerprint reader it's possible the USB/Unknown could be it if yours does not currently function. Or it could be the Bluetooth stack if you have built in bluetooth.

 

Does this computer have a camera?

 

Other than the above, I am out of ideas, sorry.






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users