Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Computer is having issues with administration privileges & installation


  • Please log in to reply
3 replies to this topic

#1 ingeborgdot

ingeborgdot

  • Members
  • 47 posts
  • OFFLINE
  •  
  • Local time:04:25 PM

Posted 21 June 2017 - 07:37 AM

My tech and I am baffled as to what is going on with my computer.  He has been trying to install Adobe products but all installs are failing and coming up with error code 1402.  It does this with all msi type installs.  He is the admin as was I on this computer but it keeps on saying things like we have insufficient privileges and things like that.  I know things about computers but when it comes to something like this, I'm lost. 

He says some registry keys don't have an owner and he goes in and fixes some and tries the install again only to have it happen again.  He says the msi installer could not open the key if that makes any sense.  I have tried revo uninstaller on the computer as some had suggested and it worked for some installs but not for this one.  What other info do I need to supply so we can get this issue fixed?  Thanks.



BC AdBot (Login to Remove)

 


#2 FreeBooter

FreeBooter

  • Members
  • 3,137 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Turkey - Adana
  • Local time:12:25 AM

Posted 21 June 2017 - 07:43 AM

Tweaking.com - Windows Repair is a tool designed help fix a large majority of known Windows problems including; registry errors, file permissions, issues with Internet Explorer, Windows Updates, Windows Firewall and more. Download Tweaking.com - Windows Repair Tool and run the Tweaking.com - Windows Repair Tool from Safe Mode With Networking and  from Repairs tab click Open Repairs button. From opened Repairs window place check mark for  Reset Registry Permissions, Reset Service Permissions, Register System Files, Repair WMI, Repair Network, Repair Windows Firewall, Remove Policies Set By Infections, Repair Proxy Settings, Repair Windows Updates, Repair MSI (Windows Installer), Restore Important Windows Services, Set Windows Services To Default Startup, Repair Windows 8/10 Component Store, Restore Windows 8/10 COM+ Unmarshalers, Restore UAC (User Account Control) Settings, Repair Hosts File, Repair Performance Counters, Repair Volume Shadow Copy Service, Repair MDAC & MS Jet and Reset File Permissions check boxes and click Start Repair button.



Share your knowledge. Its a way to achieve immortality.
- Dalai Lama

 

 


#3 ingeborgdot

ingeborgdot
  • Topic Starter

  • Members
  • 47 posts
  • OFFLINE
  •  
  • Local time:04:25 PM

Posted 21 June 2017 - 07:47 AM

I'll get my tech to give that a try or I may do it.  I'll let you know what happens.



#4 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,277 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:02:25 PM

Posted 21 June 2017 - 09:41 AM

It this the error message you are receiving?

 

adobe_zpszrwipn79.png

 

If this is the message Microsoft Community has posted a registry edit which can resolve the permissions issue.

 

You need to be aware that if errors are made in the process of editing the registry it can result in rendering you computer inoperable.  For this reason this edit should be done by someone who is familiar with editing the registry.  I would also suggest that you backup the registry before doing this edit.  I like Tweaking.com Registry Backup for backing up the registry.

 

To backup the registry please download and install Tweaking.com Registry Backup.

Play the video below for operating instructions.

 

The instructions for the registry edit is a direct quote from the Microsoft Community.

 

The solution is to change the permissions of the following folder in the Registry:

 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Components

a. Right Click on Components select permissions.
b. Click Advanced button.
c. Select the Owner Tab
d. Under Change owner to:  Select Administrators (Group) and Click Apply.
e. Then Select Check box Replace owner on subcontainers and objects and Click Apply.
f. Go to the Permissions tab, select the Check box:  Replace all child objects Permissions with inheritable permissions from this object and Click apply.  NOTE:  The wording maybe a bit different depending on your operating system.

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users