Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

<windows Root>\system32\hal.dll


  • Please log in to reply
2 replies to this topic

#1 bnrr

bnrr

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Local time:04:51 PM

Posted 09 September 2006 - 06:48 PM

:thumbsup: Hi
I have been having problems with my system in starting or loading. first of all let me give the run down of my
system. motherboard:U8668 pro Twin Pro 1.7Mhz celeron processor, 512 ram WD 40 gigabytes and 200
gigabytes IDE hard drives. Operating Systems: win98 se, win 2000 pro and XP professional.
(multiple boot). The problem I am having is with XP. when I tried to boot to XP I get the message that a
file needs to be re-installed, '<windows root>\system32\hal.dll. I have tried to re-install XP but still get the same message. after the setup for installation is complete and then it restarts and prompt to boot from
the CD then the boot menu, but before I chose XP the message comes up and then again restarts. I have
gone thru the same procedures over 8 times and still cannot get past the boot menu because of this issue.
I am thinking that I will have to start from scratch in formatting and re-installing all 3 OS. I do not want to
do this kind of thing since it will take at least 1 day to complete the windows updating, device installation, drivers installation and so forth. is there a way around this problem with XP I do not have any problems
with the other 2 OS :flowers: any advice anyone :trumpet:

Edited by bnrr, 09 September 2006 - 06:50 PM.


BC AdBot (Login to Remove)

 


#2 tg1911

tg1911

    Lord Spam Magnet


  • Members
  • 19,274 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:SW Louisiana
  • Local time:05:51 PM

Posted 09 September 2006 - 10:20 PM

See if one of these helps:
Error Message: Cannot Find \Windows\System32\hal.dll

"Invalid Boot.ini" or "Windows could not start" error messages when you start your computer
MOBO: GIGABYTE GA-MA790X-UD4P, CPU: Phenom II X4 955 Deneb BE, HS/F: CoolerMaster V8, RAM: 2 x 1G Kingston HyperX DDR2 800, VGA: ECS GeForce Black GTX 560, PSU: Antec TruePower Modular 750W, Soundcard: Asus Xonar D1, Case: CoolerMaster COSMOS 1000, Storage: Internal - 2 x Seagate 250GB SATA, 2 x WD 1TB SATA; External - Seagate 500GB USB, WD 640GB eSATA, 3 x WD 1TB eSATA

Become a BleepingComputer fan: Facebook

#3 bnrr

bnrr
  • Topic Starter

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Local time:04:51 PM

Posted 11 September 2006 - 07:58 AM

HI tq
thanks for your reply to my post. I tried the methods that you have posted. I after I have completed the task and check the boot menu,
It show on the list, 2 XP Professional(update). now I do not know exactly
what happened but I am going to try again. now I would like to know how I could remove the XP from the updated boot menu. if I have to use command lines could you please show it in an example.
Thanks




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users