Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Disk repair: rebuildbcd not working and system32 folder doesn't seem to exist


  • Please log in to reply
2 replies to this topic

#1 djensen

djensen

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:01:48 AM

Posted 05 June 2017 - 08:44 PM

Using Windows 10 Home Single Language (in Spanish), 64 bit build.

 

The problem started with a bit of stupidity on my part: was trying to reformat a hard drive from an old 32-bit system at our work (Windows 10 Pro N), and thought I could plug it directly into my computer for reformat using a SATA-USB cable I typically use for data migrations.

 

The computer froze, and I had to try several times to get Ctr-Alt-Del to work. The reboot menu would come up, but trying to turn off the compúter this way didn't work after several attempts, so after waiting a while I tried a cold restart, disconnecting the old HDD from its USB port in the process.

 

This clearly corrupted something in the file system on my computer, as turning the computer back on brought up the auto-repair sequence. When this failed, I got the following reference for the error log:

E:\Recovery\WindowsRE\Winre.wim\System32\Logfiles\Srt\SrtTrail.txt

After all the typical restore/recovery options the advanced troubleshooting menu didn't work (including system reset while saving files and applications), I created a recovery USB for my edition of Windows using another machine and tried everything again.

 

When this didn't work, I tried a number of bootrec and bcdedit commands, including all of those summarized here. None of these worked, and neither did disabling autorepair.

 

In the process, I've discovered the following, which may give some clue to what has gone wrong:

  • Repairing the startup process using the recovery USB returns a different path directory for the error file:
    C:\windows\system32\logfiles\srt\srttrail.txt
    

    Startup repair using the recovery options on the SDD returns the same E: pathway as above.

  • Command Prompt cannot find the system32 folder, even though all the partitions on the drive are still there and C:\windows still evists. The E: filepath referenced earlier can't be found either, which makes pinning down the real problem quite difficult.

  • The Windows Boot Manager shows up twice in the startup menu, when previously it only showed up once.

Many thanks in advance for any help that can be provided, Even just a suggestion on how to access srttrail would be much appreciated!



BC AdBot (Login to Remove)

 


#2 Lvlpost

Lvlpost

  • Members
  • 77 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:hawai
  • Local time:01:48 PM

Posted 05 June 2017 - 09:17 PM

Your hard drive may be having issues. If your HDD is more than three years old, you might consider a replacement. Run "chkdsk /p" or "chkdsk /f". If you see a lot of errors or bad sectors, it's time to go shopping. Otherwise, let chkdsk fix the problems and go on your merry way. Good luck!


Edited by Lvlpost, 05 June 2017 - 09:17 PM.


#3 djensen

djensen
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:01:48 AM

Posted 05 June 2017 - 09:31 PM

Thanks, I did run chkdsk (twice), and while there were some corrupted pathways in the first run, nothing in the system folders.

For context, I upgraded my machine to a Samsung Evo SSD in February, so I doubt this is a hardware issue, but the disk image has been migrated once before. Apologies for not mentioning that in the first post.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users