Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can't Access Certain Secure Sites


  • Please log in to reply
No replies to this topic

#1 ambo549

ambo549

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:03:37 AM

Posted 30 May 2017 - 03:24 AM

HI, I'm hoping someone can help me with this, I'm pretty dumb when it comes to networking issues and I'm not sure what forum this falls under. But the issue I'm having is that certain secure sites will give me the "Secure Connection Failed" error. But it's not all secure sites, for example I can check my email at gmail but not at hotmail, I have two bank accounts, I can sign in to US Bank but not PNC, I tried booking airline tickets at Frontier but it won't go beyond the landing page, however it does fine on my phone if turn the wifi off. And this has been happening over a bunch of different sites, some secure pages load while others absolutely will not and they consistently will not (like no matter how many times I try to load hotmail it will not go).

 

So I've tried Firefox, Chrome, I even resorted to IE and the sites  that don't load won't load on any of these browsers, which leads me to believe it's more of a network error of some sort. On my phone, if wifi is on these sites will not load but if I turn wifi off and just use phone data they work just fine. I also have a VPN, when I turn it on the sites work fine, but I don't use the VPN often because my internet is so much slower with it. I'm more interested in finding out why these pages won't open on my standard internet. 

 

Any help would be greatly appreciated. Thanks!



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users