Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

SSD Problem?


  • Please log in to reply
5 replies to this topic

#1 gman8901

gman8901

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:02:05 AM

Posted 25 May 2017 - 01:49 PM

Long time lurker, first time poster. I Want to thank everyone in advance who reads this, and especially anyone who comments. I know it's long, and that my technical savy leaves something to be desired. 

 

Anyway, I have an early 2011 Macbook Pro 13". Order from Apple with a 128GB SSD and 4GB (2 x 2GB) of Ram. About 3 years ago I bought 16GB (2 x 8GB) of Mac Ram from Crucial and swapped out the 4GB.

 

I was using my computer this past weekend, browsing the internet, when the computer suddenly locked up and froze completely, with no response from keyboard, mouse etc. for several minutes . To be fair, I am a bit of a tab hoarder, and had tons of stuff open. My SSD also is probably close to 100GB full. Anyway, I held down the power button and forced it to shut down.

 

I went to boot it back up, and the computer will not enter OSX. (It is running the latest version of OSX, Sierra). When I try to boot it up, it either hangs indefinitely at the loading bar indefinitely (which crawls by very slowly until getting stuck at the end), or gives me the famous grey question mark screen. 

 

I booted into Apple diagnostics (Holding Down D key while restarting) and ran test. The first test failed with a 4mem/60 error. I assumed this meant a bad stick of RAM. Subsequent extended tests with same RAM all passed. To be safe, I put in the 4GB of original ram and started the RMA process for the 16GB with crucial. 

 

The computer still will not boot! I've tried using one of the original 2GB sticks, first in the bottom, then in the top slot only, to see if I had a bad memory slot. This did not fix the problem.

 

The web based repair utility (Command + Option + R) console fails to locate any disks (just says Loading Disks forever), and the web based reinstall of OSX freezes as soon as I try to start it by pushing continue.

 

When I try to access the local repair partition (holding Command + R) nothing happens (computer tires to boot normally and gets stuck at the loading bar).

 

I was able to boot the computer using a Linux Mint Live USB key, and copy off some files I did not have backed up (insert headslap here). Computer ran fine off the USB key. I was able to use Nautilus to copy several documents and photos to a spare USB key) I at first had issues accessing the internal SSD from mint, but was able to run a repair which fixed a minor issue with the volume header (drive was in a non-zero state and couldn't be accessed, I'm guessing from the improper shutdown).

 

Could this be an SSD problem, easily solved by replacement (or not, since I could access it using Mint, but can't boot from it)? Or does it sound like a logic board issue? 

 

Normally, I's think that a computer that could boot a live USB key and run for hours properly only had a SSD issue, as issues with the RAM/logic board would have shown up. However, I was able to access and copy off files from the SSD, which open fine on another PC, which indicates the drive at least somewhat still works. Does that mean the drive is ok, or could it be too damaged to boot from but not completely non-functional.

 

Any ideas on what to try/how to properly diagnose? I believe the factory SSD from apple was made by Toshiba.

 

THANKS FOR YOUR HELP GUYS!!! I'm so lost. I don't want to buy a new SSD if that isn't the problem, and I have to seriously consider the value of the laptop if it needs a logic board repair.

 

 

 

 



BC AdBot (Login to Remove)

 


#2 smax013

smax013

  • BC Advisor
  • 2,329 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:01:05 AM

Posted 25 May 2017 - 02:21 PM

My first suspect would be the SSD based upon what you have said.

After using Linux Mint, have you tried using the Internet recovery option (i.e. Command-Option-R) to reinstall the macOS again? I ask because you mention that Linux Mint had issues first accessing the drive, but that you could after doing some sort of repair with it. It is possible that the repair might also allow the Internet recovery option to see the drive again.

The other thing to try would be booting into either Safe Mode (i.e. hold down Shift key while booting the Mac) or Single User mode (hold down Command-S while booting). Sometimes just booting into either of those modes can fix somethings. And here is a guide for repairing your drive using Single User mode (the guide is a bit old, so I am not 100% sure it will still apply with Sierra and an SSD...but the software suggestion in the comments of either Techtool Pro or Diskwarrior is still good):

http://www.everythingmacintosh.com/tech-notes/repair-your-hard-disk-in-single-user-mode/

#3 gman8901

gman8901
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:02:05 AM

Posted 25 May 2017 - 03:23 PM

Thank you so much for your reply smax013,

 

I did try to reinstall OSX after repairing the drive with Mint. No Dice.

I just tried now to boot the computer is safe mode. Same problem, long loading bar time followed by grey screen with question mark.

 

Following that, I tried single user mode. Computer seems to have frozen, here are the last dozen or so lines of text:

 

Got Book Device  = [long string of text followed by Macintosh HD]

BSD root disk1, major 1, minor 4

jnl: b(1, 4): replay_journal: from: 4492288 to: 4705792 (joffset 0x384000)

jnl: b(1, 4): journal replay done.

hfs: mounted Macintosh HD on device b(1, 4)

VM Swap Subsystem is ON

Failed to open swap file 30

Failed to open swap file 30

vm_swap_create_file failed @ 99 secs

Failed to open swap file 30

vm_swap_create_file failed @ 131 secs

Darwin Bootstrapper Version 4.0.0 Mon Feb 6 22:27:38 PST 2017; root:libxpc_executables-972.50.27~50/launchd/RELEASE_X86_64

boot-args = -s

Thu May 25 16:11:34 2017 com.apple.xpc.launchd[1] <Notice>: System Integrity Protection is engaged.

Thu May 35 16:11:35 2017 localhost com.apple.xpc.launchd[1] <Notice>: Entering single-user mode.

***Single-user boot ***

Root device is mounted read-only

Enabling and displaying services is not supported in single-user model,

and disabling services will not be respected when loading services

while in single-user mode.

To mount  the root device as read-write:

                $ /sbin/fsck -fy

                $ /sbin/mount -uw /

To boot the system:

                $ exit

localhost:/ root#

 

Its obviously waiting for my input. Any ideas what all that means?

 

EDIT: To be clear, I am continuing with the suggestions from the tutorial posted. I'm just wondering if the failed swapfile and major minor stuff is significant.

 

Thanks!


Edited by gman8901, 25 May 2017 - 03:28 PM.


#4 smax013

smax013

  • BC Advisor
  • 2,329 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:01:05 AM

Posted 25 May 2017 - 04:05 PM

Not really that familiar with Single User mode...never really had a reason to get familiar with it. So, I am not much help with it beyond what I previously suggested.

I guess my next thought would be to boot with the Linux Mint and wipe the SSD and then try the Internet recovery again to see if that changes anything. Of course, if you go that route, then any chance of recovery of what is on that drive diminishes if not effectively goes away when you wipe it (some data recovery software might still work or using a data recovery service assuming you want to spend the likely significant $$ on a reputable data recovery service...but if you this option works and you can reinstall the OS, then the old data becomes much less likely to be recovered).

The other main option is to buy a new drive and see if you can install the macOS on it using the Internet recovery option. Considering you can get a 128 GB SSD (same size as your current one) for less than $100, it is not hugely expensive in relative terms. And even if you eventually can get the old drive working again, you can still use one as a spare for emergency use...or using it as a backup drive once your get up and running (sorry, could not help myself :grinner:). And with this method, you could keep the old drive intact as it is to potentially try to recover more data files if the new drive works. But, then this option costs money while the first option does not (assuming the first option works...i.e. that the old drive is not beyond repair/use). The potential downside of this approach is if it is something other than the SSD being the problem, then buying a new SSD might be a bit of a waste. While you likely can find a use for it if it was the something more severe with the computer and had to get a new computer, you would not be able to use a new 2.5" SSD for that model Mac with a new Mac as they don't use 2.5" SSDs.

Which option to try of the two will depend on whether you want to spend money and whether you want/need to try to recover more files from the old drive.

FWIW, if it is NOT the SSD and something else with the computer, then you likely will not get much help from an Apple Store. That model is likely on the "obsolete" list and thus they likely will not repair it. They might not even evaluate it to help diagnose the problem, but they might. My 2009 17" MacBook Pro would not boot. I was 99.9% sure it was a motherboard issue, but want to try to get confirmation. I took it to the closest Apple Store about a year ago. The "Genius" told me that they no longer supported it and could not repair it, but was willing to take it back to do some checks...but had to get permission from the manager. He did more or less confirm it was the motherboard. I could have gotten a new motherboard (most likely used) from an Internet source, but it would have been like $600 to $800. Just was not worth it, especially consider I had gotten a new Retina MacBook Pro a year or so earlier. The point is that if it is something more "severe", then you will either need to take it to a third party repair shop or do the repair yourself...or just punt and get a new computer. Having said all that, I still suspect it is an issue with the SSD...either SSD being bad or maybe the file system being corrupted. If it is not the SSD, then it does not seem to be some sort of "global" motherboard issue since you could boot into Linux Mint and use it for a decent amount of time. Since it was a "live" boot using a USB key, it could be problems with the SATA chipset/interface on the motherboard. Regardless, I would rule out issues with the SSD first.

I suppose that does raise a third option to try. You could get a USB or Firewire 800 external enclosure (I would recommend the Firewire 800 enclosure over a USB 2.0 enclosure...or get one with both...Firewire 800 is faster...and all 2011 13" MBPs should have a Firewire 800 port). You then take the internal drive out of the MBP and put it in the enclosure. Then see if booting from it or restoring the macOS using the Internet recovery option works any better. This approach would work if it is some sort of issue with the SATA chipset/interface of the MBP.

The other cheaper option/variation to test the SATA chipset/interface would be to try booting from an optical disc since all 2011 13" MBPs should have an internal optical drive that is using a SATA connection. Depending on which 2011 model you have (i.e. whether the so-called "Early 2011" model or the "Late 2011" model), your MBP might have shipped with a recovery optical disc (this should be true of the Early 2011 models, I believe). If not, you should be able to at least create a Linux Live CD to try. You could also likely create a macOS recovery optical disc yourself, but it would require the use of another Mac...I am not sure if you can do that with Sierra, so it might matter which older versions of the macOS you have access to.

The other other option to test the SATA chipset/interface would be to take out the optical drive and install the SSD using the optical drive's SATA connection. There are two downsides to this approach, however. The first is that it would cost money as you would need to purchase an adapter that allows you to put the SSD in the optical drive spot. They tend to cost about $30 or so. The other issue is that it is more "significant" surgery on the inside of the Mac than just pulling the old drive and putting in a new drive.

#5 Buddyme2

Buddyme2

  • Members
  • 693 posts
  • OFFLINE
  •  
  • Local time:10:05 PM

Posted 26 May 2017 - 02:14 AM

Typing in /sbin/fsck -fy then hitting the enter/return key will try and repair your hard drive. It's worth a try IMO. Afterwards, typing in exit then hitting return key will restart your Mac, hopefully from the startup disk.

If it doesn't work then DiskWarrior may repair the hard drive. A bit expensive but worth every penny spent on it.



#6 Genex17

Genex17

  • Members
  • 80 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:05 PM

Posted 12 June 2017 - 11:40 PM

I purchased a mid 2012 Macbook Pro a few months ago and replaced the mechanical HDD with an SSD. A few weeks later I'm on vacation and noticed I was having a boot problem, namely a circle with a slash symbol before it finally booted up.

 

I have a utility called DriveDX which I bought long ago from the App store to diagnose my drives. I checked and it pointed out an increasing UDMA CRC Error count. That indicates a problem with the power supply or data cable when I clicked on the UDMA title. Sure enough some of those Mac data cables have problems.

 

https://forums.macrumors.com/threads/sata-cable-problem-in-macbook-pros.1616970/

 

I mail-ordered a new one from Amazon and replaced it. No more hanging and the UDMA count has not increased since.

 

I encourage you to look into it. A 00 Philips, a new cable with the sensor and you are in business. Just disconnect the battery before you replace it.

 

This is what I got: https://www.amazon.com/gp/product/B00MR8HZZ6/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users