Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


NIC not working after BIOS corruption (ASUS X202E)

  • Please log in to reply
1 reply to this topic

#1 Bummer_


  • Members
  • 6 posts
  • Local time:05:46 AM

Posted 22 May 2017 - 03:51 PM

Here is the situation:
I've tried a fresh install of Win10 on my X202E and after the installation finished computer went into "Wait for (something)" and stayed there forever. After an hour or so I've decided that enough is enough and I did a hard reset. After the reboot computer got into "Wait for (something)" again, got stuck there, and after some time I did a hard reset again. And then it didn't want to boot at all.
The LEDs would lite up, I could hear the HDD spinning but the monitor was off and then everything would go silent (LEDs still on).
Since the computer was unplugged during the installation I could be pretty sure that it's not a hardware damage but I had to figure out what's wrong. And a friend of mine suggested that it might be a corrupted BIOS. I've looked on-line, saw that I can buy a programmer (CH341A) for 5$, ordered one and (in the mean time) searched for the dump file for my computer so I can flash it once I have the programmer. Found the dump file, programmer arrived, unsoldered the BIOS (actually UEFI) chip and programmed it (saved the original dump).
And, voilà, I was up and running again.
There was only one problem. Network card (Atheros AR8162/8166/8168) was not recognized by the system (neither Win10 nor Ubuntu). I assumed that this is because the dump file was from another computer so I've flashed the original ASUS BIOS using WInFLASH. No changes. Thought that some of the other UEFI part might be the issue (GbE Region - but as far as I understand this is only if you have an Intel NIC. I can be completely wrong about it). Since the BIOS region is the only thing that got corrupt I've replaced all the parts except the BIOS from my saved dump file, but again no effect. Then I've compared my corrupted BIOS with the working one (with HxD) and I saw that a big number of lines got erased (turned to F's) so I've copied those lines from the working one to the corrupt one and managed to boot. Still no luck.
So, I'm asking the experts for help.
What could be the problem and what can I do to fix it?
Any advice is welcome.

P.S. Just for the clarification, when I say not recognized I don't mean that the device is seen as "Unknown", it's just not there (in the Device Manager or when I type lspci).


BC AdBot (Login to Remove)



#2 JohnC_21


  • Members
  • 22,093 posts
  • Gender:Male
  • Local time:11:46 PM

Posted 22 May 2017 - 04:56 PM

Does anything pop up in Device Manager if you select View > Show Hidden Devices? Outside of that if you want Ethernet a workaround would be to purchase a USB 3 Gigabit adapter. From the specs it says you have one USB 3 port.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users