Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Port 1433 failing to respond for MSSQL Server on Linux


  • Please log in to reply
3 replies to this topic

#1 TinoNgombo

TinoNgombo

  • Members
  • 80 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Luanda, Angola
  • Local time:12:04 PM

Posted 16 May 2017 - 05:37 AM

Hi all.

 

Got a project to migrate MSSQL Server production DBs running on Windows Server 2012 R2 to a CentOS 7 box.

 

I've already installed MSSQL Server for Linux and configured it accordingly. Now, port 1433 is failing to respond, even though I've configured it on the host side, i.e., the CentOS box.

 

Any ideas/suggestions? 
 

Thanks in advance :)



BC AdBot (Login to Remove)

 


#2 mremski

mremski

  • Members
  • 494 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:NH
  • Local time:07:04 AM

Posted 16 May 2017 - 03:32 PM

Define "failing to respond".

Do you have Iptables/firewalld running and blocking incoming requests to port 1433?

Have you done a netstat -anp | grep 1433 to verify that there is a listening socket on that port?

Have you tried connecting to that port on the same host the MSSQL server is running on? (that leads to firewall issues)

99% of the time this is issues with firewall not allowing inbound requests to the port (connecting on the same host or is firewall running tells us that).

0.5% of the time it's the listening port not bound to the exposed network interface. (netstat -anp command tells us that)

 

At this point you've basically said "My car won't start, tell me why?".  I'm trying to give you directions to information so we can help you.


FreeBSD since 3.3, only time I touch Windows is to fix my wife's computer


#3 TinoNgombo

TinoNgombo
  • Topic Starter

  • Members
  • 80 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Luanda, Angola
  • Local time:12:04 PM

Posted 17 May 2017 - 04:33 AM

Oops, so the way I've put my issue didn't make much sense, right? :D
By ''failing to respond'', I meant that it seemed that the port isn't listening... However, it's been listening ever since I added it to firewalld.

 

So, yes, firewalld is running; iptables is inactive right now.

 

I've done a netstat -anp | grep 1433 and it shows that it's listening; didn't try to connect to that port from the same host in which MSSQL is running, as you've mentioned that it leads to firewall issues...

 

That's basically it and thanks for the info so far. I'm still stuck, though...



#4 mremski

mremski

  • Members
  • 494 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:NH
  • Local time:07:04 AM

Posted 17 May 2017 - 05:07 AM

Ok, the netstat command shows something is listening, that's a good first step. 

next I'd make sure it's the mssql:

lsof -i4:1433  will show the process (the i4 means IPv4, do -i6 if you're using IPV6)

 

You could always try turning off firewalld to rule that out.  What I meant about trying to connect from the same host that you are running MSSQL server on:  If that works, it tells you that there is a problem with firewall rules.

 

"I meant that it seemed that the port isn't listening... However, it's been listening ever since I added it to firewalld."

How did you determine this?  By trying to ping the port, connect to it using a MSSQL client?  Portscan?

 

If you turn off firewalld, and you try connecting with your MSSQL client and it works, the problem lies somewhere with firewall rules.

If you try that and it doesn't work, I'd turn up logging on MSSQL server and client to see if that gives you any clues.  Could simply be a misconfiguration somewhere.


FreeBSD since 3.3, only time I touch Windows is to fix my wife's computer





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users