Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

System Restore Is Not Working


  • Please log in to reply
3 replies to this topic

#1 johnkromka

johnkromka

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:05:26 AM

Posted 14 May 2017 - 02:34 AM

I haven't used my System Restore in some time, however I tried using it tonight because I downloaded a registry script that was "supposed" to speed up my Windows 10, however it seems to have slowed down things.  So I ran the System Restore.  First thing I noticed that was odd was that there was only ONE restore point there and I have my disk usage for restore points set up quite high, so there should have been more than just one restore point and it was three days ago. Anyway, I ran the Restore and was expecting everything to go fine, but it did not.  I noticed it was not finishing in the usual 5-10 minutes.  I decided to let it run for a half hour but it would not finish.  It said "Please wait while your Windows files and settings are being restored...System Restore is initializing".  It stayed with exactly this wording the whole 30 minutes.  Then when I restarted the computer it said: "System Restore did not complete successfully.  Your computer files and settings were not changed."  Details: "The System Restore is still in progress and did not complete".   So I went looking all over Google for posts on fixing System Restore when it is not working right.  I tried MANY things.  I wish I kept a list of what I tried, but from memory I ran a scannow and it did say it found some corrupted files, but could not fix them all.  It said in one post to try a different restore point, but as I said I only had one, so could not do that.  I ran the hardware Troubleshooter, found nothing.  I went into Windows Services to make sure all the things associated with Restore were running and on automatic.  So now I come to the forum to try and get help to get the SR running right again.  Please give me some other things to try than what I mentioned here.  I didn't see this mentioned anywhere but is there any software I can download that might correct the situation?  Is there a 3rd party type of System Restore?(probably not)  As I said I am running Windows 10.  One guy said to go into my Local Group Policy Editor and I looked in vain for that...I don't see it on my system.  This is frustrating and I want the SR back.  Thanks for any help. (If this is not in the right forum, sorry, please redirect)



BC AdBot (Login to Remove)

 


#2 zainmax

zainmax

  • Banned
  • 344 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:26 PM

Posted 14 May 2017 - 02:59 AM

Your system works exactly as it should work, if there is no corrupted system files and if it is well maintained. In future, please do not use unknown scripts and any of suspicious recommendations.
The only thing that can help you right now, is here.
https://www.microsoft.com/en-us/software-download/windows10


#3 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,757 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:02:26 AM

Posted 14 May 2017 - 09:59 AM

Any time you make changes in the registry you should back it up first, there are three ways to easily do this.

 

1. Export the part of the registry which you are going to edit.  If there is a problem after the edit you can import the section of the registry you exported to restore this section.

 

2. Use a application like  Tweaking.com Registry Backup to backup the registry.  Follow the instructions in the video.

 


 

 

3. Create a Restore Point before editing the registry.  If there is a problem you can use this latest restore point to roll back the changes.

 

A question... After using the Command Prompt to run the rstrui.exe to open the System Restore did you click/tap in the box in the lower left portion of the screen for Show more restore points to see if there were other restore points?

 


 


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#4 britechguy

britechguy

    Been there, done that, got the T-shirt


  • Moderator
  • 9,359 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Staunton, VA
  • Local time:05:26 AM

Posted 14 May 2017 - 10:38 AM

dc3 asked, ". . . did you click/tap in the box in the lower left portion of the screen for Show more restore points to see if there were other restore points?"

 

This is one of the things that seems to throw many (including myself, initially) about how newer versions of system restore present restore points.  I really far preferred it when the full list of available restore points was presented in reverse chronological order but, alas, those days are gone.

 

If you've got System Restore turned on and are allowing Windows to manage the space you likely have more than one restore point as soon as the first set of Windows Updates have been applied, if not before.


Brian  AKA  Bri the Tech Guy (website in my user profile) - Windows 10 Home, 64-Bit, Version 1809, Build 17763 

     Presenting the willfully ignorant with facts is the very definition of casting pearls before swine.

             ~ Brian Vogel

 

 

 

              

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users