Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Keyboard changes character input from default to other pre OS boot


  • Please log in to reply
No replies to this topic

#1 JD-0021

JD-0021

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:58 PM

Posted 10 May 2017 - 04:09 AM

So was attempting to log into laptop when the keyboard all of a sudden decided to start shooting out three characters instead of the correct chosen character. Plugged in alternate keyboard and it worked. At least the main keys worked. Signed in. Checked drivers. Several other device drivers non related to keyboard uninstalled. Night before performed full tune up of pc. Drivers and all. So i thought this strange. So my guess for culprit to problem is another user changed settings.
Disabled and reinabled keyboard in device manager. Checked driver updated. No change.
Applied general system updates.
Ran several antivirus. Ran ccleaner to scan for registry errors.
Restarted computer.
Entered bios to check for any possible solution. Keyboard not working properly even in bios.
Got to security tab and attempted to down arrow down to the input/output port lock/ unlock selection. But the down arrow changed its value to not only down but also select value. So I'm attempting to scroll down and its selecting everything on the way down. So reached admin password and was able to select no pw. Then hdd password and in the process of trying to scroll down created a hdd pw as down arrow.
Finally made it out of bios and began boot. Entered hdd password and it worked. Got to windows login and keyboard was still acting up entering random characters for my input. Used alternate keyboard to log in.
Checked a few more things. Disabled keyboard. Reinabled. Shut down. Left for food. Came back powered on and hd password inaccessible. Cant press down button anymore on hd password entry. So now locked out of computer completely. Pulled drive used a hd dock at work. I'm a tech. And my OS sees drive in device manager and in disk management. However file explorer sees nothing.
Dusk management keeps prompting me to initialize disk. Which I think will completely erase data.
I would like to back up my data on drive then wipe and reinstall OS.
I also tore down laptop and found no cmos chip or jumper to reset bios.
Dont know what to do. Please help

Edited by JD-0021, 10 May 2017 - 04:34 AM.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users