Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Using Test Disk for WD MyBook 4tb 2nd look please


  • Please log in to reply
30 replies to this topic

#1 Lynkdev

Lynkdev

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:02:37 PM

Posted 02 May 2017 - 01:19 AM

My WD 4tb crashed on me months ago and wasnt recognized by device manger anymore. Tried replacing the USB PCB with identical one off ebay with same encryption and still wasnt recognized. 

 

I was recommended to try out Test Disk, and to be honest have limited experience with HD structure, partitions etc. 

 

Test Disk will not find the HD using the PCB so i connected directly up to PC with sata cable and it was found. 

 

After opening the application and clicking intel, and then analyse..it displayed the first partition twice which shows to be a corrupt partition or invalid table entry. 

 

I then ran a quick search and it displayed a primary bootable partition in green with [MyBook] at the end of the name. 

 

using the "p" entry, i was able to see the folders and files im trying to get back (crosses fingers)

 

__________________________________________________________________________________

 

I'm running a deep search right now which is at 16% (4TB) for the suspected missing partition (correct) ?

 

Once this search is complete and new partition(s) are found, i use the "p" command to verify which one to leave as deleted (damaged) and the other will hopefully list my files (correct)? 

 

     - I change the working one from D to L 

 

then hit write?

 

After this i follow the instructions for boot sector recovery here http://www.cgsecurity.org/wiki/TestDisk_Step_By_Step 

 

and my disk should be fixed?

 

 

Thanks for any help.


Edited by hamluis, 05 May 2017 - 12:08 PM.
Moved from External Hardware to Backup/Imaging - Hamluis.


BC AdBot (Login to Remove)

 


#2 SleepyDude

SleepyDude

  • Malware Response Team
  • 3,083 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:01:37 AM

Posted 02 May 2017 - 03:51 AM

Hi,

 

I think you don't need to run a Deep Search only when "A partition is still missing: Deeper Search" because the quick search found the partition and you could see the files you are looking for.


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#3 Lynkdev

Lynkdev
  • Topic Starter

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:02:37 PM

Posted 02 May 2017 - 11:25 AM

Hi,

 

I think you don't need to run a Deep Search only when "A partition is still missing: Deeper Search" because the quick search found the partition and you could see the files you are looking for.

 

Ok, yea i woke up this morning after the deep search finished and it looks like it didn't find anything. Where do i go from here?



#4 Lynkdev

Lynkdev
  • Topic Starter

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:02:37 PM

Posted 02 May 2017 - 12:01 PM

Do I use the write function on the partition found under quick search?

#5 SleepyDude

SleepyDude

  • Malware Response Team
  • 3,083 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:01:37 AM

Posted 02 May 2017 - 12:20 PM

Do I use the write function on the partition found under quick search?

 

Yes, highlight the partition and press p to confirm it list your files then write the partition layout.


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#6 Lynkdev

Lynkdev
  • Topic Starter

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:02:37 PM

Posted 02 May 2017 - 12:45 PM

 

Do I use the write function on the partition found under quick search?

 

Yes, highlight the partition and press p to confirm it list your files then write the partition layout.

 

 

Ok copy thanks. 

 

Do i still have to do a boot sector recovery after these steps?



#7 SleepyDude

SleepyDude

  • Malware Response Team
  • 3,083 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:01:37 AM

Posted 02 May 2017 - 01:03 PM

I don't think so.


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#8 Lynkdev

Lynkdev
  • Topic Starter

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:02:37 PM

Posted 02 May 2017 - 01:30 PM

copy thanks for the help. Will report back tonight once i perform these actions. (fingers crossed)



#9 Lynkdev

Lynkdev
  • Topic Starter

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:02:37 PM

Posted 03 May 2017 - 03:13 AM

So i wrote the partition it found under quick search and rebooted machine. No change but my files are still there. Now after analysing im seeing this, what do i do now please?

 

Boot sector recovery?

 

Looks like its showing two primary bootable partitions that are identical. 

Attached Files


Edited by Lynkdev, 03 May 2017 - 03:17 AM.


#10 SleepyDude

SleepyDude

  • Malware Response Team
  • 3,083 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:01:37 AM

Posted 03 May 2017 - 03:35 AM

So i wrote the partition it found under quick search and rebooted machine. No change but my files are still there. Now after analysing im seeing this, what do i do now please?

 

Boot sector recovery?

 

Yes try that now it says the boot sector is invalid.


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#11 Lynkdev

Lynkdev
  • Topic Starter

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:02:37 PM

Posted 03 May 2017 - 04:01 AM

 

So i wrote the partition it found under quick search and rebooted machine. No change but my files are still there. Now after analysing im seeing this, what do i do now please?

 

Boot sector recovery?

 

Yes try that now it says the boot sector is invalid.

 

 

 

Ok thanks, i did that and now the drive is accessible but only showing a total size of 2tb and not 4tb. Disk management shows the other half as unallocated. Could this unallocated space be holding some files as well? It looks like most or all of my pics are back. 



#12 SleepyDude

SleepyDude

  • Malware Response Team
  • 3,083 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:01:37 AM

Posted 03 May 2017 - 04:49 AM

Ok thanks, i did that and now the drive is accessible but only showing a total size of 2tb and not 4tb. Disk management shows the other half as unallocated. Could this unallocated space be holding some files as well? It looks like most or all of my pics are back. 

 

 

Yes it could depending on the amount of data stored on the HDD. Do you know if the HDD was formatted to use the all 4GB?


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#13 Lynkdev

Lynkdev
  • Topic Starter

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:02:37 PM

Posted 03 May 2017 - 12:00 PM

It was originally formatted to use all 4tb yes.

#14 SleepyDude

SleepyDude

  • Malware Response Team
  • 3,083 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:01:37 AM

Posted 03 May 2017 - 04:29 PM

Hi,

 

Sorry don't know why Testdisk record only a 2TB partition!

 

In the screenshot you post it complains about the bytes for sector maybe its because of that.

 

If the disk has more data than the one now visible maybe you need to try another recovery software.


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#15 Lynkdev

Lynkdev
  • Topic Starter

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:02:37 PM

Posted 03 May 2017 - 05:44 PM

Hi,

 

Sorry don't know why Testdisk record only a 2TB partition!

 

In the screenshot you post it complains about the bytes for sector maybe its because of that.

 

If the disk has more data than the one now visible maybe you need to try another recovery software.

 

Np, ill try to see if i can fix it unless anyone else has ideas. 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users